Subject: [16NG] Comments on Transmission of IPv4 packets over IEEE 802.16's IP CS draft

From: <[email-masked]>
Date: Mon, 25 Feb 2008 13:56:47 +0530

Hi,
 
Please find some of my comments/clarification sought on the draft.
 
-------------
1. Section 1: 
 
  This document specifies a method for encapsulating and transmitting
   IPv4 [2] and Address Resolution Protocol (ARP) packets over IP CS of
   IEEE 802.16. 
 
  Comment:
     The document does talk about encapsulation of IPv4 packets but not
of ARP packets.
     Is something missing?
 
2. Section 3:
 
  At least one L2 tunnel is required for each MS, so that IP packets can
   be sent to MSs before they acquire IP addresses.
 
  Comment:
    My understanding is that "atleast" signify if the MS has more than
one service flows , there
    will be seperate tunnels with different CIDs for a single MS.
    Can the sentence be rephrased to indicate this.
 
3. Section 3:
 
    The diagram does not support the statement that there will be
multiple L2 Tunnel. 
    Multiple L2 tunnels should be shown carrying CID1....CIDn
 
4. Section 5:
 
    Comment:
    The rational behind MTU being 1440 is not provided. Its mentioned
that it should be
     less than 1500, but not why it should be 1440 and not 1430?
 
     The correct rational to reach 1440 shall be provided or some
reference to be given
 
5. Section 6:
     In case DHCP server does not reside in AR, the
    AR SHOULD implement DHCP relay Agent [6].

    Comment: 
    AR can also implement a DHCP Proxy.
    The statement should read
    "In case DHCP server does not reside in AR, the
    AR SHOULD implement DHCP relay Agent /DHCP Proxy"
    
    The reference is also incorrect. It should be [5] instead of [6]
 
regards,
Keshav
 
_______________________________________________
16NG mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/16ng

---

From: "Samita Chakrabarti" <[email-masked]>
Date: Mon, 25 Feb 2008 12:44:17 -0800

Hi Keshav,

2. Section 3:

  Comment:

    My understanding is that "atleast" signify if the MS has more than one
service flows , there

 

 [SC>]  There is a single point-to-point link between a MS and the AR. If we
follow Wimax forum's architecture, then there is a GRE tunnel ( for a MS)
between a BS and the AS_GW over R6 interface. This GRE tunnel is mapped to
per MSID or per service flowID. But as far as IP-CS is concerned  the
corresponding IP-address is specific to the point-to-point link between MS
and AR. Thus service-flow mapping is out of scope at the IP-CS level.  In
the final revision of the draft, we will revisit section 3 for  more clarity
on IP-CS link between the MS and AR.

-Samita