Subject: [5gangip] identifier - locator addressing for connectivity on control plane

From: Marco Liebsch <[email-masked]>
Date: Thu, 11 May 2017 08:57:43 +0000

Not really addressed so far in the PS but I brought this some time ago into the discussion:

Address-based Identifier - locator separation may be useful as connectivity-enabler also on the control plane.
Currently control plane functions may use DNS to resolve a peer's IP address which is treated
as routable address.
Moving the control plane towards cloud, virtualized network functions (vNF) may split into multiple
components whose location may change, e.g. due to migration, scaling, etc.
Another case is 3GPP's current move to provide a service-based architecture to provide connectivity
between control plane vNFs; as alternative to the point-to-point model.
DNS may be seen as first-level resolver of a namespace into an IP address, which is treated as identifier.
The transport/service-based architecture can treat this identifier as routable or apply address-rewrite
as we currently discuss for device mobility to enable and maintain connectivity between two vNF peers.

Let me know any comments and if this seems interesting to the group.

marco

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 16 May 2017 19:40:24 -0500

Hi Marco,

Thanks for your mail.
My comments inline.

On Thu, May 11, 2017 at 3:57 AM, Marco Liebsch <[email-masked]>
wrote:

> Address-based Identifier – locator separation may be useful as
> connectivity-enabler also on the control plane.
>
> Currently control plane functions may use DNS to resolve a peer’s IP
> address which is treated
> as routable address.
>
> Another case is 3GPP’s current move to provide a service-based
> architecture to provide connectivity
> between control plane vNFs;
>

Like AMF and SMF that we have in the PS draft?

> as alternative to the point-to-point model.
>

This point I don't understand.

> connectivity between two vNF peers.
Base ILA can be used in this case as we are talking about cloud execution
and no requirement to use system assigned prefix to the UE type of
addressing?

So the goal here is to cope with vNF mobility.
Can you clarify these?
I encourage you to write a draft, it could be very useful.

Regards,

Behcet

> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip
>
>

---

From: Marco Liebsch <[email-masked]>
Date: Wed, 17 May 2017 15:33:28 +0000

Hi Behcet,

feedback inline [ml].

From: Behcet Sarikaya [mailto:[email-masked]]
Sent: Mittwoch, 17. Mai 2017 02:40
To: Marco Liebsch
Cc: [email-masked]
Subject: Re: [5gangip] identifier - locator addressing for connectivity on control plane

Hi Marco,

Thanks for your mail.
My comments inline.

On Thu, May 11, 2017 at 3:57 AM, Marco Liebsch <[email-masked]<mailto:[email-masked]>> wrote:
Not really addressed so far in the PS but I brought this some time ago into the discussion:

Address-based Identifier – locator separation may be useful as connectivity-enabler also on the control plane.
Currently control plane functions may use DNS to resolve a peer’s IP address which is treated
as routable address.
Moving the control plane towards cloud, virtualized network functions (vNF) may split into multiple
components whose location may change, e.g. due to migration, scaling, etc.
Another case is 3GPP’s current move to provide a service-based architecture to provide connectivity
between control plane vNFs;

[ml] yes.

[ml] this means the reference point representation. AMF and SMF are connected by a line, which is today realized by a
dedicated protocol running in between protocol endpoints, which are addressed using IP. In a service-based approach
AMF could send a message to an SMF without using the actual IP address of the SMF.

Base ILA can be used in this case as we are talking about cloud execution and no requirement to use system assigned prefix to the UE type of addressing?

[ml] it’s included but more general about the vNF1 identifying a vNF2 to talk to, e.g. using an IP address, but the underlying platform
treats identifier and locator addresses differently and may re-write that IP address used by the vNF1 to route the message to the right
location of a selected vNF2 that takes the request/message. Very flexible to enable transparent load balancers and support for
scaling, vNF pooling, failure handling, etc.

marco

Can you clarify these?

Regards,

Behcet

marco

_______________________________________________
5gangip mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/5gangip

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 17 May 2017 20:05:24 -0500

Hi Marco,

Pls see inline.

On Wed, May 17, 2017 at 10:33 AM, Marco Liebsch <[email-masked]>
wrote:

> Hi Behcet,
>
>
>
> feedback inline [ml].
>
>
>
> *From:* Behcet Sarikaya [mailto:[email-masked]]
> *Sent:* Mittwoch, 17. Mai 2017 02:40
> *To:* Marco Liebsch
> *Cc:* [email-masked]
> *Subject:* Re: [5gangip] identifier - locator addressing for connectivity
> on control plane
>
>
>
> Hi Marco,
>
>
>
> Thanks for your mail.
>
> My comments inline.
>
>
>
>
>
> [ml] this means the reference point representation. AMF and SMF are
> connected by a line, which is today realized by a
> dedicated protocol running in between protocol endpoints, which are
> addressed using IP.
>

> In a service-based approach

> [ml] it’s included but more general about the vNF1 identifying a vNF2 to
> talk to, e.g. using an IP address, but the underlying platform
> treats identifier and locator addresses differently and may re-write that
> IP address used by the vNF1 to route the message to the right
> location of a selected vNF2 that takes the request/message.
>

Sounds good but I wonder how universal this (ILA type of communication) is.
You seem to assume that it is true in virtualization world. However there
are other types like VXLAN which are very different and you may not find
what you want there.
So your assumption may lead us to the generalization of a certain solution
in  virtualization.

> Very flexible to enable transparent load balancers and support for

Before we go these "advanced" aspects we need to understand and agree on
the basics of your proposal.

Behcet

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 26 May 2017 10:51:17 -0500

Hi Tom,

What do you think about Marco's idea? It seems like he is proposing a
"revolutionary" use case for ILA in 5G IP?

Behcet

On Wed, May 17, 2017 at 8:05 PM, Behcet Sarikaya <[email-masked]>
wrote:

>> *Subject:* Re: [5gangip] identifier - locator addressing for
>> connectivity on control plane
>>
>>
>>
>> Hi Marco,
>>
>>
>>
>> Thanks for your mail.
>>
>> My comments inline.
>>
>>
>>
>>
>>
> Sounds good but I wonder how universal this (ILA type of communication)
> is. You seem to assume that it is true in virtualization world. However
> there are other types like VXLAN which are very different and you may not
> find what you want there.