Subject: Re: [6lowpan] 6LoWPAN-ND - Use of node registration should be optional

From: Erik Nordmark <[email-masked]>
Date: Sat, 13 Feb 2010 15:15:19 -0800

On 01/27/10 06:19 AM, Zach Shelby wrote:

> The -08 version no longer differentiates Edge Routers and Routers
> when it comes to registration. Instead, the NR/NC exchange is only
> made link-locally between a node and the router its default router.
> That router may be an Edge Router. There is no longer the concept of
> an Extended LoWPAN or Whiteboard in this draft, and NR messages are
> not relayed.
>
> Yes, this Node Registration must be performed for a node to use a
> router. This is important because that message exchange builds up the
> necessary information on both sides for address resolution,
> unreachability detection and for a node to check that its address is
> unique.

I agree that a registration is required for hosts so that the routing 
protocol on the routers know which hosts are attached.

But I don't see any logic in -08 which ensures that an IPv6 address 
based on the short addresses is unique across the lowpan. The NR/NC is 
local. Thus with this approach it isn't possible to support short addresses.

Perhaps we need a separate mechanism to allocate and/or ensure 
uniqueness of short addresses?

While there isn't a need for any ER as used in earlier versions, we do 
need some notion of the prefix originating router(s). By this I mean 
that one or more routers will originate the prefix or prefixes used in 
the lowpan. In the case of a lowpan attached to a wire it seems natural 
that the router(s) that attach to the wire would do this. That is the 
same location as what we previously called edge routers.

    Erik

---

From: Zach Shelby <[email-masked]>
Date: Mon, 15 Feb 2010 12:14:11 +0200

Hi Erik,

On Feb 14, 2010, at 1:15 , Erik Nordmark wrote:

> I agree that a registration is required for hosts so that the routing protocol on the routers know which hosts are attached.

The registration is also needed to bootstrap new routers to a LoWPAN. After that we can consider their bindings refreshed with e.g. routing signaling.  

> 
> But I don't see any logic in -08 which ensures that an IPv6 address based on the short addresses is unique across the lowpan. The NR/NC is local. Thus with this approach it isn't possible to support short addresses.
> 
> Perhaps we need a separate mechanism to allocate and/or ensure uniqueness of short addresses?

Correct, this is the aim of the split in a way. The draft currently says that address allocation and/or duplicate address detection are to be performed by the router after receiving the NR message when appropriate.  But those mechanisms are not defined in this draft.

Address allocation could be performed using DHCPv6. Another alternative will be the Extended LoWPAN draft (to be written), which would extend the registration to an Edge Router. 

The thing I found hard writing the text, was how to define the situations when duplicate detection SHOULD or MUST be performed... so plenty of comments needed on Section 5.3...

> 
> While there isn't a need for any ER as used in earlier versions, we do need some notion of the prefix originating router(s). By this I mean that one or more routers will originate the prefix or prefixes used in the lowpan. In the case of a lowpan attached to a wire it seems natural that the router(s) that attach to the wire would do this. That is the same location as what we previously called edge routers.

Right, I think we should actually keep the ER term for the purpose of prefix origination in this draft. So the ER concept now is just a router attached to the wire, from which prefixes originate. How does that sound?

Thanks,
Zach  

> 
>   Erik
> 
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan

-- 
http://www.sensinode.com
http://zachshelby.org - My blog "On the Internet of Things"
http://6lowpan.net - New book - "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

Zach Shelby
Head of Research
Sensinode Ltd.
Kidekuja 2
88610 Vuokatti, FINLAND

This e-mail and all attached material are confidential and may contain legally privileged information. If you are not the intended recipient, please contact the sender and delete the e-mail from your system without producing, distributing or retaining copies thereof.