Subject: [6lowpan] Question of the week: ND-09 status

From: Carsten Bormann <[email-masked]>
Date: Mon, 10 May 2010 14:12:42 +0200

>> I've not seen a consensus to rewrite ND from 08 to what it is
>> today. I've seen Geoff at the mike in favor, and you saying don't worry
>> I'll work with the author of ND simple and sort that out. Hardly a
>> consensus to me.
> 
> WG direction is an issue for the chairs... 

Well, no, this is an issue for the WG.

There was some vocal opposition to the complexity of ND-08.  Since I was a co-author of ND-08, I wasn't in a position to judge consensus as a WG chair, but if I had been, I would have said very, very rough consensus at best.

I didn't co-author ND-09.  I do think personally that ND-09 is in reasonable shape, and I haven't heard strong technical arguments against it.  With the exception of Pascal, all ND-08 authors seem to like it (even though each of us probably would do some little thing in a different way).  But, very importantly, this is not a paste-over-the-disagreements compromise solution: It is a solid redesign based on some evolved assumptions on what the base 6LoWPAN-ND protocol has to do and what not.

Now my questions to the WG:

1) Are these evolved assumptions correct?

The most important change is that the assumption is now that we can fully rely*) on the uniqueness of EUI-64 identifiers.

Another assumption is that staying as close to the formats of RFC 4861 as possible is a good thing.

2) Is the protocol defined in ND-09 successfully solving the problem?

If the above assumptions are correct, is ND-09 the right protocol?  Does it work?

If you think that additional functions such as backbone router, or possibly using DHCP servers for certain configuration functions, are needed: can these be added as separate documents**), with hosts implementing just ND-09 still working correctly?

3) Is the document that is ND-09 good enough?

Does it define the protocol unambiguously?
Is the terminology acceptable?

I would like the WG to make some progress on these questions this week.
Please speak up.

Gruesse, Carsten

*) [From my personal point of view, this is mainly burden-shifting to the commissioning/security process, but it is not unreasonable to do so.]

**) [Yes, it would be nice to have these documents, to make sure we understand fully how they fit together with ND.  But I don't think we have to wait for all of them.]

---

From: "Don Sturek" <[email-masked]>
Date: Mon, 10 May 2010 06:34:21 -0700

I agree completely with Carsten on this.  It is NOT up to the WG chairs to
determine direction or consensus.  It is up to the WG.

I am in favor of ND-09.  We should have some implementation experience
shortly but it does appear to address the stated issues to ND-08 and appears
to be a solid basis for 6LowPAN ND.

Don

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Carsten Bormann
Sent: Monday, May 10, 2010 5:13 AM
To: [email-masked]
Subject: [6lowpan] Question of the week: ND-09 status

There was some vocal opposition to the complexity of ND-08.  Since I was a
co-author of ND-08, I wasn't in a position to judge consensus as a WG chair,
but if I had been, I would have said very, very rough consensus at best.

I didn't co-author ND-09.  I do think personally that ND-09 is in reasonable
shape, and I haven't heard strong technical arguments against it.  With the
exception of Pascal, all ND-08 authors seem to like it (even though each of
us probably would do some little thing in a different way).  But, very
importantly, this is not a paste-over-the-disagreements compromise solution:
It is a solid redesign based on some evolved assumptions on what the base
6LoWPAN-ND protocol has to do and what not.

The most important change is that the assumption is now that we can fully
rely*) on the uniqueness of EUI-64 identifiers.

Another assumption is that staying as close to the formats of RFC 4861 as
possible is a good thing.

If the above assumptions are correct, is ND-09 the right protocol?  Does it
work?

If you think that additional functions such as backbone router, or possibly
using DHCP servers for certain configuration functions, are needed: can
these be added as separate documents**), with hosts implementing just ND-09
still working correctly?

Gruesse, Carsten

*) [From my personal point of view, this is mainly burden-shifting to the
commissioning/security process, but it is not unreasonable to do so.]

**) [Yes, it would be nice to have these documents, to make sure we
understand fully how they fit together with ND.  But I don't think we have
to wait for all of them.]

_______________________________________________
6lowpan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lowpan