Subject: [6lowpan] hc-11

From: "Reddy, Joseph" <[email-masked]>
Date: Thu, 9 Sep 2010 09:24:17 -0500

Hi Jonathan

I have a question on recent text changes in the HC draft

If I look at the text in 3.1.1 for the SAM=10 case, the text is different depending on whether SAC=0 or SAC=1. The SAC=0 explicitly calls out how to create the trailing 64bits while the SAC=1 does not (  I think the draft intends that the text in 3.2.2 should apply in this case but that is slightly confusing as that text refers to 16bit link layer address and not the inline fields )

Can you confirm that the actual behaviour ( i.e., how the 64 trailing bits are constructed ) is the same is both cases and the text difference is only editorial ? Would it make it clearer if the SAC=1 case has the similar text as SAC=0 ( "... 64 bits are 0000:00ff:fe00:XXXX, where XXXX are the 16 bits carried in-line." ). Same for destination addresses.. 

-Regards, Joseph

---

From: Jonathan Hui <[email-masked]>
Date: Tue, 14 Sep 2010 08:04:08 -0700

Hi Joseph,

> Can you confirm that the actual behaviour ( i.e., how the 64 trailing bits are constructed ) is the same is both cases and the text difference is only editorial ? Would it make it clearer if the SA…

Yes, the intent is to have the same behavior for any bits not covered by the prefix.  The wording does need to be slightly different since the prefix information has variable length.  How do you feel about the following addition to those cases?

"Any bits of the IID not covered by context information are taken directly from their corresponding bits in the 16-bit to IID mapping given by 0000:00ff:fe00:XXXX, where XXXX are the 16 bits carried in-line."

--
Jonathan Hui