Subject: [6lowpan] Fwd: New Version Notification for draft-ietf-6lowpan-hc-13

From: Jonathan Hui <[email-masked]>
Date: Mon, 27 Sep 2010 14:34:36 -0700

Added text to specify that addressing bits not covered by the context or IID are set to zero.

--
Jonathan Hui

Begin forwarded message:

> From: IETF I-D Submission Tool <[email-masked]>
> Date: September 27, 2010 2:33:08 PM PDT
> To: [email-masked]
> Cc: [email-masked]
> Subject: New Version Notification for draft-ietf-6lowpan-hc-13 
> 
> 
> A new version of I-D, draft-ietf-6lowpan-hc-13.txt has been successfully submitted by Jonathan Hui and posted to the IETF repository.
> 
> Filename:	 draft-ietf-6lowpan-hc
> Revision:	 13
> Title:		 Compression Format for IPv6 Datagrams in 6LoWPAN Networks
> Creation_date:	 2010-09-27
> WG ID:		 6lowpan
> Number_of_pages: 23
> 
> Abstract:
> This document specifies an IPv6 header compression format for IPv6
> packet delivery in 6LoWPAN networks.  The compression format relies
> on shared context to allow compression of arbitrary prefixes.  How
> the information is maintained in that shared context is out of scope.
> This document specifies compression of multicast addresses and a
> framework for compressing next headers.  UDP header compression is
> specified within this framework.
> 
> 
> 
> The IETF Secretariat.
> 
>

---

From: "Samita Chakrabarti" <[email-masked]>
Date: Mon, 27 Sep 2010 17:08:45 -0700

Hi Jonathan,

This request is for next update/revision whenever possible. Sorry for the
late response.

It'd be very useful if this document provides an example section of
encoding/decoding of link-local, global and multicast addressed IPv6 header
in stateless and stateful mode.

For example, I had to read a few times to look for the behavior of
context-based compression methods for unicast in the document as it is
hiding in the field definitions of SAC and DAC.

Section 3.2 has two subsections on stateless and stateful mcast address
compression - we should also have similar sub-sections for unicast cases for
clarity and understanding. 

Thanks,
-Samita

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Jonathan Hui
> Sent: Monday, September 27, 2010 2:35 PM
> To: [email-masked] 6lowpan
> Subject: [6lowpan] Fwd: New Version Notification for
draft-ietf-6lowpan-hc-
> 13
> 
> 
> Added text to specify that addressing bits not covered by the context or
IID
> are set to zero.
> > A new version of I-D, draft-ietf-6lowpan-hc-13.txt has been successfully
> submitted by Jonathan Hui and posted to the IETF repository.
> >
> > packet delivery in 6LoWPAN networks.  The compression format relies on
> > shared context to allow compression of arbitrary prefixes.  How the
> > information is maintained in that shared context is out of scope.
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 28 Sep 2010 10:01:43 +0200

Samita,

6lowpan-HC has passed working-group last call.

The next step is requesting IETF last call; of course, everybody in the IETF can put in comments in an IETF last-call.
Unequal coverage of the examples in a specification is a well-known cause for early interoperability issues, so I believe your observation would make an excellent comment.

Gruesse, Carsten