Subject: [6lowpan] RAVEN cygwin setup

From: <[email-masked]>
Date: Wed, 22 Sep 2010 16:25:42 -0700

This is my first post to this group, sorry if I didn't get it right. I just purchased the AVR Raven kit & dragon. I'm on WIN 7, 32-bit and not a linux or cygwin user. I'm following the install as shown on;

Running Contiki with uIPv6 and SICSlowpan support on Atmel RAVEN hardware

http://www.sics.se/~adam/contiki/docs-uipv6/a01107.html#annex_software

<<snip>>

Software setup details
Contiki
Download Contiki code from http://www.sics.se/contiki and extract the source code. We assume the directory you extract to is c:/contiki.
Cygwin

Download Cygwin from http://www.cygwin.com

Launch the setup executable

Follow the instructions until you reach the Window "Cygwin Setup - Select Packages"

In this window, expand the "Devel" item and ?????

...and what?

I assumed the MAKE is required and I enabled it. What else needs to be setup?

Just in case, I setup everything.

<<<<snip>>>>>

To compile each of them, type in Cygwin:

cd c:/contiki/examples/webserver-ipv6-raven
make TARGET=avr-raven webserver6.elf

Cygwin replies;

no rule to make target

Your suggestions are welcome.

Can this be built from AVR Studio 4?

My suggestion is to review this section and add some hints.

best,

spincraft

---

From: Joakim Eriksson <[email-masked]>
Date: Thu, 23 Sep 2010 08:34:02 +0200

Hello Don,

This is not the right list for Contiki-related emails, this is the
mailing list for the IETF 6lowpan working group. Please send your
Contiki-related questions to [email-masked]
instead.

Best regards,
-- Joakim Eriksson, SICS

[email-masked] skrev 2010-09-23 01:25:
> This is my first post to this group, sorry if I didn't get it right. I
> just purchased the AVR Raven kit & dragon. I'm on WIN 7, 32-bit and not
> a linux or cygwin user. I'm following the install as shown on;
> *Contiki*
> Download Contiki code from http://www.sics.se/contiki and extract the
> source code. We assume the directory you extract to is c:/contiki.
> *Cygwin*
>
>     * Download Cygwin from http://www.cygwin.com <http://www.cygwin.com/>
>     * Launch the setup executable
>     * Follow the instructions until you reach the Window "Cygwin Setup -
>       Select Packages"
>     * In this window, expand the "Devel" item and ?????
>
>> >>>>>>>>>>
> ...and what?
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan