Subject: [6lowpan] 6lowpan-hc and 802.15.4g

From: Zhen Cao <[email-masked]>
Date: Mon, 6 Sep 2010 23:00:21 +0800

Hi,

A question for 6lowpan used in 802.15.4g.

Since 15.4g has defined a MTU of 2047, is there still a need to use
6lowpan-hc there?

Thanks for discussion.

Regards,
Zhen

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 7 Sep 2010 09:34:32 +0200

> Since 15.4g has defined a MTU of 2047, is there still a need to use 6lowpan-hc there? 

I would very much think so.

While reducing fragmentation is an important motivator for 6lowpan-hc in 802.15.4 networks, the significant packet size reductions are useful in any constrained network, as every byte actually sent and received:

-- consumes power at both sender and receiver,
-- increases the packet transmission time and this makes it subject to additional bursts of interference, reducing delivery probability,
-- increases contention of the channel (which, in turn, also may cause interference).

With the large headers used by IPv6 and the small payloads expected for 6lowpan applications (e.g., CORE's CoAP protocol), the ~30-40 byte per packet savings will be worth it in these environments even if the hazards of MTU-related fragmentation are going away.

Gruesse, Carsten

---

From: Zhen Cao <[email-masked]>
Date: Tue, 7 Sep 2010 23:39:33 +0800

> With the large headers used by IPv6 and the small payloads expected for 6lowpan applications (e.g., CORE's CoAP protocol), the ~30-40 byte per packet savings will be worth it in these environments…

I remember that in RFC4944 it states the small MTU is the main
motivation for header compression.  The reasons you stated above are
reasonable only if the complexity incurred are considerable low.   I
agree that 6lowpan is not designed for a certain MAC/PHY, otherwise it
couldn't be used long since the MAC and PHY are evolving.

Thank you,
Zhen