Subject: Re: [6lowpan] Fwd: New Version Notification for draft-ietf-6lowpan-hc-10

From: Dario Tedeschi <[email-masked]>
Date: Wed, 01 Sep 2010 11:53:34 -0700

I think there is a small and potentially misleading mistake in the last 
paragraph of section 3.2.2 . Instead of:

    This mapping from a short IEEE 802.15.4 address to 64-bit IIDs is
    also used to reconstruct any part of an IID not covered by context
    information when only 16 bits are carried in-line*(SAC/DAC=10)*.

it should read:

    This mapping from a short IEEE 802.15.4 address to 64-bit IIDs is
    also used to reconstruct any part of an IID not covered by context
    information when only 16 bits are carried in-line*(SAM = 2 or DAM = 2)*.

Or would it not be simpler to just say:

    This mapping from a short IEEE 802.15.4 address to 64-bit IIDs is
    also used to reconstruct any part of an IID not covered by context
    information.

Dario

On 31/08/2010 2:56 PM, Jonathan Hui wrote:
> This revision takes into account comments raised during WGLC of 6lowpan-hc-09.
>
> Specifically:
> - Specify that the IID has the form 0000:00ff:fe00:XXXX when SAC/DAC=0 and SAM/DAM=10.
>
> --
> Jonathan Hui
>
> Begin forwarded message:
>
>> From: IETF I-D Submission Tool<[email-masked]>
>> Date: August 31, 2010 2:54:13 PM PDT
>> To: [email-masked]
>> Cc: [email-masked]
>> Subject: New Version Notification for draft-ietf-6lowpan-hc-10
>>
>>
>> A new version of I-D, draft-ietf-6lowpan-hc-10.txt has been successfully submitted by Jonathan Hui and posted to the IETF repository.
>>
>> Filename:	 draft-ietf-6lowpan-hc
>> Revision:	 10
>> Title:		 Compression Format for IPv6 Datagrams in 6LoWPAN Networks
>> Creation_date:	 2010-08-31
>> WG ID:		 6lowpan
>> Number_of_pages: 23
>>
>> Abstract:
>> This document specifies an IPv6 header compression format for IPv6
>> packet delivery in 6LoWPAN networks.  The compression format relies
>> on shared context to allow compression of arbitrary prefixes.  How
>> the information is maintained in that shared context is out of scope.
>> This document specifies compression of multicast addresses and a
>> framework for compressing next headers.  UDP header compression is
>> specified within this framework.
>>
>>
>>
>> The IETF Secretariat.
>>
>>
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan

---

From: Jonathan Hui <[email-masked]>
Date: Wed, 1 Sep 2010 12:05:34 -0700

Thanks for the catch.  I think we can call this an editorial mistake and continue with our goal of submitting hc-10 to IESG.  We will be sure to fix it during the editorial process that follows.

--
Jonathan Hui

On Sep 1, 2010, at 11:53 AM, Dario Tedeschi wrote:

> 
> I think there is a small and potentially misleading mistake in the last paragraph of section 3.2.2 . Instead of:
>    information when only 16 bits are carried in-line 
> (SAC/DAC=10).
> it should read:
>    information when only 16 bits are carried in-line 
> (SAM = 2 or DAM = 2).
>>> From: IETF I-D Submission Tool <[email-masked]>
>>> 
>>> To: 
>>> [email-masked]
>>> Cc: 
>>> [email-masked]