Subject: [6lowpan] 6lowpan blip simulation tool

From: amy wang <[email-masked]>
Date: Mon, 22 Nov 2010 22:04:32 +0800

hi, everyone

I want to do some simulation works of blip header compression, but I do not
know whether there is any existed simulation tool which can support blip.
Does anyone can give me help?  I want to simulate the node energy consume.

thanks very much.

amy
--

---

From: alessandro ludovici <[email-masked]>
Date: Mon, 22 Nov 2010 15:17:59 +0100

try TOSSIM (tinyos) but I am not sure it will works.
Other network simulator (omnet, ns-3) does not implements 6loWPAN. If you
know any solution please let me know.

I am interested in simulation to.

2010/11/22 amy wang <[email-masked]>

---

From: Ikram Ashraf <[email-masked]>
Date: Mon, 22 Nov 2010 16:23:49 +0200

Hi,

Try Cooja from Contiki it uses uIPv6 stack, but I guess it will not work 
with Berkeley Low-power IP stack (blip)

http://www.sics.se/~fros/cooja/cooja.pdf

Br,
Ikram

On 22/11/2010 16:17, alessandro ludovici wrote:
> Other network simulator (omnet, ns-3) does not implements 6loWPAN. If 
> you know any solution please let me know.
>
> 2010/11/22 amy wang <[email-masked] <mailto:[email-masked]>>
>
>     hi, everyone
>     I want to do some simulation works of blip header compression, but
>     I do not know whether there is any existed simulation tool which
>     can support blip.
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan

---

From: alessandro ludovici <[email-masked]>
Date: Mon, 22 Nov 2010 15:49:36 +0100

Does Avrora support 6LoWPAN?

2010/11/22 Urs Hunkeler <[email-masked]>

> Hi Amy,
>
> Avrora can simulate the power consumption of MicaZ nodes, so you should be
> able to simulate a 6lowPAN network running on MicaZ with Avrora and estimate
> its power consumption.
> http://compilers.cs.ucla.edu/avrora/
>
> I have never used Avrora or blip, but I would be interested in learning
> about the future of this project.
>
> Cheers,
> Urs
>
>
>
> On 11/22/2010 03:04 PM, amy wang wrote:
>
>> hi, everyone
>> I want to do some simulation works of blip header compression, but I do
>> not know whether there is any existed simulation tool which can support
>> blip.