Subject: [Ace] Fwd: New Version Notification for draft-porambage-core-ace-x509-00.txt

From: Corinna Schmitt <[email-masked]>
Date: Fri, 14 Feb 2014 16:02:19 +0100

Hallo together,

based on discussions in Vancouver and offline we created a new draft 
focusing on x.509 certificates for CoAP.
It is just a rudimentary version but will be improved soon.

We - the authors - look forward to your feedback.

Regards,
Pawani, Andrei, Steffi, and Corinna

-------- Original-Nachricht --------
Betreff: 	New Version Notification for draft-porambage-core-ace-x509-00.txt
Datum: 	Fri, 14 Feb 2014 06:58:35 -0800
Von: 	[email-masked]
An: 	Corinna Schmitt <[email-masked]>, Pawani Porambage 
<[email-masked]>, Corinna Schmitt <[email-masked]>, Andrei 
Gurtov <[email-masked]>, Stefanie Gerdes <[email-masked]>, Pawani 
Porambage <[email-masked]>, Andrei Gurtov <[email-masked]>, 
Stefanie Gerdes <[email-masked]>

A new version of I-D, draft-porambage-core-ace-x509-00.txt
has been successfully submitted by Corinna Schmitt and posted to the
IETF repository.

Name:		draft-porambage-core-ace-x509
Revision:	00
Title:		X.509 Public Key Infrastructure Certificates for the Constrained Application Protocol (CoAP)
Document date:	2014-02-14
Group:		Individual Submission
Pages:		7
URL:            http://www.ietf.org/internet-drafts/draft-porambage-core-ace-x509-00.txt
Status:         https://datatracker.ietf.org/doc/draft-porambage-core-ace-x509/
Htmlized:       http://tools.ietf.org/html/draft-porambage-core-ace-x509-00

Abstract:
    The Constrained Application Protocol (CoAP) is a web transfer
    protocol designed for resource limited nodes in constrained networks.
    For securing the protocol, CoAP defines a binding to Datagram
    Transport Layer Security (DTLS) with four security modes.  One of
    them is the Certificate mode where the device has an asymmetric key
    pair with an X.509 certificate.  However, the intrinsic properties of
    x.509 certificates impede the application on the resource constrained
    nodes.  This draft describes the necessary adjustments and derives a
    modified profile for X.509 certificates to cope with the resource
    limitations of low-power low-performing devices

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

--

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 14 Feb 2014 16:09:39 +0100

Hi Corinna,
Hi Pawani,

do the two of you see a chance to fill in some content for this document before London?
The submission reopens on Monday morning, March 3rd.
Based on the plan laid out in the abstract, I think this would also be good material for DICE.

Grüße, Carsten

---

From: Corinna Schmitt <[email-masked]>
Date: Fri, 14 Feb 2014 16:14:50 +0100

Dear Carsten,

we are working on it but cannot promise it for London yet.
If you have hint for us your are welcome!

DICE is also a good idea.
But due to discussion within BOF ACE preparation we currently prefer to 
mainly locate it in ACE.

Regards,
Corinna

Am 14.02.14 16:09, schrieb Carsten Bormann:
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace
>

--