Subject: [Ace] Wi-Fi Systems on a Chip

From: Margaret Wasserman <[email-masked]>
Date: Fri, 14 Mar 2014 09:11:00 -0400

Just so that people who haven't working in the low-end embedded space understand the sort of limitations that a low-end, low-power wi-fi system might have, I thought it might be useful for folks to see the specs of a few common SoCs (Systems on a Chip) and/or modules that are available today.  

http://www.gainspan.com/gs1011soc1
http://www.semiconductorstore.com/pages/asp/DownloadDirect.asp?sid=1394777188416
http://www.embeddedworks.net/wlan308.html?gclid=COeprveLkr0CFYt9Ogod6ncAug

[Note: in high volumes, these chips/modules might cost 10-20% of the low-volume prices indicated.]

I have no interest at all in these companies -- I'm not even using any of their products at the moment.  I just compiled this list from a quick web search for "low-power wi-fi SoC".  This doesn't represent a full survey of the market by any means -- these are just a few examples to give people an idea of the constraints we might be dealing with in a sensor, actuator or other battery-operated device.

Margaret

---

From: Ralph Droms <[email-masked]>
Date: Fri, 14 Mar 2014 09:24:19 -0400

Corresponding info for IEEE802.15.4:

http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=MC13224V&fsrch=1

http://store.redwirellc.com/collections/frontpage/products/m12-mc13224v-6lowpan-module

I'm working with a team at Purdue to implement a ZigBee-IP stack on an earlier, prototyping version of the 6LowPAN module.

- Ralph

PS Following up on Cartsen's slide from his WG presentation, if you added 30MB of disk (dual RK05 and a 3rd party fixed disk) and doubled the RAM, it would look pretty much like a PDP 11-34 running Sixth Edition UNIX.  The key is doubling the RAM.  We're finding it a little tough to wedge a full Z-IP stack into the 96KB of RAM on the mc13224v.  It can be done, as the Z-IP interop and cert tests have shown...

On Mar 14, 2014, at 9:11 AM 3/14/14, Margaret Wasserman <[email-masked]> wrote:

> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 14 Mar 2014 14:40:11 +0100

On 14 Mar 2014, at 14:24, Ralph Droms <[email-masked]> wrote:

> We're finding it a little tough to wedge a full Z-IP stack into the 96KB of RAM on the mc13224v. 

It may be worth pointing out that the MC13224V is a bit unusual due to its serial flash architecture:
At boot time, the program code is copied from the serial flash to the RAM, which is shared by both code and data.  

This differs sharply from most other SoCs in this space, which can execute right out of Flash, but only have 8-16 KiB (or 32 KiB if you are very lucky) RAM.

That’s why the LWIG terminology class table gives separate numbers for RAM and Code; on the MC13224V you could theoretically use 64 KiB for state data and 32 KiB for code, if that were useful in any way.  (Hey, you could even use an overlay linker, if someone here remembers what that is — the serial Flash is 128 KiB and WKdm style compression works reasonably well…)

Grüße, Carsten

---

From: Ralph Droms <[email-masked]>
Date: Fri, 14 Mar 2014 09:47:32 -0400

> At boot time, the program code is copied from the serial flash to the RAM, which is shared by both code and data.  

Right - to be precise, I should have described the MC13224V as having 96KB of program+data space.
> This differs sharply from most other SoCs in this space, which can execute right out of Flash, but only have 8-16 KiB (or 32 KiB if you are very lucky) RAM.

Even so, the 96KB is in the ballpark of the program+data space available on other SoCs.  And 8-16KB of data space can be limiting...
> That’s why the LWIG terminology class table gives separate numbers for RAM and Code; on the MC13224V you could theoretically use 64 KiB for state data and 32 KiB for code, if that were useful in an…

Yeah, we've thought about the overlay strategy.  It would take a pretty significant redesign of the code to gain much benefit.