Subject: [Ace] Webex Conference Call about "How to Select Hardware for IoT Systems?"

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 23 Aug 2014 14:24:51 +0200

Hi all,

Various groups in the IETF currently standardize technology for use with
constrained devices and the choice of hardware impacts the design of
Internet of Things (IoT) systems. To provide guidance RFC 7228
"Terminology for Constrained-Node Networks" defines three classes of
devices depending on their RAM and flash memory size. Class 0
characterizes devices that have less than 10 KiB of RAM and less than
100 KiB of flash memory and RFC 7228 adds "... most likely they will not
have the resources required to communicate directly with the Internet in
a secure manner." For others even class 2 with ~ 50 KiB of RAM and ~ 250
KiB of flash memory is too constrained.

With the increasing commercial interest in IoT the question about a
reasonable hardware configuration surfaces again and again. At IETF#90 I
offered to bring a hardware expert along. Peter Aldworth, a hardware
engineer with more than 19 years of experience, will lead the discussion
at an upcoming webinar.

Please indicate your availability here:
http://moreganize.com/bzTrVxhqaHp

Ciao
Hannes

---

From: Paul Lambert <[email-masked]>
Date: Thu, 28 Aug 2014 11:09:26 -0700

> KiB of flash memory is too constrained.
May or may not be able to attend call, but generally disagree with above statement.
Bluetooth, WI-Fi, Zigbee all have built in security and crypto hardware.  It’s not hard to provide cryptography.
Public key techniques are also possible in very constrained devices.  

There are also some low overhead symetric algorithms that take minimal processing and memory.

All that is needed is clear requirements and devices can be built.

However … TLS, DTLS and X.509 are a bad path (IMHO).  These have been verburdened with cruft from years of patching and bad design practice.   These security approaches will not fit.  

Likewise, OAuth and other web centric security frameworks were not designed for small devices.   Trimming might be possible, but it would be better to pursue simpler frameworks that could be scaled upward, than trying to shrink larger frameworks to fit.

Paul

PS - currently working at a Semiconductor company on IoT and wireless ...

> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace