Subject: [Ace] Alexey Melnikov's No Objection on draft-ietf-ace-cbor-web-token-12: (with COMMENT)

From: Alexey Melnikov <[email-masked]>
Date: Sun, 04 Mar 2018 11:18:39 -0800

Alexey Melnikov has entered the following ballot position for
draft-ietf-ace-cbor-web-token-12: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ace-cbor-web-token/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Just to double check: a CWT claim registration from a Proposed Standard still
needs to be submitted to the review mailing list, but it is not really subject
to Expert Review, correct? You might want to make it clearer.

---

From: Jim Schaad <[email-masked]>
Date: Sun, 4 Mar 2018 11:39:24 -0800

IANA does ask for the expert review as part of the processing it does even for standards track documents.  This is because, in part, they are responsible for doing the final number assignment.  That is which number in the range is actually used.  The interesting question would be what happens if the IESG and the DEs disagree about such things.  I would expect that this would result in a long discussion with some type of final agreement between them.

Jim

> -----Original Message-----
> From: Alexey Melnikov [mailto:[email-masked]]
> Sent: Sunday, March 4, 2018 11:19 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Alexey Melnikov's No Objection on draft-ietf-ace-cbor-web-token-
> 12: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> needs to be submitted to the review mailing list, but it is not really subject to
> Expert Review, correct? You might want to make it clearer.

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 04 Mar 2018 21:00:58 +0000

On Sun, Mar 4, 2018, at 7:39 PM, Jim Schaad wrote:
> IANA does ask for the expert review as part of the processing it does 
> even for standards track documents.  This is because, in part, they are 
> responsible for doing the final number assignment.  That is which number 
> in the range is actually used.  The interesting question would be what 
> happens if the IESG and the DEs disagree about such things.

This is exactly why I am asking about this. It might also possible to game the system to ask IESG approval of a Proposed Standard that bypasses Expert Review.

>  I would 
> expect that this would result in a long discussion with some type of 
> final agreement between them.
> 
> Jim
> 
>

---

From: Jim Schaad <[email-masked]>
Date: Sun, 4 Mar 2018 13:11:36 -0800

> Sent: Sunday, March 4, 2018 1:01 PM
> To: Jim Schaad <[email-masked]>; The IESG <[email-masked]>
> Subject: Re: Alexey Melnikov's No Objection on draft-ietf-ace-cbor-web-
> token-12: (with COMMENT)
> 
> > even for standards track documents.  This is because, in part, they
> > are responsible for doing the final number assignment.  That is which
> > number in the range is actually used.  The interesting question would
> > be what happens if the IESG and the DEs disagree about such things.
> 
> This is exactly why I am asking about this. It might also possible to game the
> system to ask IESG approval of a Proposed Standard that bypasses Expert
> Review.

Interesting.  The text that IANA and I finally agreed to for the COSE Algorithm registry is "Standards Action With Expert Review".

That would make sure that it cannot bypass the Expert Review.

Jim

> > > When responding, please keep the subject line intact and reply to
> > > all email addresses included in the To and CC lines. (Feel free to
> > > cut this introductory paragraph, however.)
> > >
> > >
> > > Please refer to
> > > https://www.ietf.org/iesg/statement/discuss-criteria.html
> > > Just to double check: a CWT claim registration from a Proposed
> > > Standard still needs to be submitted to the review mailing list, but
> > > it is not really subject to Expert Review, correct? You might want to make
> it clearer.
> >
> >

---

From: Mike Jones <[email-masked]>
Date: Fri, 16 Mar 2018 10:04:50 +0000

Hi Alexey,

https://tools.ietf.org/html/draft-ietf-ace-cbor-web-token-14 should address your comments.  Changes motivated by your comments were:
  - Added the text "IANA must only accept registry updates from the Designated Experts and should direct all requests for registration to the review mailing list" from RFC 7519, as suggested by Amanda Baber of IANA, which is also intended to address Alexey Melnikov's comment.

				Thanks again,
				-- Mike

-----Original Message-----
From: Jim Schaad <[email-masked]> 
Sent: Sunday, March 4, 2018 1:12 PM
To: 'Alexey Melnikov' <[email-masked]>; 'The IESG' <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Alexey Melnikov's No Objection on draft-ietf-ace-cbor-web-token-12: (with COMMENT)

> > IANA does ask for the expert review as part of the processing it 
> > does even for standards track documents.  This is because, in part, 
> > they are responsible for doing the final number assignment.  That is 
> > which number in the range is actually used.  The interesting 
> > question would be what happens if the IESG and the DEs disagree about such things.
> 
> This is exactly why I am asking about this. It might also possible to 
> game the system to ask IESG approval of a Proposed Standard that 
> bypasses Expert Review.

Jim

> > > ------------------------------------------------------------------
> > > --
> > > --
> > > COMMENT:
> > > ------------------------------------------------------------------
> > > --
> > > --
> > >
> > > Standard still needs to be submitted to the review mailing list, 
> > > but it is not really subject to Expert Review, correct? You might 
> > > want to make
> it clearer.
> >
> >

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 16 Mar 2018 13:03:29 +0000

Hi Mike,

> On 16 Mar 2018, at 10:04, Mike Jones <[email-masked]> wrote:
> 
> Hi Alexey,
> 

Works for me, thank you!