Subject: [Ace] AIF as a suggestion in key-groupcomm; AIF in MQTT

From: Carsten Bormann <[email-masked]>
Date: Mon, 18 May 2020 17:21:38 +0200

As I said today, the role of AIF [1] in ACE documents can only be as a suggestion, or as a starting point, because it assumes that the (resource) names are static, and something application-specific has to be added for more dynamic names.

The current MQTT proposal [2] is different in three ways:
(1) it has different verbs (publish, subscribe)
(2) it uses topic filters instead of resource names
(3) it uses a text-based syntax.

I think that (3) has all the usual problems, so I would recommend against this.
(1) and (2) can be mapped to the structure of AIF without any pain, and I would recommend for this.

In summary, essence, AIF could be made useful as the base suggestion for MQTT as well as REST, with the refinement for verbs and filters retained in the current draft.

Grüße, Carsten

[1]: https://tools.ietf.org/html/draft-bormann-core-ace-aif
[2]: https://tools.ietf.org/html/draft-ietf-ace-mqtt-tls-profile-04#section-3

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 18 May 2020 18:12:14 +0200

> [1]: https://tools.ietf.org/html/draft-bormann-core-ace-aif

Benjamin reminds me that this has -core- as the crucial third word of the draft name.
I hope that doesn’t get in the way if we decide to pick this up as an (informational) ACE document (I could resubmit this under a different name, but that would be confusing).
Or we (ACE) could actually decide to throw this back over the fence to CoRE?

Grüße, Carsten

---

From: Jim Schaad <[email-masked]>
Date: Mon, 18 May 2020 13:43:09 -0700

That is not an issue.  If you ask for adoption, we can adopt any draft with any name.

-----Original Message-----
From: Ace <[email-masked]> On Behalf Of Carsten Bormann
Sent: Monday, May 18, 2020 9:12 AM
To: Ace Wg <[email-masked]>
Subject: Re: [Ace] AIF as a suggestion in key-groupcomm; AIF in MQTT

Grüße, Carsten

_______________________________________________
Ace mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ace