Subject: Re: [Add] The ADD WG has placed draft-btw-add-home in state "Candidate for WG Adoption"

From: <[email-masked]>
Date: Mon, 1 Feb 2021 11:16:39 +0000

Hi, 

I do support working group adoption.

Regards

Nic

-----Ursprüngliche Nachricht-----
Von: Add <[email-masked]> Im Auftrag von IETF Secretariat
Gesendet: Donnerstag, 28. Januar 2021 00:16
An: [email-masked]; [email-masked]; [email-masked]
Betreff: [Add] The ADD WG has placed draft-btw-add-home in state "Candidate for WG Adoption"

The ADD WG has placed draft-btw-add-home in state Candidate for WG Adoption (entered by Glenn Deen)

The document is available at
https://datatracker.ietf.org/doc/draft-btw-add-home/

Comment:
Based on list and discussion during the January 27th ADD Interim this document is being put up for call for WG Adoption.

WG Call for adoption is open until February 10th, 2021

--
Add mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/add

---

From: "Diego R. Lopez" <[email-masked]>
Date: Mon, 1 Feb 2021 11:25:54 +0000

I support adoption as well

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]
Mobile:  +34 682 051 091
----------------------------------

On 01/02/2021, 12:20, "Add on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    Regards

    Nic

    -----Ursprüngliche Nachricht-----
    Von: Add <[email-masked]> Im Auftrag von IETF Secretariat
    Gesendet: Donnerstag, 28. Januar 2021 00:16
    An: [email-masked]; [email-masked]; [email-masked]
    Betreff: [Add] The ADD WG has placed draft-btw-add-home in state "Candidate for WG Adoption"

    Comment:

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Ralf Weber" <[email-masked]>
Date: Mon, 01 Feb 2021 12:38:13 +0100

Moin!

On 28 Jan 2021, at 0:15, IETF Secretariat wrote:

> The ADD WG has placed draft-btw-add-home in state
> Candidate for WG Adoption (entered by Glenn Deen)
>

So long
-Ralf
——
Ralf Weber

---

From: Daniel Migault <[email-masked]>
Date: Tue, 9 Feb 2021 10:14:59 -0500

I support adoption of the document.
Yours,
Daniel

-- 
Daniel Migault
Ericsson

---

From: Michael Richardson <[email-masked]>
Date: Tue, 09 Feb 2021 18:47:55 -0500

I have read draft-btw-add-home a few times, and I read it again from scratch
today.

I believe that the ideas present in this document are good ones and the WG
should spend time working on them, adopting the document.

I found that section 3, _Overview and Rationale_ was rather weak on both
Overview and Rationale.  It got very quickly into minutia of the
implementation (such as when there is a list of addresses), so the reader
unfamiliar with the situation gets lots very quickly.

I suggest that the this section be broken into two (maybe three) major
sections, the first is a more clear Overview, possibly followed immediately
by the section 4,5,6,7 on the protocol elements themselves.

Then, many of the paragraphs of section 3, would then appear in sections
perhaps named: "Architectural Challenges", "Client Implementation Considerations",
and "Deployment Considerations".
Many of the elements from section 8 would go into these sections.

I'm not sure why section 8 says that these are not "recommendations".
(noting that "RECOMMENDED" is a BCP14 synonym for SHOULD)
Perhaps the authors could explain why these are not SHOULDs?

There are a few really long sentences in the draft which maybe could be
better understood as pseudo-code.

I believe that 8.2, Unmananged CPE might reasonably be a section on its own.

WRT the security considerations around spoofed messages.

I think that this WG concluded back in early 2020 that we had to assume that
the "wire" was trusted to the extent that DHCP/RA-Guard was either
implemented, or if it was absent, that it was irrelevant.
i.e. home users who run multiple DHCP servers or let attacking systems on
     their network know what they are doing.
(Please note that the default configuration of OpenWRT actually
filters DHCPv4/v6 messages out, so most people are actually in the
former part of the clause)
I'm not saying not the talk about spoofing, but rather, I think that
the text "may be mitigated" is just too weak a statement.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Jim Reid <[email-masked]>
Date: Wed, 10 Feb 2021 10:13:11 +0000

> On 9 Feb 2021, at 23:47, Michael Richardson <[email-masked]> wrote:
> 
> should spend time working on them, adopting the document

+1. I support adoption of this I-D.

---

From: "Deen, Glenn" <[email-masked]>
Date: Mon, 22 Feb 2021 17:57:48 +0000

The chairs have reviewed the ADD list discussion and this draft has WG consensus for adoption by the ADD WG.

The new short name for this document is:  DNR - Discovery of Network designated Resolvers

Full name: DHCP and Router Advertisement Options for the Discovery of Network-designated Resolvers

Mohamed Boucadair and Tiru Reddy have agreed to be the draft editors.

The -00 version has been uploaded to Datatracker:  https://datatracker.ietf.org/doc/draft-ietf-add-dnr/

There is a GitHub repository which the editors will be working on adding to add the draft source to. (https://github.com/ietf-wg-add/draft-ietf-add-dnr)

Regards
ADD Chairs - Glenn Deen, David Lawrence

On 1/27/21, 3:16 PM, "IETF Secretariat" <[email-masked]> wrote:

    The document is available at
    https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-btw-add-home/__;!!CQl3mcHX2A!Xp0NErMP19eEAkw9_U-6afpQG595siG_WMkLBPPcnnaTIZYklfGlos3X0e6xHX-zTw$

    Comment:
    Based on list and discussion during the January 27th ADD Interim this
    document is being put up for call for WG Adoption.