Subject: [Add] Call for adoption: draft-reddy-add-enterprise-split-dns

From: "Deen, Glenn" <[email-masked]>
Date: Thu, 9 Dec 2021 18:01:06 +0000

The call for adoption of draft-reddy-add-enterprise-split-dns has been difficult to assess because there are a number of issues that are intersecting in some participants' considerations around the general topic of Split DNS.

Here’s what the chairs, with consultation of ADD AD Eric Vyncke, have conclude so far:

1. There is clear interest and consensus in the ADD WG for working on discovery of encrypted resolvers in the Split DNS scenario.

2. There is no consensus in the ADD WG for draft-reddy-add-enterprise-split-dns being ready to move forward within the ADD group.

3. There are a number of issues that are out of the scope of the ADD WG, such as the use of DNSSEC or other non-DNSSEC domain validation methods, that are either proposed to be addressed in the ADD work, or a being asserted as needing to be solved in another group before ADD work could proceed.

Taking these points into consideration the chairs believe the following is the right thing to move forward.

1. The call for adoption of draft-reddy-add-enterprise-split-dns as it currently stands has failed.

2. Issues such as Domain Validation, DNSSEC adoption, etc., are clearly out of scope of the ADD charter, which is focused on and limited to the Discovery of Available resolvers, not the validation of the domains they resolve, or their authorization to resolve one domain set over another.

3. Meanwhile the actual use case of Split-DNS is in wide and active deployment  across a sizable portion of institutions and enterprises around the world that make use of split-DNS in their infrastructure design and there is a desire to enable a standard means of discovery of encrypted DNS servers in Split-DNS environments.    If ADD does not offer a standard way of doing such discovery, even in light of the absence of solutions to the domain validation issues, there will likely emerge non-standard approaches which will undermine any future hope of introducing and getting adoption for a standardized discovery mechanism.

4. Since there is consensus for the ADD WG to work on the use-case of discovery of encrypted resolvers in the Split-DNS scenario, we will schedule an Interim ADD session in early 2022, possibly late January- February  that focuses on this topic.

signed,
ADD Co-chairs and AD
Glenn Deen, David Lawrence, Eric Vyncke

---

From: Michael Richardson <[email-masked]>
Date: Thu, 09 Dec 2021 13:21:43 -0500

Deen, Glenn <Glenn_Deen=[email-masked]> wrote:
    > 4. Since there is consensus for the ADD WG to work on the use-case of
    > discovery of encrypted resolvers in the Split-DNS scenario, we will
    > schedule an Interim ADD session in early 2022, possibly late January-
    > February  that focuses on this topic.

okay. (Good call)

Can you do this joint with dnsop?
Could the issues that out of charter for ADD turn into a document there?
And/or could the history split-dns standardization/BCP-ization perhaps be
included in the discussion?

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide