Subject: [Adslmib] Review comment of NG-ADSL-MIB

From: Chen Jian <[email-masked]>
Date: Mon, 12 Sep 2005 22:23:13 +0800

ADSL2 mib Review comment :

1. The description of the MIB node adsl2LConfProfPsdMaskUs : " The downstream PSD mask applicable... " , the word 'downstream' may be 'upstream'.
2. The description of the MIB node adsl2LConfProfPsdMaskUs : " This is a string of 16 pairs of values in ...", Actually, in ITU-T G997.1 paragraph 7.3.1.2.11
the maximum number of breakpoints in upstream is 4.
3. The description of RowStatus node may be detail .
4.  Why the adsl2PMrLineCurrInitTable & adsl2PMrLineCurrInitEntry have a letter 'r' follow the 'PM' ?

-----------
Regards,
Chen Jian
Huawei Technologies Co.,Ltd
_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: [email-masked]
Date: Sun, 25 Sep 2005 19:51:57 +0300

Hello Mr. Chen Jian,

You say that "...the bearer may not be a interface entry of Iftable" but
this statement is incorrect.

Bearer channels are considered as virtual interfaces and have been
allocated ifType values by IANA. E.g., the "Interleave" [=124] and "Fast"
[=125] ifType values are allocated by IANA for ADSL bearer channels as you
can learn in RFC2662.
In adsl2ChannelStatusTable the first key is the ifIndex of the bearer
channel. This is a direct addressing of the bearer channel layer. We
however did not asked for a new ifType value. Instead, we recommended on
using either one of the two values mentioned above or the ifType value
"Channel" [=70] for the ifIndex of the ADSL/2/2plus bearer channels.

Addressing a specific channel STATUS is an operation we identified as a
necessity. This does not contradict the way we CONFIGURE the line.
The configuration template is a complete structure, containing the details
for all layers, line level and channel/Data-Path level. The template is
associated with the whole line and there's is no need to attach a profile
per channel. So, we actually use for this operation the ifIndex of the
line.

Last but not least. You must implement the rows in the ifTable for the
ADSL2 channels because this is MANDATORY. This is not a new requirement in
our document.  E.g., this is already in RFC2662. Also, in case the bearer
channel is an ATM interface then the RFC2515 assumes that the ATM interface
has a matching row in the ifTable.

Best regards,
Moti Morgenstern & Menachem Dodge
ECI Telecom Ltd.
Broadband Access Division
30 Hasivim St.
Petach Tikva, Israel 49517
Tel.: +972-3-9266258/9268421
Fax: +972-3-9287342
www.ecitele.com

                      Chen Jian                                                                                                        
                      <chanboy@huawei.         To:      [email-masked]                                                     
                      com>                     cc:      [email-masked]                                                               
                      Sent by:                 Subject: Re: [Adslmib] Review comment of NG-ADSL-MIB                                    
                      adslmib-bounces@                                                                                                 
                      ietf.org                                                                                                         

                      22/09/2005 15:23                                                                                                 

Hello Menachem Dodge,

The indexes of the adsl2ChannelStatusTable are 'ifindex' &
'adsl2ChStatusUnit ' in the MIB draft.
It seems the 'ifindex' stand for index  of  frame bearer of TPS-TC layer in
this table. I think bearer
channels are contained in a physical line.The physical line can be a entry
of Iftable and the bearer
 may not be a interface entry of Iftable.
In the Profile section, we can only bind a Template which contained all
bearer
channel profiles to a xDSL line.  The operation of bind a channel profile
to a bearer channel is
unavailable. Thus, the minimum interface may be a physical xDSL line.
So, I suggest the index of the adsl2ChannelStatusTable add a node
adsl2ChStatusChIndex(1-4).
The 'ifindex' of the table means a physical line.
There is another reason for this. If a bearer channel is a interface of
IfTable, we must implement 2-5
interface instances in IfTable of one physical line. I think it is not
necessay.

Best Rgds,
Chen Jian

-----------
 Regards,
Chen Jian
----- Original Message -----
From: <[email-masked]>
To: "Chen Jian" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Wednesday, September 21, 2005 7:49 PM
Subject: Re: [Adslmib] Review comment of NG-ADSL-MIB

>
>
>
>
> Hello Chen Jian,
>
>       Thank you for pointing this out, it seems that these two parameters
> have been overlooked. It  will be fixed
> in  the next version of the draft.
>
> Regards,
>
> Menachem Dodge
>
>
>
>

>                       <chanboy@huawei.         To:
[email-masked]

>                       com>                     cc:      [email-masked]

>                       Sent by:                 Subject: Re: [Adslmib]
Review comment of NG-ADSL-MIB
>                       adslmib-bounces@

>                       ietf.org

>                       20/09/2005 10:39

>
>
>
> Hello Menachem Dodge,
>
> About the NG-ADSL-MIB,
>
> I can not find the configration node "Downstream Transmit Spectrum
Shaping"
> & " Upstream Transmit Spectrum Shaping " which defined in ITU-T G997.1
> paragraph 7.5.1.21.5 & 7.5.1.21.6 in the draft.
>
> Is it in particular consideration or lost?
>
> Best Rgds,
> Chen Jian
>
> -----------
> Regards,
> Chen Jian
> ----- Original Message -----
> From: <[email-masked]>
> To: "Chen Jian" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Wednesday, September 14, 2005 12:55 AM
> Subject: Re: [Adslmib] Review comment of NG-ADSL-MIB
>