Subject: [Adslmib] Comments on NG-DSL-MIB

From: Chen Jian <[email-masked]>
Date: Wed, 28 Sep 2005 12:31:21 +0800

Hello Moti & Menachem,

I think you are approaching success. Thank you for your excellent work.

Review comments:

1. 'adsl2LineCmndConfLdsfFailReason' has a read-only accessing mode that the name may be use 'Status' instead of 'Cmnd'.

2. 'adsl2PMChCurr15McodingViolations' may have the first letter upcased of the word 'coding'.

3.  LineAtten and SignalAtten have duplicate nodes placed in 'adsl2SCStatusTable' and 'adsl2LineTable'. 

4.  'adsl2PMChCurr15MtimeElapsed' may have the first letter upcased of the word 'time'.
    
-----------
Regards,
Chen Jian
Huawei Technologies Co.,Ltd 
_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: [email-masked]
Date: Thu, 29 Sep 2005 14:29:42 +0300

Hello Mr. Chen Jian,

Thank you very much for your comments and suggested corrections. We'll
implement the changes you point out in (2) and (4).

Response to Comment (1):
---------------------------------------
The adsl2LineCmndConfLdsfFailReason is actually a status object. Its name
reflects two points: First, the association to the adsl2LineCmndConfLdsf
object and, secondly, that it is not just a pass/fail status object but
more specifically the failure reason of the LDSF command.

Response to Comment (3):
---------------------------------------
The reason we have certain line status attributes (including those you
mention) "duplicated" in the SC status table is to be able to freeze the
DELT results, including attributes that change dynamically after the DELT
is over. By using two sets of line status attributes the operator can still
retrieve the current line status attributes (through the line table) but
now he is also able to find a second set of attributes (in the SC status
table) "recording" the line status attributes during the DELT process.
Otherwise, as an example, if he executes a DELT and doesn't bother
immediately reading the results then the SC status attributes are more
likely to be present while most line status attributes are dynamically
changed.

Best Regards,
Moti Morgenstern

                      Chen Jian                                                                                                        
                      <chanboy@huawei.         To:      moti <[email-masked]>, [email-masked]                
                      com>                     cc:      [email-masked]                                                               
                                               Subject: Comments on NG-DSL-MIB                                                         
                      28/09/2005 07:31                                                                                                 

Hello Moti & Menachem,

Review comments:

1. 'adsl2LineCmndConfLdsfFailReason' has a read-only accessing mode that
the name may be use 'Status' instead of 'Cmnd'.

2. 'adsl2PMChCurr15McodingViolations' may have the first letter upcased of
the word 'coding'.

3.  LineAtten and SignalAtten have duplicate nodes placed in
'adsl2SCStatusTable' and 'adsl2LineTable'.

4.  'adsl2PMChCurr15MtimeElapsed' may have the first letter upcased of the
word 'time'.

-----------
Regards,
Chen Jian