Subject: [Adslmib] Adsl2 MIB draft - IfType and Transmission number.

From: "Menachem Dodge" <[email-masked]>
Date: Tue, 17 Oct 2006 10:37:46 +0200

Hi All,
 
    I wish to inform you all, that an issue has arisen (many thanks to
Bert for catching this in time) regarding the
IfType and Transmission number assigned to the adsl2 MIB.
 
    Bert has pointed out that for a long time it has been the IETF
intention that for a specific ifType someIfType(nnn), we would have a
someIfType specific MIB module under the branch transmission.nnn.
 
    Now, for adsl2 the ifType that was assigned and can be found in
www.iana.org/assignments/ianaiftype-mib
<http://www.iana.org/assignments/ianaiftype-mib>  
was adsl2 (230) but the OID assigned for the adsl2MIB under the
"transmission" branch as found in www.iana.org/assignments/smi-numbers
<outbind://79/www.iana.org/assignments/smi-numbers>  the value 231 was
assigned. 
 
The ifType 231 has already been assigned, as has the transmission.230 to
other technologies. So we have a mismatch.
 
Thus, the ifType adsl2 must be obsoleted and we need a new type
adsl2plus (thanks Moti for the suggestion) which will
represent all of the adsl2 family of technologies ADSL, ADSL2 and ADSL2+
and any variants of these.

    The following steps need to be taken:
 
    1. Request the IANA to obsolete the ifType adsl2 (230).
    2. Request that the IANA assign a new ifType adsl2plus (nnn).  
    3. Request that the IANA assign the OID adsl2MIB to the
transmission.nnn (same nnn as the ifType).
    4. Once the IANA has made these assignments I will request that the
RFC editor update the text in 
the draft replacing "adsl2 (230)" with "adsl2plus (nnn)" for each
occurrence.
 
    After this is done, the process of publishing the draft as an RFC
can continue.
 
Best Regards,
Menachem Dodge
 
_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: "Menachem Dodge" <[email-masked]>
Date: Wed, 18 Oct 2006 16:38:53 +0200

Hello All,
 
    I am pleased to inform you that the IANA has carried out steps 1
through 3 below
and that the ifType adsl2plus (238) as well as transmission.238 has been
assigned.
 
    This leaves item #4 the correction of the draft. 
 
Best Regards,
Menachem Dodge.

________________________________

From: Menachem Dodge 
Sent: Tuesday, October 17, 2006 10:38 AM
To: IETF ADSL MIB Working Group
Subject: Adsl2 MIB draft - IfType and Transmission number.

Hi All,

 

 

Best Regards,
Menachem Dodge