Subject: Re: [alto] Comments on provisioned bandwidth and ALTO

From: "Woundy, Richard" <[email-masked]>
Date: Thu, 18 Mar 2010 09:06:17 -0400

>The network maps (and the associated cost map) is fine as long as the IP prefix allocation in an ISP's network is stable. Where stable means changes of the IP prefix allocation are happening in the range of weeks.

In the networks I am familiar with (cable), most of the time the IP address is fairly stable, with DHCP lease times on the order of several days or a week. And the same lease is often renewed to the same DHCP client (even on a modem reboot), so a DHCP client could maintain the same IP address for months at a time. So most of the time, most of the information in a network map will be fairly stable.

(On non-cable networks, your mileage may vary.)

My original point is that some individual map entries may not be as stable, if there are renumbering events in particular parts of the topology. So most of the map is stable for a long period of time, but a few parts may be subject to renumbering in hours or minutes.

>I don't see a particular reason why the information gained from provisioned bandwidth is not subject to the same rules as topology information delivered for a peer's IP address.

I think I agree.

-- Rich

----- Original Message -----
From: Martin Stiemerling <[email-masked]>
To: Woundy, Richard; [email-masked] <[email-masked]>
Sent: Thu Mar 18 07:17:34 2010
Subject: RE: [alto] Comments on provisioned bandwidth and ALTO

Rich,

Here I go with my comments on the dynamic IP address re-allocation.

I commented on this during the IETF-76 on (taken from the minutes)
Martin: how static is a network map in reality?
and also by email:
http://www.ietf.org/mail-archive/web/alto/current/msg00519.html

My point was that the proposed network map/cost map in the ALTO protocol would be less beneficially, if the ISP are exactly doing what you have described and what I have commented on during the last IETF. 

However, I've had the impression that most people in the room didn't agree to this view:

The network maps (and the associated cost map) is fine as long as the IP prefix allocation in an ISP's network is stable. Where stable means changes of the IP prefix allocation are happening in the range of weeks. 

Now the caveats of network maps:
It is up to the ISP to change the IP prefix allocation in its own network at anytime. Including using some dynamic re-allocation schemes, for instance, supported by using Cisco's ODAP feature, but also shuffling them manually. If now, a dynamic reallocation scheme is used (and I guess some ISP will need to do this soon, as there not too many free ISP prefix blocks left), the network maps have to be updated in much shorter time frame than actually envisioned by the ALTO protocol.

This takes away the advantage of having network maps and would clearly argue for enhanced oracle approach.

Coming now to provisioned bandwidth and dynamic IP address re-allocation:
I don't see a particular reason why the information gained from provisioned bandwidth is not subject to the same rules as topology information delivered for a peer's IP address.

Both are subject to change and have more less only a good meaning at the time of the query. With time evolving, the information where a peer is topology wise close or if the peer has a particular provisioned bandwidth will anyhow change (e.g., home gateway or cable modem is rebooting, causing to get a new IP address assigned and the old one being re-assigned to some other customer access line).

Thanks,

  Martin

> 
> Here are my thoughts on dynamic address re-allocation.
> 
> ISPs reallocate IPv4 subnets within their infrastructure from time to
> time, partly to ensure the efficient usage of IPv4 addresses (a scarce
> resource), and partly to enable efficient route tables within their
> network routers. The frequency of these "renumbering events" depend on
> the growth in number of subscribers and the availability of address
> space within the ISP. As a result, a subscriber's household device
> could retain an IPv4 address for as short as a few minutes, or for
> months at a time or even longer.
> 
> Some folks have suggested that ISPs providing ALTO services could sub-
> divide their subscribers' devices into different IPv4 subnets (or
> certain IPv4 address ranges) based on the purchased service tier, as
> well as based on the location in the network topology. The problem is
> that this sub-allocation of IPv4 subnets tends to decrease the
> efficiency of IPv4 address allocation. A growing ISP that needs to
> maintain high efficiency of IPv4 address utilization may be reluctant
> to jeopardize their future acquisition of IPv4 address space.
> 
> Therefore, consumers of per-user ALTO information should assume that
> subscribers retain IPv4 addresses for only a relatively short period of
> time, e.g. minutes, and that subscribers of different service tiers
> will co-exist in some ISP's IPv4 subnets.
> 
> -- Rich

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Enrico Marocco <[email-masked]>
Date: Fri, 19 Mar 2010 07:29:30 +0100

Woundy, Richard wrote:
>> The network maps (and the associated cost map) is fine as long as
>> the IP prefix allocation in an ISP's network is stable. Where
>> stable means changes of the IP prefix allocation are happening in
>> the range of weeks.
> 
> In the networks I am familiar with (cable), most of the time the IP
> address is fairly stable, with DHCP lease times on the order of
> several days or a week. And the same lease is often renewed to the
> same DHCP client (even on a modem reboot), so a DHCP client could
> maintain the same IP address for months at a time. So most of the
> time, most of the information in a network map will be fairly stable.
> 
> 

On a non-cable network I'm somewhat familiar with, we have observed that
about 60% of the residential access lines change address in 24h, while
the remaining ~40% remains fairly stable for several days (i.e. in 2
days 40% of the lines maintain the same address, in 7 days 38%).

This is of course a very particular case, and the numbers are likely to
vary whenever address pools got reallocated -- i.e. quite often, in
nationwide ISPs.

-- 
Ciao,
Enrico