Subject: [alto] Error handling in the ALTO protocol (-03)

From: "Martin Stiemerling" <[email-masked]>
Date: Thu, 18 Mar 2010 12:29:18 +0100

Hi all,

While reading draft-ietf-alto-protocol-03 is stumbled over the error handling. 

It seems that the error handling of ALTO relies on the http error codes, but does not provide its own error code or proceed. 

I see this a shortcoming of the current design and also as not favourably.

This mixes transport related error messages (e.g., 404 not found, i.e., the general alto resource your asking for isn't here) and errors related the actual ALTO handling (e.g., asking guidance for private or reserved IP addresses that cannot be rated by ALTO, syntax errors, or not understood objects). 

My proposal:
- separate both levels clearly
- define an error object for cases where no or only a partial answer can be given
- define that the server can deliver some information he has understood (e.g., some IP addresses) within the given semantics, as defined in the draft as is. 

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Richard Alimi <[email-masked]>
Date: Thu, 18 Mar 2010 09:06:53 -0400

Hi Martin,

On Thursday 18 March 2010 7:29:18 am Martin Stiemerling wrote:
> It seems that the error handling of ALTO relies on the http error codes,
> but does not provide its own error code or proceed.
> 
> This mixes transport related error messages (e.g., 404 not found, i.e., the
> general alto resource your asking for isn't here) and errors related the
> actual ALTO handling (e.g., asking guidance for private or reserved IP
> addresses that cannot be rated by ALTO, syntax errors, or not understood
> objects).
> 
> My proposal:
> - define an error object for cases where no or only a partial answer can be
> given - define that the server can deliver some information he has
> understood (e.g., some IP addresses) within the given semantics, as
> defined in the draft as is.
> 
>   Martin
> 
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

This makes sense, and I think it is reasonable to adopt for the next version 
of the document.  It would be good to get opinions from others here as well.

-- 
Richard Alimi
Department of Computer Science
Yale University