Subject: [alto] Is source address optional in Endpoint Property lookup requests?

From: Ben Niven-Jenkins <[email-masked]>
Date: Fri, 24 Jun 2011 16:48:34 +0100

Colleagues,

Section 10.3 of draft-ietf-alto-protocol-08 states:

   The protocol specified in this document provides a mode of operation
   where the source network location is computed by the ALTO Server (via
   the Endpoint Property Lookup interface) from the source IP address
   found in the ALTO Client query packets.  This is similar to how some
   P2P Trackers (e.g., BitTorrent Trackers - see "Tracker HTTP/HTTPS
   Protocol" in [BitTorrent]) operate.

However, although section 7.7.5.1.3 (for the Endpoint Cost service) allows the source address to be inferred from the client's IP address, section 7.7.4.1.3 (for the Endpoint Property Lookup service) doesn't allow the source address to be optional or inferred from the client's IP address.

Is this an oversight in the description of the Endpoint Property Lookup service or should the example in section 10.3 point to the Endpoint Property Cost service?

Thanks
Ben

---

From: Reinaldo Penno <[email-masked]>
Date: Sat, 25 Jun 2011 13:47:11 -0400

Hi Ben,

Endpoint cost service calculates the cost of the client sending the message
to one or more clients. The client's IP address is used in order to generate
the  appropriate answer.

The endpoint property lookup service provides a way to find a list of
properties about a endpoint. The IP address of the client sending the query
has no bearing on the answer. Or does it?

Or you are talking about a client finding properties for itself?

Thanks,

Reinaldo

On 6/24/11 10:48 AM, "Ben Niven-Jenkins" <[email-masked]> wrote:

> However, although section 7.7.5.1.3 (for the Endpoint Cost service) allows the
> source address to be inferred from the client's IP address, section 7.7.4.1.3
> (for the Endpoint Property Lookup service) doesn't allow the source address to
> be optional or inferred from the client's IP address.
> 
> Is this an oversight in the description of the Endpoint Property Lookup
> service or should the example in section 10.3 point to the Endpoint Property
> Cost service?
> 
> Thanks
> Ben
> 
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 27 Jun 2011 21:10:38 +0100

Reinaldo,

> Or you are talking about a client finding properties for itself?

Thanks for the explanation - that makes sense and therefore I think the example in section 10.3 need changing to refer to the Endpoint Cost service, which is the service that allows an ALTO server to use the source IP address in the query packets to derive the source network location as the current reference to the Endpoint Property service in that context is clearly wrong.

Ben

---

From: Richard Alimi <[email-masked]>
Date: Mon, 27 Jun 2011 16:40:07 -0700

Hi Ben,

> Thanks for the explanation - that makes sense and therefore I think the example in section 10.3 need changing to refer to the Endpoint Cost service, which is the service that allows an ALTO server…

We'll fix this reference.

Rich

---

From: Robert Varga <[email-masked]>
Date: Tue, 28 Jun 2011 14:12:25 +0200

Hi,

since we are on the subject of source IP address. Would it make sense to
use X-Forwarded-For header instead of peer IP address? That could be
beneficial in case there is an HTTP cache involved, but it is easily faked.

Bye,
Robert

-- 
Robert Varga
Pantheon Technologies, s.r.o.
Mlynske Nivy 56
831 05 Bratislava