Subject: Re: [alto] Pathological network maps ...

From: Bill Roome <[email-masked]>
Date: Mon, 12 Mar 2012 11:04:13 -0400

Okay!  However, do you think it's worth adding an "implementation note" to
the protocol spec, warning people that they can't merge adjacent CIDRs in
the same PID, because that could change how endpoints map to PIDs?

I know I considering doing that in my ALTO client. I was really surprised
when I investigated various test cases and discovered that I couldn't do
that safely.

	- Bill

On 03/11/2012 15:00, "[email-masked]" <[email-masked]> wrote:

>Date: Sun, 11 Mar 2012 00:23:37 -0800
>From: Richard Alimi <[email-masked]>
>To: Nicholas Weaver <[email-masked]>
>Cc: Bill Roome <[email-masked]>, "[email-masked]"
>	<[email-masked]>
>Subject: Re: [alto] Pathological network maps: "empty" PIDs and
>	"unreduced"	PIDs
>Message-ID:
>	<[email-masked]>
>Content-Type: text/plain; charset=ISO-8859-1
>
>On Wed, Mar 7, 2012 at 8:03 AM, Nicholas Weaver
><[email-masked]> wrote:
>>
>>On Mar 7, 2012, at 7:57 AM, Bill Roome wrote:
>>>1. Should the ALTO spec forbid "empty" CIDRs in the network map?
>>
>>>2. Should the ALTO spec require the CIDRs in a PID to be reduced to
>>>"lowest terms"?
>>
>>
>>My thoughts are "No" and "No", because churn will happen.
>>
>>
>>For the first, the "empty" CIDRs can be effectively catch-all rules,
>>which when a subrule goes in and out may change things.
>>
>>Likewise, I don't see the benefit of mandatory
>>canonicalization/reduction when there is possible churn, which will
>>force the undoing/redoing of the canonicalization.
>>
>
>Agreed. While it may be aesthetically pleasing (and perhaps slightly
>smaller on the wire) to have a canonical representation, I'm not sure
>I see a reason to force this upon servers.
>
>Rich
>

---

From: Richard Alimi <[email-masked]>
Date: Mon, 12 Mar 2012 08:46:42 -0700

> the same PID, because that could change how endpoints map to PIDs?

Sure we can add that.  Mind if I keep a note of this for the next
round instead of uploading a -12 version today just for this? :)

Rich

> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Fri, 16 Mar 2012 21:04:51 +0000

> the same PID, because that could change how endpoints map to PIDs?

I think that would be a good idea to avoid later interop issues.

Ben