Subject: [alto] ALTO home proxy

From: Picconi Fabio <[email-masked]>
Date: Thu, 29 Mar 2012 13:35:06 +0200

Hi,

Following the ALTO meeting, there's a couple of things I would like to mention regarding ALTO home proxies (draft-picconi-alto-home-proxy-00).

1) I propose to mention home proxies in the ALTO discovery draft. If there is an ALTO server running at the home (e.g., on the gateway, on a NAS, etc.), it could be easily discovered through SLP/uPnP/Bonjour. This "local" discovery does not mean that the "traditional" discovery becomes useless: the client may want to determine what the "authoritative" ALTO server is, to check whether the "local" ALTO server is providing the data the client wants. However, discovering a local server is still useful, as the client may use it to keep ALTO queries local.

2) I plan to edit the ALTO home proxy draft to include the "HTTP redirect" use case, which I mentioned during the Paris meeting. The idea is that applications may discover a local ALTO server through SLP/uPnP/Bonjour, and this local server always redirects to the closest ALTO server. The advantage is that the client does not need to find the closest ALTO server: the local server does it for him. This scenario makes most sense when the ISP includes such a "redirecting ALTO server" in the home gateways that it ships to its users. Of course, if the home gateways have enough RAM, hard disk space, CPU, etc., the local server may cache the ALTO information and respond to local queries instead of redirecting them.

Please let me know what you think.

Best,

Fabio

---

From: Sebastian Kiesel <[email-masked]>
Date: Thu, 29 Mar 2012 15:36:13 +0200

Hi Fabio, all,

my thoughts on this:

1.) There are several reasons why it may make sense to have an
    ALTO proxy in a home gateway or NAS, etc.  
    
    But regarding the discovery issue, how does this solve or ease our
    problems?  Aren't we just shifting the complexity of finding the
    ISP's (upstream) ALTO server, from the ALTO client to the local ALTO
    proxy?

2.) The main problems we're having with the discovery document are NOT
    with the scenario "ALTO client in the resource consumer (in the home
    network)".  The difficult scenarios are when the ALTO client is at a
    central place (e.g., bittorrent tracker, or DNS-server for
    redirection in some CDN scenarios), i.e., when we have to issue ALTO
    queries on behalf of a distant resource consumer. I don't see how a
    ALTO home proxy could help here.

 Thanks
 Sebastian

On Thu, Mar 29, 2012 at 01:35:06PM +0200, Picconi Fabio wrote:
> Hi,
> 
> Following the ALTO meeting, there's a couple of things I would like to
> mention regarding ALTO home proxies
> (draft-picconi-alto-home-proxy-00).
> 
> 1) I propose to mention home proxies in the ALTO discovery draft. If
> there is an ALTO server running at the home (e.g., on the gateway, on
> a NAS, etc.), it could be easily discovered through SLP/uPnP/Bonjour.
> This "local" discovery does not mean that the "traditional" discovery
> becomes useless: the client may want to determine what the
> "authoritative" ALTO server is, to check whether the "local" ALTO
> server is providing the data the client wants. However, discovering a
> local server is still useful, as the client may use it to keep ALTO
> queries local.
> 
> 2) I plan to edit the ALTO home proxy draft to include the "HTTP
> redirect" use case, which I mentioned during the Paris meeting. The
> idea is that applications may discover a local ALTO server through
> SLP/uPnP/Bonjour, and this local server always redirects to the
> closest ALTO server. The advantage is that the client does not need to
> find the closest ALTO server: the local server does it for him. This
> scenario makes most sense when the ISP includes such a "redirecting
> ALTO server" in the home gateways that it ships to its users. Of
> course, if the home gateways have enough RAM, hard disk space, CPU,
> etc., the local server may cache the ALTO information and respond to
> local queries instead of redirecting them.
>

---

From: Picconi Fabio <[email-masked]>
Date: Thu, 29 Mar 2012 15:51:56 +0200

Hi Sebastian,

1) Yes, we're moving the problem of discovery to the local proxy. The idea is that the local proxy may be running on a home gateway provided by the user's ISP (in countries like France this is practically always the case), and the ISP has pre-configured the ALTO proxy to redirect requests to its ALTO server.

If the applications don't care about checking the "authoritativeness" of the redirection, then discovery simplified. At any rate, if the local proxy is behaving as a full-blown ALTO server (e.g., it serves queries instead of forwarding them), then you reduce the query latency and the load on the ISP's central ALTO server.

2) The ALTO home proxy is useful for peer-to-peer applications that make local decisions on neighbor selection. This includes trackerless BitTorrent, which is very common today. For CDN scenarios I'm not sure that an ALTO home proxy would help.

Cheers,

Fabio

> -----Original Message-----
> From: Sebastian Kiesel [mailto:[email-masked]]
> Sent: jeudi 29 mars 2012 15:36
> To: Picconi Fabio
> Cc: [email-masked]
> Subject: Re: [alto] ALTO home proxy
> 
> Hi Fabio, all,
> 
> my thoughts on this:
>