Subject: [alto] Cost map: undefined vs. default value

From: Sebastian Kiesel <[email-masked]>
Date: Mon, 25 Mar 2013 09:31:45 +0100

Dear all,

draft-ietf-alto-protocol-14, section 9.1.2.5. says: "An ALTO Server MAY
omit entries for which a Path Cost is not defined (e.g., both the Source
and Destination PIDs contain addresses outside of the Network Provider's
administrative domain)."

I think it would be beneficial to have an (optional) method of specifying
a default value in the header of the map.

For example, in today's encoding:

 Content-Type: application/alto-costmap+json

   {
     "meta" : {},
     "data" : {
       "cost-mode" : "numerical",
       "cost-type" : "routingcost",
       "map-vtag"  : "1266506139",
       "map" : {
         "PID1": { "PID1": 10, "PID2": 5,  "PID3": 10 },
         "PID2": { "PID1": 5,  "PID2": 10, "PID3": 20 },
         "PID3": { "PID1": 10, "PID2": 20, "PID3": 10 }
       }
     }
   }

could become:

 Content-Type: application/alto-costmap+json

   {
     "meta" : {},
     "data" : {
       "cost-mode" : "numerical",
       "cost-type" : "routingcost",
       "cost-default" : 10,
       "map-vtag"  : "1266506139",
       "map" : {
         "PID1": { "PID2": 5 },
         "PID2": { "PID1": 5, "PID3": 20 },
         "PID3": { "PID2": 20 }
       }
     }
   }

The motivation is, that for most src/dst-pairs I don't know the costs,
i.e., all I can say is "try and see what happens".  But I know some
src/dst-pairs where I assume lower costs as well as some pairs where I
expect higher costs.  So I would like being able to express "this should
be better-than-random" and "this should be worse-than-random". Assuming
that all omitted entries are 0 or INT_MAX (or FLOAT_MAX) doesn't help.

Comments?

Thanks
Sebastian

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 25 Mar 2013 09:06:18 +0000

Sebastian,

> a default value in the header of the map.

Are you suggesting the default cost replace the unknown cost semantic or that we keep the unknown cost semantic and add an additional default cost semantic?

Thanks
Ben

> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

---

From: Sebastian Kiesel <[email-masked]>
Date: Mon, 25 Mar 2013 10:53:49 +0100

Ben, all,

On Mon, Mar 25, 2013 at 09:06:18AM +0000, Ben Niven-Jenkins wrote:
> Are you suggesting the default cost replace the unknown cost semantic
> or that we keep the unknown cost semantic and add an additional
> default cost semantic?

Both options would work for me as I personally do not see much use of
the "undefined" semantic. On the other hand, adding the "cost-default"
as an optional feature seems less disruptive wrt. existing
implementations and then we could support both the "undefined" and the
"default" semantics, so I think the proposal is: add it as an option,
i.e., if "cost-default" is present all omitted entries in the cost map
are assigned this value, otherwise they are undefined.

Thanks
Sebastian