Subject: [alto] Ato extension for representing SDN policies

From: 郭华明 <[email-masked]>
Date: Tue, 31 Mar 2015 04:23:49 +0800 (GMT+08:00)

Hi Richard, All

In SDN, each pair of source and destination network could have multiple policy rules. These rules maybe include source/destination address, protocols, ports, QoS, actions and so on. These information is
also important attributes of the path.     

I am thinking that if some policy information could be provided for applications in Alto, this is also helpful for traffic optimization.

I think there are two methods to do that in Alto.

1, Use a multiple cost types in Cost Maps (similar ideas in  draft-randriamasy-alto-multi-cost-10), add a new Cost Mode: policy, the Cost Metric use multiple fields, like <Protocol, Port, QoS>,  to represent a policy.

2, Add a new map service, like Policy Maps Service. In Policy Maps, applications can get the policy rule information.

Thanks.   

--

----------------
Best!

Huaming Guo

China Academy of Information and Communications Technology (CAICT)

---

From: ChenGuohai <[email-masked]>
Date: Wed, 8 Apr 2015 13:18:44 +0000

Hi Huaming,All
Getting policy rules does benefit to traffic optimization. In addition to that it can reduce ALTO request and response. 
For example, a policy is that band between a pair of src(A)and dst is 20M between 11:00 to 14:00 and is 10M for other time. And band between other src(B,C,D ....) and this dst is 15M. The ALTO client can use this policy in selecting more optimal peers without sending ATLO cost map request to ALTO server now and then. 
ALTO client select src(A) as the peer between 11:00 to 14:00 and one of src(B,C,D....) at other time.
Make sense?

BR
Guohai
Date: Tue, 31 Mar 2015 04:23:49 +0800
From: [email-masked]
To: [email-masked]
CC: [email-masked]
Subject: [alto] Ato extension for representing SDN policies

Hi Richard, All
In SDN, each pair of source and destination network could have multiple policy rules. These rules maybe include source/destination address, protocols, ports, QoS, actions and so on. These information isalso important attributes of the path.     

Thanks.   
--
----------------Best!

Huaming Guo
China Academy of Information and Communications Technology (CAICT)
_______________________________________________
alto mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/alto

---

From: 郭华明 <[email-masked]>
Date: Thu, 9 Apr 2015 22:49:27 +0800 (GMT+08:00)

Hi Guohai,

I think your example is good, it's my opinion that more meaningful policies are helpful for traffic optimization.

-----原始邮件-----
发件人:ChenGuohai <[email-masked]>
发送时间:2015-04-08 21:18:44 (星期三)
收件人: "郭华明" <[email-masked]>, "Richard Yang Y." <[email-masked]>
抄送: "[email-masked]" <[email-masked]>
主题: RE: [alto] Ato extension for representing SDN policies

Hi Huaming,All

Make sense?

BR
Guohai

Hi Richard, All

Thanks.   

--

----------------
Best!

Huaming Guo

_______________________________________________ alto mailing list [email-masked] https://www.ietf.org/mailman/listinfo/alto

--

----------------
Best!

Huaming Guo