Subject: Re: [alto] Spencer Dawkins' No Objection on draft-ietf-alto-cost-calendar-09: (with COMMENT)

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 16 Jan 2019 13:40:54 +0000

Hi Spencer,

Please see answer to your question inline,
Sabine

-----Original Message-----
From: Spencer Dawkins <[email-masked]> 
Sent: Tuesday, December 04, 2018 7:48 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; Gurbani, Vijay (Nokia - US/Naperville) <[email-masked]>; [email-masked]; Gurbani, Vijay (Nokia - US/Naperville) <[email-masked]>; [email-masked]
Subject: Spencer Dawkins' No Objection on draft-ietf-alto-cost-calendar-09: (with COMMENT)

Spencer Dawkins has entered the following ballot position for
draft-ietf-alto-cost-calendar-09: No Objection

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-alto-cost-calendar/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for specifying this useful capability.

I did have one question - I didn't see anywhere in the document that

   An ALTO Cost calendar provided by the ALTO Server provides 2
   information items:

   o  an array of values for a given metric, where each value
      corresponds to a time interval, where the value array can
      sometimes be a cyclic pattern that repeats a certain number of
      times.

allowed a cyclic pattern to repeat indefinitely. Just for my background, that's an intentional omission, right?
[[SR]] yes, the omission is intentional. 
This can be addressed in  section 4.1.2, by writing that:
 "Attribute "repeated" may take a very high value if a Calendar represents a cyclic value pattern that the Server considers valid for a long period and hence will only update once this period has elapsed or if an unexpected event occurs on the network. In the latter case, the client will be notified if it uses the "ALTO Incremental Updates Using Server-Sent Events" service. See also, section 7. Operational Considerations".

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 16 Jan 2019 11:48:33 -0600

Hi, Sabine,

On Wed, Jan 16, 2019 at 7:40 AM Randriamasy, Sabine (Nokia -
FR/Paris-Saclay) <[email-masked]> wrote:

> Cc: [email-masked]; Gurbani, Vijay (Nokia -
> US/Naperville) <[email-masked]>; [email-masked];
> Gurbani, Vijay (Nokia - US/Naperville) <
> [email-masked]>; [email-masked]
> Subject: Spencer Dawkins' No Objection on
> draft-ietf-alto-cost-calendar-09: (with COMMENT)
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
>  "Attribute "repeated" may take a very high value if a Calendar represents
> a cyclic value pattern that the Server considers valid for a long period
> and hence will only update once this period has elapsed or if an unexpected
> event occurs on the network. In the latter case, the client will be
> notified if it uses the "ALTO Incremental Updates Using Server-Sent Events"
> service. See also, section 7. Operational Considerations".
>
> Thanks for the explanation!

Spencer