Subject: [alto] Finishing milestones: Status of drafts?

From: Vijay Gurbani <[email-masked]>
Date: Wed, 1 Jul 2020 22:42:02 -0500

Folks: There are three drafts that we need to progress: path vector,
performance metrics, and unified properties.

Jan and I will like to get a clear idea from the authors of each of these
documents as to where things stand.

The WG list has been rather silent on progress on the drafts.  For unified
properties, Sabine had posted an email on Jun-10, but there has not been
anything else on that draft since.

Performance metrics saw some action on the WG list on May-17, but that is
it.

I don't see anything for path vector.

Can we kindly have the authors of the draft please put forward where they
are and whether the work is done enough to start WGLC on them.  Please do
so ASAP.

Thanks,

- vijay

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 2 Jul 2020 16:30:53 +0000

Dear Vijay, Jan and all,

Here are some updates regarding the Unified Property and Path Vector drafts.

Upon discussions during our weekly ALTO syncup calls,  have adapted the Path-Vector (PV) design so as to enable standalone Property queries on particular ANEs.

Up to now, the PV draft says:  "the scope of an ANE Name is limited to the Path Vector response."  One reason is that an (ALTO) Client is not necessarily interested in details on ANEs on a path but only needs to know their existence and impact on the connection performance.

While ANEs returned by a PV response do not exist beyond this response, some of them may represent entities that are persistent because it is useful for Servers and Clients to occasionally query properties without caring about the path that traverses them. In this case, they have a persistent ID that can be registered in a property map, together with properties.

When a  Client wants to query such properties on a persistent ANE, it needs 2 informations:
- persistent ID of the ANE,
- Name of the Property map defining properties on this ANE.
These 2 informations are assembled so as to form an entity ID format with the format specified in the Unified Property (UP) draft and that can be directly utilized for entity property queries.

The updates to support such a functionality are being integrated in both PV and UP draft.

Additionally, the UP draft introduces the field of  "defining resource"  in the specification of entity domains and registrations at the IANA. The "defining resource" specifies where an entity is being defined and applies to all entity domains.

We plan to submit an updated version by July 13th  on which we will request a WGLC.

Thanks,
Sabine

From: alto <[email-masked]> On Behalf Of Vijay Gurbani
Sent: Thursday, July 2, 2020 5:42 AM
To: IETF ALTO <[email-masked]>
Subject: [alto] Finishing milestones: Status of drafts?

Folks: There are three drafts that we need to progress: path vector, performance metrics, and unified properties.

Jan and I will like to get a clear idea from the authors of each of these documents as to where things stand.

The WG list has been rather silent on progress on the drafts.  For unified properties, Sabine had posted an email on Jun-10, but there has not been anything else on that draft since.

Performance metrics saw some action on the WG list on May-17, but that is it.

Can we kindly have the authors of the draft please put forward where they are and whether the work is done enough to start WGLC on them..  Please do so ASAP.

Thanks,

- vijay

---

From: "Y. Richard Yang" <[email-masked]>
Date: Thu, 2 Jul 2020 14:01:01 -0400

Hi Vijay, Jan,

Let me give some update on the performance metrics. We continued our
discussions on this document. For example, during the weekly meeting
yesterday, some of the authors (Luis, Sabine, and I) discussed the
potential impact of Prometheus (
https://prometheus.io/docs/prometheus/latest/), which is used in related
context, on the draft. For example, we looked at the list of statistics
from Prometheus (min, max, avg, stddev, stdvar, quintile, topk, bottomk) to
compare with our list. We found that there are design points from
Prometheus which we may consider in future work but keep the simplicity of
the current design. We will upload an update by the end of next week before
the July 13 deadline.

Any comments are greatly welcome!

Richard

On Wed, Jul 1, 2020 at 11:42 PM Vijay Gurbani <[email-masked]>
wrote:

> are and whether the work is done enough to start WGLC on them..  Please do
> so ASAP.
>
> Thanks,
>
> - vijay
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>
-- 
Richard

---

From: Vijay Gurbani <[email-masked]>
Date: Mon, 6 Jul 2020 11:26:34 -0500

On Thu, Jul 2, 2020 at 11:30 AM Randriamasy, Sabine (Nokia -
FR/Paris-Saclay) <[email-masked]> wrote:

> [...] We plan to submit an updated version by July 13th  on which we will
> request a WGLC.
>
>
Dear Sabine: OK, thanks.  Please do make sure that the draft is out by the
date indicated, or a couple of days earlier, so we can schedule a WGLC.
FYI: the ALTO meeting is scheduled for Mon, Jul 27.

Thanks,

- vijay

---

From: Vijay Gurbani <[email-masked]>
Date: Mon, 6 Jul 2020 11:29:12 -0500

On Thu, Jul 2, 2020 at 1:01 PM Y. Richard Yang <[email-masked]> wrote:

> Hi Vijay, Jan,
>
> Let me give some update on the performance metrics. [...] We will upload
> an update by the end of next week before the July 13 deadline.Do
>

Dear Richard: Thanks.  Do you think that the draft will be ready for WGLC
on Jul 13?  If not, what do you think is holding it up?

Thanks,

- vijay

---

From: "Y. Richard Yang" <[email-masked]>
Date: Mon, 6 Jul 2020 20:01:12 -0400

Hi Vijay,

The draft will be ready for WGLC on July 13. We will make sure to achieve
this goal.

Thanks a lot!

Richard

-- 
Richard