Subject: Re: [alto] Shepherd writeup for path-vector (draft)

From: Qin Wu <[email-masked]>
Date: Tue, 12 Jan 2021 01:45:08 +0000

Hi, authors of path-vector:
I haven’t seen you addressed IDnits errors raised by Vijay below:
https://www6.ietf.org/tools/idnits?url=https://www.ietf.org/archive/id/draft-ietf-alto-path-vector-13.txt
Please reply to Vijay and confirm whether there are anything missing or open issues which haven’t been closed.

-Qin (With chair hat on)
发件人: alto [mailto:[email-masked]] 代表 Vijay Gurbani
发送时间: 2020年12月2日 1:36
收件人: IETF ALTO <[email-masked]>
主题: [alto] Shepherd writeup for path-vector (draft)

All: I have started the shepherd review of path-vector  The review is below.
The token is with me to do a chair/shepherd review of the draft.  With the semester coming to a close and grading to do, etc., I have reserved the week starting Dec-16 to do the shepherd review of the draft.

In the meantime, please go through the draft shepherd writeup and let me know if I have erred anywhere.

Thanks,

- vijay
---------------------------------------------------------------------------------------------
Shepherd writeup for draft-ietf-alto-path-vector-13

1. Summary.

The document shepherd is Vijay K. Gurbani, and the responsible area director is Martin Duke.

The document is a Standards Track document, targeted as a Proposed Standard.  The WG has chosen the requested publication type since this draft extends the base ALTO protocol in a normative manner.  Specifically, the document seeks to extend the base ALTO protocol (RFC 7285) to provide the concept of "Abstract Network Elements" (ANE).  ANEs are an abstraction of physical network components --- routers, etc. --- that handle (switch) packets.  An application whose performance may be impacted by a particular traversal path in the network may wish to consult the ANEs to determine an optimized path to the destination.

This draft is a major conceptual advance in the abstractions provided by the base ALTO protocol.

2. Review and consensus.
This work is mature.  It started off as an individual submission in March 2015, and was adopted as a WG deliverable in May 2017.  A detailed review of this draft was provided early on by Sabine Randriamasy [1,2,3] shortly after it was adopted.  Version -04 was further reviewed by Danny Perez [4] and Qiao Xiang [5] in 2018, and the work progressed appreciably between 2018 and 2019, resulting in the release of -09 in November 2019.

A WGLC was initiated on Sep-28-2020, and a review was provided by Qiao Xiang [6] and Luis Contreras [7] on version -11.  Version -12 included the comments from Qiao and Luis, with version -13 following with some minor revisions.

Earlier versions of path-vector have been implemented (without the integration of unified-props); the implementation was used in a super computing conference demonstration for OpenFlow-based networks [8].  The latest version of path-vector is being implemented and will be open-sourced on GitHub [9].

The shepherd has an action item to review version -13.

3. Intellectual property
All of the authors have confirmed with the shephered that they are not aware of any IPR filed with respect to the draft.

4. Other points
IDNits reports 1 error, 7 warnings, and 2 comments.

[1] https://mailarchive.ietf.org/arch/msg/alto/IQ0WwgWewFKJkvzZSIQRhkiN-hc/
[2] https://mailarchive.ietf.org/arch/msg/alto/4wa_kXE4GUrigZ33TBCVVuwBuiw/
[3] https://mailarchive.ietf.org/arch/msg/alto/GGroJgfL5XGuH1ydWOLmISCPMKY/
[4] https://mailarchive.ietf.org/arch/msg/alto/HSGkZ2o4JvneiiYiVSGcCZjDVSQ/
[5] https://mailarchive.ietf.org/arch/msg/alto/qnIBXzFEiYxMDm9kvHLH53qbn_Y/
[6] https://mailarchive.ietf.org/arch/msg/alto/uwFNjekGcc3zMdSKleHU7eIdsW4/
[7] https://mailarchive.ietf.org/arch/msg/alto/D5jkRGws2c75paw6yP8_5_40ViY/
[8] https://github.com/openalto/mercator-setup
[9] https://github.com/openalto/sextant

---

From: [email-masked]
Date: Tue, 12 Jan 2021 17:46:53 +0800 (GMT+08:00)

Hi Qin,

Thanks for the notification! I will fix the IDNits errors as soon as possible.

Best,
Kai

2021-01-12 09:45:08"Qin Wu" <[email-masked]>wrote:

-Qin (With chair hat on)

Thanks,

- vijay

1. Summary.

2. Review and consensus.

3. Intellectual property

4. Other points

---

From: [email-masked]
Date: Tue, 12 Jan 2021 19:39:06 +0800 (GMT+08:00)

Hi Vijay,

How do you do? We have fixed most of the IDNits errors/warnings with a new revision -14. The remaining warnings are:

1. IDNits identifes [TBD] as references but we are using them in examples as placeholders for content length values.

2. IDNits thinks the version of [I-D.yang-alto-deliver-functions-over-networks] is -00 but the latest version as we used in the draft is -01.

How do you suggest we proceed here? Do you think we can submit -14 right now? Or we should wait for your review on -13?

Thanks!

Best,

Kai

-----Original Messages-----
From:[email-masked]
Sent Time:2021-01-12 17:46:53 (Tuesday)
To: "Qin Wu" <[email-masked]>
Cc: "IETF ALTO" <[email-masked]>
Subject: Re: [alto] Shepherd writeup for path-vector (draft)

Hi Qin,

Best,
Kai

-Qin (With chair hat on)

Thanks,

- vijay

1. Summary.

2. Review and consensus.

3. Intellectual property

4. Other points

---

From: Vijay Gurbani <[email-masked]>
Date: Tue, 12 Jan 2021 08:33:33 -0600

Dear Kai: Happy new year.

I am in the process of doing a chair review of path-vector and
unified-props.  My suggestion is that the nits can be addressed after I
post my chair review on the mailing list.
I am reviewing unified-props this week, so I will get to path-vector next
week.
Thanks,
- vijay

On Tue, Jan 12, 2021 at 5:39 AM <[email-masked]> wrote:

>
> Hi Vijay,
>
>
> How do you do? We have fixed most of the IDNits errors/warnings with a new
> revision -14. The remaining warnings are:
>
>
> 1. IDNits identifes [TBD] as references but we are using them in examples
> as placeholders for content length values.
>
> 2. IDNits thinks the version of
> [I-D.yang-alto-deliver-functions-over-networks] is -00 but the latest
> version as we used in the draft is -01.
>
>
> How do you suggest we proceed here? Do you think we can submit -14 right
> now? Or we should wait for your review on -13?
>
>
> Thanks!
>
>
> Best,
>
> Kai
>
>
> *From:[email-masked]
> *Sent Time:*2021-01-12 17:46:53 (Tuesday)
> *To:* "Qin Wu" <[email-masked]>
> *Cc:* "IETF ALTO" <[email-masked]>
> *Subject:* Re: [alto] Shepherd writeup for path-vector (draft)
>
> Hi Qin,
>
>
> *发件人:* alto [mailto:[email-masked]] *代表 *Vijay Gurbani
> *发送时间:* 2020年12月2日 1:36
> *收件人:* IETF ALTO <[email-masked]>
> *主题:* [alto] Shepherd writeup for path-vector (draft)
>
>
>
> The token is with me to do a chair/shepherd review of the draft.  With the
> semester coming to a close and grading to do, etc., I have reserved the
> week starting Dec-16 to do the shepherd review of the draft.
>
>
>
> The document is a Standards Track document, targeted as a Proposed
> Standard.  The WG has chosen the requested publication type since this
> draft extends the base ALTO protocol in a normative manner.  Specifically,
> the document seeks to extend the base ALTO protocol (RFC 7285) to provide
> the concept of "Abstract Network Elements" (ANE).  ANEs are an abstraction
> of physical network components --- routers, etc. --- that handle (switch)
> packets.  An application whose performance may be impacted by a particular
> traversal path in the network may wish to consult the ANEs to determine an
> optimized path to the destination.
>
> This work is mature.  It started off as an individual submission in March
> 2015, and was adopted as a WG deliverable in May 2017.  A detailed review
> of this draft was provided early on by Sabine Randriamasy [1,2,3] shortly
> after it was adopted.  Version -04 was further reviewed by Danny Perez [4]
> and Qiao Xiang [5] in 2018, and the work progressed appreciably between
> 2018 and 2019, resulting in the release of -09 in November 2019.
>
> A WGLC was initiated on Sep-28-2020, and a review was provided by Qiao
> Xiang [6] and Luis Contreras [7] on version -11.  Version -12 included the
> comments from Qiao and Luis, with version -13 following with some minor
> revisions.
>
> Earlier versions of path-vector have been implemented (without the
> integration of unified-props); the implementation was used in a super
> computing conference demonstration for OpenFlow-based networks [8].  The
> latest version of path-vector is being implemented and will be open-sourced
> on GitHub [9].
>
> All of the authors have confirmed with the shephered that they are not
> aware of any IPR filed with respect to the draft.
>
> 4. Other points
> [1]
> https://mailarchive.ietf.org/arch/msg/alto/IQ0WwgWewFKJkvzZSIQRhkiN-hc/
> [2]
> https://mailarchive.ietf.org/arch/msg/alto/4wa_kXE4GUrigZ33TBCVVuwBuiw/
> [3]
> https://mailarchive.ietf.org/arch/msg/alto/GGroJgfL5XGuH1ydWOLmISCPMKY/
> [4]
> https://mailarchive.ietf.org/arch/msg/alto/HSGkZ2o4JvneiiYiVSGcCZjDVSQ/
> [5]
> https://mailarchive.ietf.org/arch/msg/alto/qnIBXzFEiYxMDm9kvHLH53qbn_Y/
> [6]
> https://mailarchive.ietf.org/arch/msg/alto/uwFNjekGcc3zMdSKleHU7eIdsW4/
> [7]
> https://mailarchive.ietf.org/arch/msg/alto/D5jkRGws2c75paw6yP8_5_40ViY/

---

From: [email-masked]
Date: Tue, 12 Jan 2021 22:44:31 +0800 (GMT+08:00)

Hi Vijay,

Happy New Year!

No problem at all. We will wait for the chair review and submit a new version based on that.

Thanks!

Best,
Kai

2021-01-12 22:33:33"Vijay Gurbani" <[email-masked]>wrote:

I am in the process of doing a chair review of path-vector and unified-props.  My suggestion is that the nits can be addressed after I post my chair review on the mailing list.
I am reviewing unified-props this week, so I will get to path-vector next week.
Thanks,
- vijay

Hi Vijay,

Thanks!

Best,

Kai

-----Original Messages-----
From:[email-masked]

Hi Qin,

Best,
Kai

-Qin (With chair hat on)

Thanks,

- vijay

1. Summary.

2. Review and consensus.

3. Intellectual property

4. Other points