Subject: Re: [alto] ALTO Draft ReCharter WG review - extensible set of policy attributes

From: Qin Wu <[email-masked]>
Date: Thu, 11 Mar 2021 08:32:24 +0000

Hi, Sabine:
发件人: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) [mailto:[email-masked]]
发送时间: 2021年3月11日 1:55
收件人: Qin Wu <[email-masked]>; IETF ALTO <[email-masked]>
抄送: [email-masked]; [email-masked]
主题: RE: ALTO Draft ReCharter WG review - extensible set of policy attributes

Hello ALTO WG,

Regarding the proposed work item on “Protocol extensions to support a richer and extensible set of policy attributes in ALTO information update request and response” (GPE for short) , I would like to add the following:

This work item can be useful, among others, to allow a UE getting cellular network KPIs from an ALTO Server, to figure out for example whether the cell is congested, or which cell to choose.

An ALTO Server cannot provide real-time information. With the proposed extensions, it can indicate a number of real-time network parameters against which ALTO cost values can be modulated.

[Qin]: Yes, the current ALTO server can only provide non-real time or near real time information, performance metrics work allows ALTO server expose performance data. If ALTO protocol is extended to support pub sub mechanism,
Providing real time information will not be an issue.

But I agree in many cases, providing real time information is not necessary, e.g., cloud gaming use case provided Tencent and china mobile, their case is different from your proposed case, they will use cloud gaming server as ALTO client to get needed information.

These parameters are received by UEs directly from the network and not from ALTO. The UE receives an array of ALTO cell KPI values that each depend on the value of a parameter. The UE can pick the  ALTO value corresponding to the value of the real-time parameter received from the network. Thus, the UE modulates the received ALTO values in real-time.

[Qin]: your case is UE centric solution, UE gets network KPI from ALTO server and get real time parameter from another data source in the Network, what is not clear is how real time parameter is correlated with Network KPI information within UE.
Also the interface between UE and RAN is not in the scope of ALTO work, I think.

This use-case is illustrated in the slides presented at the previous IETF 109 ALTO WG meeting, see (1), slide 4. A preliminary design with example IRD and ALTO request and response can be found in slides 7 and 8.

Any feedback is more than welcome,
(1)  https://datatracker.ietf.org/meeting/109/materials/slides-109-alto-proposed-recharter-item-general-alto-protocol-extensions-00
Thanks,
Sabine

From: alto <[email-masked]<mailto:[email-masked]>> On Behalf Of Qin Wu
Sent: Monday, February 22, 2021 2:51 PM
To: IETF ALTO <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [alto] ALTO Draft ReCharter WG review

Hi, :
We have requested one hour session for ALTO WG meeting in the upcoming IETF 110, which is arranged on Friday, March 12, 14:30-15:30(UTC).
The goal is to boil down ALTO recharter and have consensus on charter contents in IETF 110.
To get this goal, an updated inline draft charter text for ALTO has just been posted to this list,

This charter has received a couple of rounds of informal review from WG members, chairs and our Ads from brief to deep thorough, 5 new chartered items have been listed.
We would like to solicit feedback on these new chartered items and your use case, deployment, idea corresponding to these new chartered items.
Sharing your past deployment story will also be appreciated.

============================================================================================
The ALTO working group was established in 2008 to devise a request/response protocol to allow a host to benefit from a server that is more cognizant of the network infrastructure than the host is.

The working group has developed an HTTP-based protocol and recent work has reported large-scale deployment of ALTO based solutions supporting applications such as content distribution networks (CDN).

ALTO is now proposed as a component for cloud-based interactive applications, large-scale data analytics, multi-cloud SD-WAN deployment, and distributed
computing. In all these cases, exposing network information such as abstract topologies and network function deployment location helps applications.

To support these emerging uses, extensions are needed, and additional functional and architectural features need to be considered as follows:

o Protocol extensions to support a richer and extensible set of policy attributes in ALTO information update request and response. Such policy attributes may indicate information dependency (e.g., ALTO path-cost/QoS properties with dependency on real-time network  indications), optimization criteria (e.g., lowest latency/throughput network performance objective), and constraints (e.g., relaxation bound of optimization criteria, domain or network node to be traversed, diversity and redundancy of paths).

o Protocol extensions for facilitating operational automation tasks and improving transport efficiency. In particular, extensions to provide "pub/sub" mechanisms to allow the client to request and receive a diverse types (such as event-triggered/sporadic, continuous), continuous, customized feed of publisher-generated information. Efforts developed in other working groups such as MQTT Publish / Subscribe Architecture, WebSub, Subscription to YANG Notifications will be considered, and issues such as scalability (e.g., using unicast or broadcast/multicast, and periodicity of object updates) should be considered.

o The working group will investigate the configuration, management, and operation of ALTO systems and may develop suitable data models.

o Extensions to ALTO services to support multi-domain settings. ALTO is currently specified for a single ALTO server in a single administrative domain, but a network may consist of
multiple domains and the potential information sources may not be limited to a certain domain. The working group will investigate extending the ALTO framework to (1) specify multi-ALTO-server protocol flow and usage guidelines when an ALTO service involves network paths spanning multiple domains with multiple ALTO servers, and (2) extend or introduce ALTO
services allowing east-west interfaces for multiple ALTO server integration and collaboration. The specifications and extensions should use existing services whenever possible. The specifications and extensions should consider realistic complexities including incremental deployment, dynamicity, and security issues such as access control, authorization (e.g., an ALTO server provides information for a network that the server has no authorization), and privacy protection in multi-domain settings.

o The working group will update RFC 7971 to provide operational considerations for recent protocol extensions (e.g., cost calendar, unified properties, and path vector) and new extensions that the WG develops. New considerations will include decisions about the set of information resources (e.g., what metrics to use), notification of changes either in proactive or reactive mode (e.g., pull the backend, or trigger just-in-time measurements), aggregation/processing of the collected information  (e.g., compute information and network information )according to the clients’ requests, and integration with new transport mechanisms (e.g., HTTP/2 and HTTP/3).

When the WG considers standardizing information that the ALTO server could provide, the following criteria are important
to ensure real feasibility:

- Can the ALTO server realistically provide (measure or derive) that information?

- Is it information that the ALTO client cannot find easily some other way?

- Is the distribution of the information allowed by the operator of the network? Does the exposure of the information introduce privacy and information leakage concerns?

Issues related to the specific content exchanged in systems that make use of ALTO are excluded from the WG's scope, as is the issue of dealing with enforcing the legality of the content. The WG will also not propose standards on how congestion is signaled, remediated, or avoided.

-Qin Wu (on behalf of chairs)

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 11 Mar 2021 10:00:44 +0000

Hi Qin,

Please see inline,
Thanks
Sabine

From: Qin Wu <[email-masked]>
Sent: Thursday, March 11, 2021 9:32 AM
To: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>; IETF ALTO <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: RE: ALTO Draft ReCharter WG review - extensible set of policy attributes

Hi, Sabine:
发件人: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) [mailto:[email-masked]]
发送时间: 2021年3月11日 1:55
收件人: Qin Wu <[email-masked]<mailto:[email-masked]>>; IETF ALTO <[email-masked]<mailto:[email-masked]>>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: RE: ALTO Draft ReCharter WG review - extensible set of policy attributes

Hello ALTO WG,

But I agree in many cases, providing real time information is not necessary, e.g., cloud gaming use case provided Tencent and china mobile, their case is different from your proposed case, they will use cloud gaming server as ALTO client to get needed information.
[ [SR] ] indeed, an ALTO client (AOC for short) can be beneficially integrated with a cloud gaming server (CGS for short) . In that case, the ALTO information provided by the ALTO Server (AOS for short) can be made aware of given specific parameters captured by the CGS at a different pace. This may speed up the process as well.

[Qin]: your case is UE centric solution, UE gets network KPI from ALTO server and get real time parameter from another data source in the Network, what is not clear is how real time parameter is correlated with Network KPI information within UE.
Also the interface between UE and RAN is not in the scope of ALTO work, I think.
[ [SR] ] definitely, the scope of the extension restricts to exchanges between AOS and AOC. The UE may have some agent that gathers and relates the RAN indicators and the ALTO information and passes the relevant costs to the application client. Again this agent is out of scope of ALTO.

Hi, :

---

From: "Y. Richard Yang" <[email-masked]>
Date: Thu, 11 Mar 2021 16:28:37 -0500

Hi Sabine, Qin,

Good discussions.

I support the use cases of the design direction. One suggestion is to look
at the design in a slightly abstract, general framework. In particular, the
abstract framework looks like this to me:

- Ve: A set of "volatile" (ephemeral) variables; Ve tends to be small,
fast-changing data;
- Vs: Another set of records that are stable and indexed by the
ephemeral variables; Vs can be large, but stable data.

There are two channels from the network to the application:
- Channel 1 for Ve
- Channel 2 for Vs

This definitely is a generic framework supported by some existing use cases
including what you presented.

In the general framework, Channel 1 can be ALTO or protocol specific. Since
it is short and needs low latency, it is more likely to be protocol
specific and embedded in some other protocol such as even data path
protocols (5G, ECN bits in IP); channel 2 is ALTO.

A couple of points to be considered when conducting further design:
- One thing we learned from SSE is the consistency between these two
channels (or more, as Ve can be carried by multiple channels, etc), and
- Document additional use cases beyond the demonstrated use cases.

Looking forward to talking to you (virtually) f2f tomorrow.

Richard

On Thu, Mar 11, 2021 at 5:01 AM Randriamasy, Sabine (Nokia -
FR/Paris-Saclay) <[email-masked]> wrote:

> Hi Qin,
>
>
>
> Please see inline,
>
> Thanks
>
> Sabine
>
>
>
> *From:* Qin Wu <[email-masked]>
> *Sent:* Thursday, March 11, 2021 9:32 AM
> *To:* Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <
> [email-masked]>; IETF ALTO <[email-masked]>
> *Cc:* [email-masked]; [email-masked]
> *Subject:* RE: ALTO Draft ReCharter WG review - extensible set of policy
> attributes
>
>
>
> Hi, Sabine:
>
> *发件人**:* Randriamasy, Sabine (Nokia - FR/Paris-Saclay) [
> mailto:[email-masked]
> <[email-masked]>]
> *发送时间**:* 2021年3月11日 1:55
> *收件人**:* Qin Wu <[email-masked]>; IETF ALTO <[email-masked]>
> *抄送**:* [email-masked]; [email-masked]
> *主题**:* RE: ALTO Draft ReCharter WG review - extensible set of policy
> attributes
>
>
>
> Hello ALTO WG,
>
>
>
> Regarding the proposed work item on “Protocol extensions to support a
> richer and extensible set of policy attributes in ALTO information update
> request and response” (GPE for short) , I would like to add the following:
>
>
>
> This work item can be useful, among others, to allow a UE getting cellular
> network KPIs from an ALTO Server, to figure out for example whether the
> cell is congested, or which cell to choose.
>
>
>
> An ALTO Server cannot provide real-time information. With the proposed
> extensions, it can indicate a number of real-time network parameters
> against which ALTO cost values can be modulated.
>
>
>
> [Qin]: Yes, the current ALTO server can only provide non-real time or near
> real time information, performance metrics work allows ALTO server expose
> performance data. If ALTO protocol is extended to support pub sub mechanism,
>
> But I agree in many cases, providing real time information is not
> necessary, e.g., cloud gaming use case provided Tencent and china mobile,
> their case is different from your proposed case, they will use cloud gaming
> server as ALTO client to get needed information.
>
> *[ [SR] ] indeed, an ALTO client (AOC for short) can be beneficially
> integrated with a cloud gaming server (CGS for short) . In that case, the
> ALTO information provided by the ALTO Server (AOS for short) can be made
> aware of given specific parameters captured by the CGS at a different pace.
> This may speed up the process as well.  *
>
>
>
> These parameters are received by UEs directly from the network and not
> from ALTO. The UE receives an array of ALTO cell KPI values that each
> depend on the value of a parameter. The UE can pick the  ALTO value
> corresponding to the value of the real-time parameter received from the
> network. Thus, the UE modulates the received ALTO values in real-time.
>
>
>
> [Qin]: your case is UE centric solution, UE gets network KPI from ALTO
> server and get real time parameter from another data source in the Network,
> what is not clear is how real time parameter is correlated with Network KPI
> information within UE.
>
> *[ [SR] ] definitely, the scope of the extension restricts to exchanges
> between AOS and AOC. The UE may have some agent that gathers and relates
> the RAN indicators and the ALTO information and passes the relevant costs
> to the application client. Again this agent is out of scope of ALTO. *
>
>
>
> This use-case is illustrated in the slides presented at the previous IETF
> 109 ALTO WG meeting, see (1), slide 4. A preliminary design with example
> IRD and ALTO request and response can be found in slides 7 and 8.
>
>
>
> (1)
> https://datatracker.ietf.org/meeting/109/materials/slides-109-alto-proposed-recharter-item-general-alto-protocol-extensions-00
>
> Thanks,
>
> Sabine
>
>
>
>
>
>
>
> *From:* alto <[email-masked]> *On Behalf Of *Qin Wu
> *Sent:* Monday, February 22, 2021 2:51 PM
> *To:* IETF ALTO <[email-masked]>
> *Cc:* [email-masked]; [email-masked]
> *Subject:* [alto] ALTO Draft ReCharter WG review
>
>
>
> Hi, :
>
> We have requested one hour session for ALTO WG meeting in the upcoming
> IETF 110, which is arranged on Friday, March 12, 14:30-15:30(UTC).
>
> We would like to solicit feedback on these new chartered items and your
> use case, deployment, idea corresponding to these new chartered items.
>
> The ALTO working group was established in 2008 to devise a
> request/response protocol to allow a host to benefit from a server that is
> more cognizant of the network infrastructure than the host is.
>
>
>
> The working group has developed an HTTP-based protocol and recent work has
> reported large-scale deployment of ALTO based solutions supporting
> applications such as content distribution networks (CDN).
>
>
>
> ALTO is now proposed as a component for cloud-based interactive
> applications, large-scale data analytics, multi-cloud SD-WAN deployment,
> and distributed
>
> computing. In all these cases, exposing network information such as
> abstract topologies and network function deployment location helps
> applications.
>
>
>
> To support these emerging uses, extensions are needed, and additional
> functional and architectural features need to be considered as follows:
>
>
>
> o Protocol extensions to support a richer and extensible set of policy
> attributes in ALTO information update request and response. Such policy
> attributes may indicate information dependency (e.g., ALTO path-cost/QoS
> properties with dependency on real-time network  indications), optimization
> criteria (e.g., lowest latency/throughput network performance objective),
> and constraints (e.g., relaxation bound of optimization criteria, domain or
> network node to be traversed, diversity and redundancy of paths).
>
>
>
> o Protocol extensions for facilitating operational automation tasks and
> improving transport efficiency. In particular, extensions to provide
> "pub/sub" mechanisms to allow the client to request and receive a diverse
> types (such as event-triggered/sporadic, continuous), continuous,
> customized feed of publisher-generated information. Efforts developed in
> other working groups such as MQTT Publish / Subscribe Architecture, WebSub,
> Subscription to YANG Notifications will be considered, and issues such as
> scalability (e.g., using unicast or broadcast/multicast, and periodicity of
> object updates) should be considered.
>
>
>
> o The working group will investigate the configuration, management, and
> operation of ALTO systems and may develop suitable data models.
>
>
>
> o Extensions to ALTO services to support multi-domain settings. ALTO is
> currently specified for a single ALTO server in a single administrative
> domain, but a network may consist of
>
> multiple domains and the potential information sources may not be limited
> to a certain domain. The working group will investigate extending the ALTO
> framework to (1) specify multi-ALTO-server protocol flow and usage
> guidelines when an ALTO service involves network paths spanning multiple
> domains with multiple ALTO servers, and (2) extend or introduce ALTO
>
> services allowing east-west interfaces for multiple ALTO server
> integration and collaboration. The specifications and extensions should use
> existing services whenever possible. The specifications and extensions
> should consider realistic complexities including incremental deployment,
> dynamicity, and security issues such as access control, authorization
> (e.g., an ALTO server provides information for a network that the server
> has no authorization), and privacy protection in multi-domain settings.
>
>
>
> o The working group will update RFC 7971 to provide operational
> considerations for recent protocol extensions (e.g., cost calendar, unified
> properties, and path vector) and new extensions that the WG develops. New
> considerations will include decisions about the set of information
> resources (e.g., what metrics to use), notification of changes either in
> proactive or reactive mode (e.g., pull the backend, or trigger just-in-time
> measurements), aggregation/processing of the collected information  (e.g.,
> compute information and network information )according to the clients’
> requests, and integration with new transport mechanisms (e.g., HTTP/2 and
> HTTP/3).
>
>
>
> When the WG considers standardizing information that the ALTO server could
> provide, the following criteria are important
>
> - Is the distribution of the information allowed by the operator of the
> network? Does the exposure of the information introduce privacy and
> information leakage concerns?
>
>
>
> Issues related to the specific content exchanged in systems that make use
> of ALTO are excluded from the WG's scope, as is the issue of dealing with
> enforcing the legality of the content. The WG will also not propose
> standards on how congestion is signaled, remediated, or avoided.
>
>
>
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>

---

From: chunshxiong(熊春山) <[email-masked]>
Date: Fri, 12 Mar 2021 06:37:31 +0000

Hello all,

@Randriamasy, Sabine (Nokia - FR/Paris-Saclay)<mailto:[email-masked]>,  You say “An ALTO Server cannot provide real-time information".
I almost agree with your point.

But I want the ALTO Server to support very quick notification information to the ALTO Client, if there is a quick change as provided in my other email.

I think one goal of ALTO Server is not to  provide very frequent notification to the ALTO Client, but If there is some quick or big change, the ALTO Server needs very quickly notify the ALTO Client, just this, not repeated and continuous notify. I think this quick notification is very helpful for the cloud gaming server to adaptive change the coding scheme. But the cloud gaming does not need the ALTO server to repeated notify the current network bitrates. Cloud gaming server needs the change information not the status information. For the cloud gaming sever can “intelligently” detect the slow change information, but it is very hard for the gaming server to detect the quick change in short time (because there is buffer in the client and Server), in such case, if the ALTO server can provide such quick (QoS) change information to the cloud gaming server, the cloud gaming server can quickly change its coding scheme.

So, Yes, the cloud gaming server does NOT need the real-time QoS information, but the cloud gaming server does need the real-time QUICK QOS CHANGE information.

But, this Quick QoS change (e.g. Alternative QoS profile) is defined to trigger the cloud server to make some changes(e.g. encoding scheme change).  It should be avoid to define a  QUICK QOS change that does not trigger the cloud server to make any changes. So the real-time frequently reporting the current QOS to the cloud server is really not needed,  this repeated and continuous reporting/notification only creates a lot of message loads and no help for the cloud gaming server.

Also this Quick QoS Change notification should not be too frequent, the QUICK QoS change notification should be minutes level, i.e. one notification per one minute. In some cases, it is possible that the notification can be several notifications per one minutes, but the average rate should be less than one notification per one minute.

BRs,
Chunshan Xiong

From: alto <[email-masked]> On Behalf Of Y. Richard Yang
Sent: Friday, March 12, 2021 5:29 AM
To: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>
Cc: [email-masked]; [email-masked]; Qin Wu <[email-masked]>; IETF ALTO <[email-masked]>
Subject: Re: [alto] ALTO Draft ReCharter WG review - extensible set of policy attributes(Internet mail)

Hi Sabine, Qin,

Good discussions.

I support the use cases of the design direction. One suggestion is to look at the design in a slightly abstract, general framework. In particular, the abstract framework looks like this to me:

- Ve: A set of "volatile" (ephemeral) variables; Ve tends to be small, fast-changing data;
- Vs: Another set of records that are stable and indexed by the ephemeral variables; Vs can be large, but stable data.

This definitely is a generic framework supported by some existing use cases including what you presented.

In the general framework, Channel 1 can be ALTO or protocol specific. Since it is short and needs low latency, it is more likely to be protocol specific and embedded in some other protocol such as even data path protocols (5G, ECN bits in IP); channel 2 is ALTO.

A couple of points to be considered when conducting further design:
- One thing we learned from SSE is the consistency between these two channels (or more, as Ve can be carried by multiple channels, etc), and
- Document additional use cases beyond the demonstrated use cases.

Richard

On Thu, Mar 11, 2021 at 5:01 AM Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Qin,

Please see inline,
Thanks
Sabine

From: Qin Wu <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, March 11, 2021 9:32 AM
To: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>>; IETF ALTO <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: ALTO Draft ReCharter WG review - extensible set of policy attributes

Hi, Sabine:

Hello ALTO WG,

Hi, :

-Qin Wu (on behalf of chairs)
_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/alto

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 12 Mar 2021 12:22:42 +0000

Hi Richard,

Thanks for your thoughts. This is definitely the path we want to take together with a flexible design to encode and represent information carried by Ve.
Meet you virtually at the ALTO session
Cheers,
Sabine

From: Y. Richard Yang <[email-masked]>
Sent: Thursday, March 11, 2021 10:29 PM
To: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>
Cc: Qin Wu <[email-masked]>; IETF ALTO <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [alto] ALTO Draft ReCharter WG review - extensible set of policy attributes

Hi Sabine, Qin,

Good discussions.

Richard

Please see inline,
Thanks
Sabine

Hi, Sabine:

Hello ALTO WG,

Hi, :

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 12 Mar 2021 13:11:17 +0000

Hello Chunchan,

Thanks for the clarification. If I understand well:
- the cloud gaming server (CGS) needs notifications on QoS CHANGE information. This change would be conveyed by an ALTO Server that abstracts NEF information to the ALTO Client in the CGS.
- only QoS CHANGES upon e.g. exceeding some hysteresis threshold are useful because Continuous QoS information is needless and causes signaling overhead. These changes should be reported to the CGS immediately. To this end, ALTO extended pub/sub is needed.
- regarding the pace of the notification, I would have a question: Your e-mail says “the cloud gaming server does need the real-time QUICK QOS CHANGE information” and later specifies “Quick QoS Change notification should not be too frequent, the QUICK QoS change notification should be minutes level”.
So what frequency does the term “real-time” in the 1rst sentence cover? Maybe I missed something. Definitely minute-level notification is achievable, given the limited size of the topology covered by ALTO in this case.

Another question:
- the number of possible QoS values Qi are quite limited and this “volatile” and light information would be conveyed with a given channel, say the channel “Ve” mentioned earlier by Richard.
- The longer term costs and properties reflecting QoS impacting KPIs such as latency L and throughput T would then be conveyed via ALTO channel “Vs” in an asynchronous way
-  would the values of these costs and properties be made dependent on the values of Qi?

Thanks,
Sabine

From: chunshxiong(熊春山) <[email-masked]>
Sent: Friday, March 12, 2021 7:38 AM
To: Y. Richard Yang <[email-masked]>; Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>
Cc: [email-masked]; [email-masked]; Qin Wu <[email-masked]>; IETF ALTO <[email-masked]>
Subject: RE: [alto] ALTO Draft ReCharter WG review - extensible set of policy attributes(Internet mail)

Hello all,

BRs,
Chunshan Xiong

From: alto <[email-masked]<mailto:[email-masked]>> On Behalf Of Y. Richard Yang
Sent: Friday, March 12, 2021 5:29 AM
To: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Qin Wu <[email-masked]<mailto:[email-masked]>>; IETF ALTO <[email-masked]<mailto:[email-masked]>>
Subject: Re: [alto] ALTO Draft ReCharter WG review - extensible set of policy attributes(Internet mail)

Hi Sabine, Qin,

Good discussions.

Richard

Please see inline,
Thanks
Sabine

Hi, Sabine:

Hello ALTO WG,

Hi, :