Subject: [alto] Bringing operation automation cases to the list

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Wed, 10 Mar 2021 22:17:48 +0000

Hi all,

Apologies for the time taking to post the operation automation cases to the list.

As part of the re-charter discussion, for use cases will be considered for supporting the proposal in which respect to ALTO extensions for operation automation.

Case 1. Extensions to RFC 7971 leveraging on previous protocol extensions (e.g., cost calendar, path vector) that can make necessary new architectural and deployment considerations

Case 2. Usage of ALTO for combined compute and network selection (e.g., for optimal edge computing service placement)

Case 3. Extensions to ALTO for acting as aggregator of information from different sources (e.g., TEDB, LSP DB, etc)

Case 4. Overlay / underlay integration supported by ALTO (e.g., CDN)

Any comment, suggestion or indication is more than welcome.

Thanks

Luis

__________________________________
Luis M. Contreras

Technology and Planning
Transport, IP and Interconnection Networks
Telefónica I+D / Global CTIO unit / Telefónica

Distrito Telefónica, Edificio Sur 3, Planta 3
28050 Madrid
España / Spain

Skype (Lync): +34 91 312 9084
Mobile: +34 680 947 650
[email-masked]<mailto:[email-masked]>

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Y. Richard Yang" <[email-masked]>
Date: Wed, 10 Mar 2021 23:51:50 -0500

Hi Luis,

Good summary. Please see below.

On Wed, Mar 10, 2021 at 5:18 PM LUIS MIGUEL CONTRERAS MURILLO <
[email-masked]> wrote:

> As part of the re-charter discussion, four use cases will be considered
> for supporting the proposal in which respect to ALTO extensions for
> operation automation.
>
>
>
> Case 1. Extensions to RFC 7971 leveraging on previous protocol extensions
> (e.g., cost calendar, path vector) that can make necessary new
> architectural and deployment considerations
>

RFC7971 is valuable and hence an update to include the effects of protocol
extensions is highly valuable. I understand that cost calendar and path
vector are examples, and other extensions such as SSE can be included and
we want to make sure to do a relatively comprehensive update.

> Case 2. Usage of ALTO for combined compute and network selection (e.g.,
> for optimal edge computing service placement).
>

Does Case 2 belong to general protocol extension or operation automation?

>
>
> Case 3. Extensions to ALTO for acting as aggregator of information from
> different sources (e.g., TEDB, LSP DB, etc)
>

Case 3 is definitely a good use case supporting operation automation.

> Case 4. Overlay / underlay integration supported by ALTO (e.g., CDN).
>
>
>

Overlay/underlay integration can have many aspects. So the goal is to focus
on the operation automation aspect? One possibility is to define operation
automation broadly, including operation automation of not only ALTO but the
overall system (i.e., the integrated overlay/underlay). If this is the
case, we may want to specify the scope well.

Looking forward to a great discussion on Friday.

Richard

> [email-masked]
>
>
>
>
>
> ------------------------------
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>

-- 
-- 
 =====================================
| Y. Richard Yang <[email-masked]>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================