Subject: [alto] I-D Action: draft-ietf-alto-unified-props-new-17.txt

From: [email-masked]
Date: Fri, 16 Apr 2021 11:54:02 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Application-Layer Traffic Optimization WG of the IETF.

        Title           : ALTO Extension: Entity Property Maps
        Authors         : Wendy Roome
                          Sabine Randriamasy
                          Y. Richard Yang
                          Jingxuan Jensen Zhang
                          Kai Gao
	Filename        : draft-ietf-alto-unified-props-new-17.txt
	Pages           : 59
	Date            : 2021-04-16

Abstract:
   This document extends the base Application-Layer Traffic Optimization
   (ALTO) Protocol by generalizing the concept of "endpoint properties"
   as applied to endpoints as defined by IP addresses to endpoints
   defined by a wider set of objects.  Further, these properties are
   presented as maps, similar to the network and cost maps in the base
   ALTO protocol.  The protocol is extended in two major directions.
   First, from endpoints restricted to IP addresses to entities covering
   a wider and extensible set of objects; second, from properties on
   specific endpoints to entire entity property maps.  These extensions
   introduce additional features allowing entities and property values
   to be specific to a given information resource.  This is made
   possible by a generic and flexible design of entity and property
   types.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-alto-unified-props-new/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-alto-unified-props-new-17
https://datatracker.ietf.org/doc/html/draft-ietf-alto-unified-props-new-17

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-alto-unified-props-new-17

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 16 Apr 2021 19:05:22 +0000

Dear Vijay,

A new version 17 of the "ALTO Extension: Entity Property Maps" has been uploaded and hopefully addresses the pending review comments.
It can be found at the link below, by clicking on the number "16" on the ALTO status pages.
https://tools.ietf.org/html/draft-ietf-alto-unified-props-new-17
Below is a digest of the updates and we look forward to having your feedback.
A detailed "diff" can be sent if you wish. 

Best regards,
Sabine & co-authors
=========================
updates in draft-ietf-alto-unified-props-new-17
=========================
Previous V16 was submitted to address Vijay's review of v15
This V17 addresses remaining issues on V15 review

Main update is the addition of a substantial Section 11. Security Considerations. 
The other updates are as follows:  

- Defined terminology nomenclature used in 4.4.  Entity Hierarchy and Property Inheritance
--- related (small) edits in subsections 

- In Section 4.7 Defining Information Resource for Resource-Specific Property Values
text was clarified and moved back from 4.6.1 to 4.7. Section 4.7.1 (of V15) with examples was merged with 4.7 

- Clarified text on defining information resources in sections 4.6 and 4.7, as review reflects it was unclear
--- added example in 4.6.2 of entity domain types that do  not have a defining resource
--- Clarified text in related IANA sections 12.2.2 and 12.3

- Added normative "MUST" wherever needed 
--- section 4.3.  Resource-Specific Entity Property Value
--- 4.6.1.  Defining Information Resource and its Media Type
--- sections 12.2.2 and 12.3 on item "Media type of defining information resource"
- Replaced lower case "must" with other words where convenient

- Rewording
---  Clarified sentence distinguishes domain name and domain type in 3.2.1 
--- Added introduction sentence in Section 4 Advanced Features... 
- Typos and nits in sections  5.1.2, 8.6

- Added normative and informative references

>-----Original Message-----
>From: alto <[email-masked]> On Behalf Of [email-masked]
>Sent: Friday, April 16, 2021 8:54 PM
>To: [email-masked]
>Cc: [email-masked]
>Subject: [alto] I-D Action: draft-ietf-alto-unified-props-new-17.txt
>
>
>_______________________________________________
>alto mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/alto

---

From: Vijay Gurbani <[email-masked]>
Date: Sat, 17 Apr 2021 10:42:01 -0500

Dear Sabine: Excellent. I will start to wrap up the post-chair review
process next week on this and path-vector so they can be sent to IESG.

Have a nice weekend.

On Fri, Apr 16, 2021, 2:05 PM Randriamasy, Sabine (Nokia - FR/Paris-Saclay)
<[email-masked]> wrote:

> Dear Vijay,
>
> A new version 17 of the "ALTO Extension: Entity Property Maps" has been
> uploaded and hopefully addresses the pending review comments.
> >This draft is a work item of the Application-Layer Traffic Optimization
> WG of
> >the IETF.
> >