Subject: [alto] I-D Action: draft-ietf-alto-unified-props-new-18.txt

From: [email-masked]
Date: Thu, 12 Aug 2021 07:44:35 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Application-Layer Traffic Optimization WG of the IETF.

        Title           : ALTO Extension: Entity Property Maps
        Authors         : Wendy Roome
                          Sabine Randriamasy
                          Y. Richard Yang
                          Jingxuan Jensen Zhang
                          Kai Gao
	Filename        : draft-ietf-alto-unified-props-new-18.txt
	Pages           : 60
	Date            : 2021-08-12

Abstract:
   This document extends the base Application-Layer Traffic Optimization
   (ALTO) Protocol by generalizing the concept of "endpoint properties"
   to entities defined by a wide set of objects, instead of only IP
   addresses.  Further, these properties are presented as maps, similar
   to the network and cost maps in the base ALTO protocol.  The protocol
   is extended in two major directions.  First, from endpoints
   restricted to IP addresses to entities covering a wider and
   extensible set of objects; second, from properties on specific
   endpoints to entire entity property maps.  These extensions introduce
   additional features allowing entities and property values to be
   specific to a given information resource.  This is made possible by a
   generic and flexible design of entity and property types.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-alto-unified-props-new/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-alto-unified-props-new-18

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-alto-unified-props-new-18

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 12 Aug 2021 15:38:07 +0000

Hello Martin and ALTO WG,

Thanks again Martin for your thorough review and discussions that allowed to improve the document and enrich the capabilities of this extension. 

This new version addresses the comments in the AD review and is available at
https://datatracker.ietf.org/doc/html/draft-ietf-alto-unified-props-new-18
You may check the diffs here
https://www.ietf.org/rfcdiff?url2=draft-ietf-alto-unified-props-new-18

The main updates:
- remove unused and unclear terms and clarifies text in many places,
- Filtered Property Map (FPM) queries now allow empty lists of entities and properties. Empty lists are interpreted as representing the full set of entities and properties. 
- put tables and text in coherency in IANA sections 12.2 and 12.3. Though due to lack of space, only added a column "mapping to ALTO address type" in Table 2.  Some text on the security issue item referring to relevant sections was added in the introduction of section 12.2 and 12.3 

The key updates were added in section 8 "Filtered Property Map". (FPM)
They address the question on: how a Client can obtain the list of entityIDs that can be used as input to a FPM without having to download a full property map. The FPM query input format and response have been updated accordingly. 
- In Section 8: a paragraph explains why this is useful for a Client 
- In section 8.3 Accept Input Parameters: the format of query object ReqFilteredPropertyMap is revised and explained to support this. The property member is optional.
- In section 8.6 Filtered Property Map Response: 
--- an error case is added when input member "entities" is absent 
--- text explains how, when the "property" member is absent in the query, the Server returns an empty value for the queried entities. 

We hope the updates are meeting the review expectations.
Thanks,
Sabine and authors 

>-----Original Message-----
>From: alto <[email-masked]> On Behalf Of [email-masked]
>Sent: Thursday, August 12, 2021 4:45 PM
>To: [email-masked]
>Cc: [email-masked]
>Subject: [alto] I-D Action: draft-ietf-alto-unified-props-new-18.txt
>
>
>_______________________________________________
>alto mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/alto

---

From: Martin Duke <[email-masked]>
Date: Thu, 12 Aug 2021 13:33:28 -0700

Hi Sabine,

Minor comments that aren't blocking last call:

(7) Eliminate the commas around "for the Client"

(8.3) Isn't " The client wants all properties values on all the entities,"
the use case for the (unfiltered) property map?

(8.3) s/Sever/Server

On Thu, Aug 12, 2021 at 8:38 AM Randriamasy, Sabine (Nokia -
FR/Paris-Saclay) <[email-masked]> wrote:

> Thanks again Martin for your thorough review and discussions that allowed
> to improve the document and enrich the capabilities of this extension.
>
> - Filtered Property Map (FPM) queries now allow empty lists of entities
> and properties. Empty lists are interpreted as representing the full set of
> entities and properties.
> - put tables and text in coherency in IANA sections 12.2 and 12.3. Though
> due to lack of space, only added a column "mapping to ALTO address type" in
> Table 2.  Some text on the security issue item referring to relevant
> sections was added in the introduction of section 12.2 and 12.3
>
> They address the question on: how a Client can obtain the list of
> entityIDs that can be used as input to a FPM without having to download a
> full property map. The FPM query input format and response have been
> updated accordingly.
> - In section 8.3 Accept Input Parameters: the format of query object
> ReqFilteredPropertyMap is revised and explained to support this. The
> property member is optional.
> --- text explains how, when the "property" member is absent in the query,
> the Server returns an empty value for the queried entities.
>
> >This draft is a work item of the Application-Layer Traffic Optimization
> WG of
> >the IETF.
> >

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 12 Aug 2021 21:37:06 +0000

Hi Martin,

Thanks for your feedback and further comments.
Please see inline. I will see to prepare the updates for the newt iterations of the document.
Best regards,
Sabine

From: Martin Duke <[email-masked]>
Sent: Thursday, August 12, 2021 10:33 PM
To: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>
Cc: IETF ALTO <[email-masked]>
Subject: Re: [alto] I-D Action: draft-ietf-alto-unified-props-new-18.txt

Hi Sabine,

(8.3) Isn't " The client wants all properties values on all the entities," the use case for the (unfiltered) property map?
[ [SR] ] It is indeed, we may mention that in the next versions.  If it adds something, we may also say that some Clients may prefer to systematically make filtered property map queries.

(8.3) s/Sever/Server

On Thu, Aug 12, 2021 at 8:38 AM Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>> wrote:
Hello Martin and ALTO WG,

The main updates:

>From: alto <[email-masked]<mailto:[email-masked]>> On Behalf Of [email-masked]<mailto:[email-masked]>
>To: [email-masked]<mailto:[email-masked]>
>Cc: [email-masked]<mailto:[email-masked]>
>[email-masked]<mailto:[email-masked]>

_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/alto