Subject: [alto] IETF 113 ALTO Hackathon

From: Jordi Ros Giralt <[email-masked]>
Date: Mon, 21 Mar 2022 13:00:11 +0000

Hi all,

I wanted to start thanking all of you who have worked in the ALTO hackathon project for the past weeks. Significant work was carried out by many of you during the last 2 months to make this a successful event. We started with the goal of performing 1 demo, and we ended up doing two and a half demos (a 150% more than originally planned for). Many of you (Jensen, Kai, Richard, Mahdi, and various Yale and Sichuan Univ. students) dedicated endless hours the past ten days, working across 3 times zones (USA, EU, Asia), including weekends. Thank you.

For those of you who could not attend yesterday, here are the final hackathon resources:

  *   Scrum dashboard: https://github.com/orgs/openalto/projects/1/views/1
  *   Repo: https://github.com/openalto/ietf-hackathon
  *   113 hackathon presentation: https://github.com/IETF-Hackathon/ietf113-project-presentations/blob/main/ietf-113-hackathon-alto.pdf

Please check slide #3 that summarizes the overall plan to manage the OpenALTO code base project (attached below too). We welcome anyone of you who wants to participate in the development of the code base to join us. Starting next week, we will be discussing the goals (epics) for the next four months targeting the next hackathon checkpoint in July.

Looking forward to discussions this week and to our weekly meetings thereafter.

Jordi on behalf of ALTO Code Base project.

---

From: "Y. Richard Yang" <[email-masked]>
Date: Mon, 21 Mar 2022 16:19:30 -0400

I want to echo this message to thank the wonderful Hackathon team. A
special thank also goes to Jordi, who omitted himself in the thanks :-). He
leads the project with great leadership, passion, and wisdom! The project
would not be possible without Jordi's leadership.

As Jordi specified in the Hackathon guidelines, a key goal is to use real,
impactful production systems and use cases to drive ALTO code base and
development, and this depends on the contributions from such real systems:

- The Rucio@CERN leadership (Mario Lassnig, Martin Barisits, and Radu
Carpa, all cc'd) is essential for the much needed expert guidance to
integrate into the Rucio codebase; in particular, the guidance to proceed
gradually from the independent download workflow (largely done in the
hackathon), to the automation workflow (partial progress in Hackathon), and
eventually to the cutting edge turned out to be invaluable, and we hope
that they will become a major contributor to drive this and other IETF work.

Another shout-out I want to add goes to John Graham (cc'd), who is the
"Secret Weapon" of Pacific Research Platform, a large platform supporting a
broad range of data-intensive fields and projects. Open development of ALTO
can benefit from (1) open-source applications (e.g., LHC), (2) open
standard (what the WG is working on), and (3) open platforms to deploy and
test the development. John helped set up the cluster, the basic platform
(cluster) and advocated developing and testing on real platforms (basic and
new settings such as his 5G platform). Ingmar and Danny also offered the
Benocs platform for ALTO-related development, and this is greatly
appreciated.

With such wonderful open-source, real applications, open platforms, many of
us are very excited to drive ALTO forward, in both deployment and
development, and we look forward to more discussions on Wednesday.

Richard

On Mon, Mar 21, 2022 at 9:00 AM Jordi Ros Giralt <[email-masked]>
wrote:

> Hi all,
>
> I wanted to start thanking all of you who have worked in the ALTO
> hackathon project for the past weeks. Significant work was carried out by
> many of you during the last 2 months to make this a successful event. We
> started with the goal of performing 1 demo, and we ended up doing two and a
> half demos (a 150% more than originally planned for). Many of you (Jensen,
> Kai, Richard, Mahdi, and various Yale and Sichuan Univ. students) dedicated
> endless hours the past ten days, working across 3 times zones (USA, EU,
> Asia), including weekends. Thank you.
>
>    - Scrum dashboard: https://github.com/orgs/openalto/projects/1/views/1
>    - Repo: https://github.com/openalto/ietf-hackathon
>    - 113 hackathon presentation:
>    https://github.com/IETF-Hackathon/ietf113-project-presentations/blob/main/ietf-113-hackathon-alto.pdf
>
> Please check slide #3 that summarizes the overall plan to manage the
> OpenALTO code base project (attached below too). We welcome anyone of you
> who wants to participate in the development of the code base to join us.
> Starting next week, we will be discussing the goals (epics) for the next
> four months targeting the next hackathon checkpoint in July.
>
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>

---

From: Jordi Ros Giralt <[email-masked]>
Date: Mon, 21 Mar 2022 20:30:24 +0000

Thank you very much Richard for including the folks from CERN and John Graham at PRP/UCSD. I echo your words, they were also key and going forward their input will be invaluable for a successful integration and deployment of ALTO in their production networks.

Thank you all.

Jordi
________________________________
From: Y. Richard Yang <[email-masked]>
Sent: Monday, March 21, 2022 21:19
To: Jordi Ros Giralt <[email-masked]>; [email-masked] <[email-masked]>; Martin Barisits <[email-masked]>; [email-masked] <[email-masked]>; John Graham <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [alto] IETF 113 ALTO Hackathon

WARNING: This email originated from outside of Qualcomm. Please be wary of any links or attachments, and do not enable macros.

I want to echo this message to thank the wonderful Hackathon team. A special thank also goes to Jordi, who omitted himself in the thanks :-). He leads the project with great leadership, passion, and wisdom! The project would not be possible without Jordi's leadership.

As Jordi specified in the Hackathon guidelines, a key goal is to use real, impactful production systems and use cases to drive ALTO code base and development, and this depends on the contributions from such real systems:

- The Rucio@CERN leadership (Mario Lassnig, Martin Barisits, and Radu Carpa, all cc'd) is essential for the much needed expert guidance to integrate into the Rucio codebase; in particular, the guidance to proceed gradually from the independent download workflow (largely done in the hackathon), to the automation workflow (partial progress in Hackathon), and eventually to the cutting edge turned out to be invaluable, and we hope that they will become a major contributor to drive this and other IETF work.

Another shout-out I want to add goes to John Graham (cc'd), who is the "Secret Weapon" of Pacific Research Platform, a large platform supporting a broad range of data-intensive fields and projects. Open development of ALTO can benefit from (1) open-source applications (e.g., LHC), (2) open standard (what the WG is working on), and (3) open platforms to deploy and test the development. John helped set up the cluster, the basic platform (cluster) and advocated developing and testing on real platforms (basic and new settings such as his 5G platform). Ingmar and Danny also offered the Benocs platform for ALTO-related development, and this is greatly appreciated.

With such wonderful open-source, real applications, open platforms, many of us are very excited to drive ALTO forward, in both deployment and development, and we look forward to more discussions on Wednesday.

Richard

On Mon, Mar 21, 2022 at 9:00 AM Jordi Ros Giralt <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/alto