Subject: Re: [alto] [hackathon] IETF ALTO WG hackathon project and participation

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 3 Mar 2022 22:15:20 +0000

Thanks to the project champions for bringing this to the Hackathon. 
Please see questions inline.

> On Feb 25, 2022, at 3:36 AM, Christian Esteve Rothenberg <[email-masked]> wrote:
> 
> Nice initiative!
> 
> I always felt that hving reference client and server implementations
> for ALTO would boost interest and adoption of the protocol.
> 
> I will present the hackathon topics to my students but unfortunately
> we do not have any chance to participate on-site in this edition.
> 
> In the past we have done some ALTO research and produced some open
> source work that may be of interest:
> 
> https://github.com/intrig-unicamp/alto-based-broker-assisted-mdo
> https://github.com/intrig-unicamp/ALTO-as-a-Service

I had a quick look at these but the licensing was not clear. It is mentioned that they are open source, but I could not find a license file. 

> 
> Thanks,
> Christian
> 
> On Thu, Feb 24, 2022 at 9:58 AM <[email-masked]> wrote:
>> 
>> Hi Reinaldo and all,
>> 
>> 
>> There are some projects where the hackathon can be based on. If you are developing something on top of these projects, I would recommend using the same or compatible licenses.
>> 
>> 
>> https://github.com/openalto/sextant  (EPL v1.0)

I could not find the license for this one either. Sorry if I missed it. It would be good to add a license file, or make the existing one easier to find.

>> 
>> https://github.com/reservoirlabs/g2-mininet (Apache v2.0)

I could not find the license for this one either. Sorry if I missed it. It would be good to add a license file, or make the existing one easier to find.

>> 
>> https://github.com/rucio/rucio (Apache v2)

This one is clear. 

Thanks,
Charles

>> 
>> 
>> Best,
>> 
>> Kai
>> 
>> 
>> -----Original Messages-----
>> From:"Reinaldo Penno (repenno)" <repenno=[email-masked]>
>> Sent Time:2022-02-24 05:39:02 (Thursday)
>> To: "Muhammad Usman Bashir" <[email-masked]>, "Jordi Ros Giralt" <[email-masked]>
>> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
>> Subject: Re: [alto] [hackathon] IETF ALTO WG hackathon project and participation
>> 
>> Hello,
>> 
>> 
>> 
>> Will the stack be developed from scratch or there is something? If there is something what is the proposed license?
>> 
>> 
>> 
>> Thanks,
>> 
>> 
>> 
>> From: hackathon <[email-masked]> on behalf of Muhammad Usman Bashir <[email-masked]>
>> Date: Wednesday, February 23, 2022 at 12:30 PM
>> To: Jordi Ros Giralt <[email-masked]>
>> Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
>> Subject: Re: [hackathon] IETF ALTO WG hackathon project and participation
>> 
>> I am interested in the project.
>> 
>> 
>> 
>> On Wed, Feb 23, 2022 at 7:05 PM Jordi Ros Giralt <[email-masked]> wrote:
>> 
>> Hi all,
>> 
>> 
>> 
>> The ALTO WG is starting an initiative to develop an open-source code base for the ALTO standard. During the upcomming IETF 113 Hackathon, we plan to do some initial work and demonstrations (see the ALTO project description in the Hackathon Wiki). Our current team includes a small community of companies and universities participating in the ALTO WG as well as students from Yale University and Sichuan University. If anyone is interested in participating, please let me know by replying to this note.
>> 
>> 
>> 
>> Thank you.
>> 
>> 
>> 
>> Jordi
>> 
>> _______________________________________________
>> hackathon mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/hackathon
>> Unsubscribe: mailto:[email-masked]?subject=unsubscribe
>> 
>> _______________________________________________
>> alto mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/alto
> 
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon
> Unsubscribe: mailto:[email-masked]?subject=unsubscribe

---

From: Jordi Ros Giralt <[email-masked]>
Date: Thu, 3 Mar 2022 22:35:30 +0000

I will let Kai respond about the Sextant license.

As for the G2-Mininet license, it is described in the provided repo, in the COPYING file: https://github.com/reservoirlabs/g2-mininet/blob/master/COPYING

Thank you,
Jordi

________________________________
From: hackathon <[email-masked]> on behalf of Charles Eckel (eckelcu) <eckelcu=[email-masked]>
Sent: Thursday, March 3, 2022 23:15
To: Christian Esteve Rothenberg <[email-masked]>
Cc: repenno=[email-masked] <repenno=[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Muhammad Usman Bashir <[email-masked]>; Kai Gao <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [hackathon] [alto] IETF ALTO WG hackathon project and participation

WARNING: This email originated from outside of Qualcomm. Please be wary of any links or attachments, and do not enable macros.

This one is clear.

Thanks,
Charles

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Thu, 3 Mar 2022 23:18:49 +0000

Thanks Folks,

I looked at linkage below. Licensing and tech issues apart, I am always okay with leveraging something that is out there with running code.

Alternatively, we apply the lessons learned from the projects that exists and start a new codebase.

There are pros and cons with both, and I am sure the group will reach a decision.

Regards

-RP

From: Jordi Ros Giralt <[email-masked]>
Date: Thursday, March 3, 2022 at 2:36 PM
To: Charles Eckel (eckelcu) <[email-masked]>, Christian Esteve Rothenberg <[email-masked]>
Cc: Reinaldo Penno (repenno) <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, Muhammad Usman Bashir <[email-masked]>, Kai Gao <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [hackathon] [alto] IETF ALTO WG hackathon project and participation
I will let Kai respond about the Sextant license.

Thank you,
Jordi

This one is clear.

Thanks,
Charles

---

From: [email-masked]
Date: Fri, 4 Mar 2022 09:35:33 +0800 (GMT+08:00)

Hi Jordi and all,

Sextant is EPL v1.0 (inherited from OpenDaylight). The license is put in the front of each source file.

Best,

Kai

-----Original Messages-----
From:"Jordi Ros Giralt" <[email-masked]>
Sent Time:2022-03-04 06:35:30 (Friday)
To: "Charles Eckel (eckelcu)" <eckelcu=[email-masked]>, "Christian Esteve Rothenberg" <[email-masked]>
Cc: "repenno=[email-masked]" <repenno=[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "Muhammad Usman Bashir" <[email-masked]>, "Kai Gao" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [hackathon] [alto] IETF ALTO WG hackathon project and participation

Thank you,
Jordi

This one is clear.

Thanks,
Charles

---

From: Muhammad Usman Bashir <[email-masked]>
Date: Thu, 24 Feb 2022 01:29:28 +0500

On Wed, Feb 23, 2022 at 7:05 PM Jordi Ros Giralt <[email-masked]>
wrote:

> Hi all,
>
> The ALTO WG is starting an initiative to develop an open-source code base
> for the ALTO standard. During the upcomming IETF 113 Hackathon, we plan to
> do some initial work and demonstrations (see the ALTO project description
> in the Hackathon Wiki
> <https://trac.ietf.org/trac/ietf/meeting/wiki/113hackathon>). Our current
> team includes a small community of companies and universities participating
> in the ALTO WG as well as students from Yale University and Sichuan
> University. If anyone is interested in participating, please let me know by
> replying to this note.
>
> Thank you.
>
> Jordi

---

From: Jordi Ros Giralt <[email-masked]>
Date: Thu, 10 Mar 2022 17:14:30 +0000

Thank you everyone who have responded to my message below with interest in participating in the Hackathon as part of the ALTO WG.

To those of you who would like to participate, we are going to do a kick-off meeting next Wednesday 9am EST. I will be sending an invite, but just in case I miss anyone, here are the coordinates:

what: IETF Hackathon 113 ALTO project kickoff meeting
when: Wed March 16, 9am EST
where: Click here to join the meeting<https://teams.microsoft.com/l/meetup-join/19%3ameeting_NWEwYzc3NmMtNDgyZi00OTlkLTkyY2ItYzkwOTQ4MDY3MGJj%40thread.v2/0?context=%7b%22Tid%22%3a%2298e9ba89-e1a1-4e38-9007-8bdabc25de1d%22%2c%22Oid%22%3a%22b90fe06a-f028-4de4-b117-379d0c4badb5%22%7d>

The IETF ALTO WG has been working these past weeks to prepare for the hackathon.

This is the repo where we track the work: https://github.com/openalto/ietf-hackathon
And this is the project dashboard: https://github.com/orgs/openalto/projects/1/views/1?groupedBy%5BcolumnId%5D=2113975

We will be going through this during the kick-off.

Thank you and we look forward to it!

Jordi

________________________________
From: Jordi Ros Giralt
Sent: Wednesday, February 23, 2022 15:04
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: IETF ALTO WG hackathon project and participation

Hi all,

The ALTO WG is starting an initiative to develop an open-source code base for the ALTO standard. During the upcomming IETF 113 Hackathon, we plan to do some initial work and demonstrations (see the ALTO project description in the Hackathon Wiki<https://trac.ietf.org/trac/ietf/meeting/wiki/113hackathon>). Our current team includes a small community of companies and universities participating in the ALTO WG as well as students from Yale University and Sichuan University. If anyone is interested in participating, please let me know by replying to this note.

Thank you.

Jordi