Subject: Re: [alto] I-Draft discussion - Supporting Bottleneck Structure Graphs in ALTO: Use Cases and Requirements

From: Jordi Ros Giralt <[email-masked]>
Date: Fri, 8 Apr 2022 11:48:19 +0000

Copying over some questions that Qin asked in a separate conversation and including my answers:

Regarding section 3, I am thinking whether this require interaction between overlay and underlay, one typical example is SDWAN use case described in

https://datatracker.ietf.org/doc/html/draft-dukes-spring-sr-for-sdwan

which require SDWAN controller and SR controller better interaction.

This is a good question and we had a similar conversation with Luis during the IETF Meetings. In order to construct the bottleneck structure of the network, we need flow path information (i.e., the set of links traversed by the flows). In overlay/underlay networks like SDWAN, ground-truth flow-path information needs to be obtained from the underlay. This information can be derived from protocols like NetFlow / IPFIX. Alternatively, it can also be obtained from the traffic engineering database (TED) or from the SDN controller.

In section 4.4 “Optimal Joint Congestion Control and Routing<https://giralt.github.io/draft-ietf-alto-gradient-graph/draft-giraltyellamraju-alto-bsg-requirements.html#name-optimal-joint-congestion-co>”, I assume Routing is at the network layer while congestion control is at the transport layer, do we have similar interaction between network layer and transport layer.

I assume some emulation platform you should build to test impact of new added flow on the network.

​Good question too. In this case there is no need for network and transport to interact. Once the bottleneck structure of the network has been computed, we can jointly solve routing and congestion control. For instance, a PCE could use the bottleneck structure to compute a throughput optimal SRv6 path and then program a flow's packet header SIDs accordingly. See Section '5. Application Layer Traffic Optimization using Bottleneck Structures'<https://datatracker.ietf.org/doc/draft-giraltyellamraju-alto-bsg-requirements/> for an example.

​

Thanks,

Jordi

________________________________
From: alto <[email-masked]> on behalf of Jordi Ros Giralt <[email-masked]>
Sent: Thursday, March 24, 2022 21:36
To: [email-masked] <[email-masked]>
Subject: [alto] I-Draft discussion - Supporting Bottleneck Structure Graphs in ALTO: Use Cases and Requirements

WARNING: This email originated from outside of Qualcomm. Please be wary of any links or attachments, and do not enable macros.

Hello all,

During the ALTO session, the chair asked that we bring to the mailing list the discussion about the new draft "Supporting Bottleneck Structure Graphs in ALTO: Use Cases and Requirements"

https://datatracker.ietf.org/doc/draft-giraltyellamraju-alto-bsg-requirements/

I will start by following up on the questions raised during the session via the Jabber chat, but feel free to raise any other questions during this conversation:
[QW]
Can alto provide sufficient information to build bottleneck structure graph? is there data translation needed? in the scope of your draft or not?

[RY]
There are two interpretations to this question: (1) build bottleneck structure on top of alto and (2) make bottleneck structure a (new) service provided by alto. For (1), we need some modifications; I think the focus here is (2). Jordi?
[JRG] Right, I think the focus is (2). To construct the bottleneck structure, we need information about the set of links traversed by the flows and the link capacity. Flow information can be obtained from protocols such as NetFlow or sFlow (this approach is similar to how other deployments discussed in ALTO collect flow info, such as the Flow Director<https://people.csail.mit.edu/gsmaragd/publications/CoNEXT2019/CoNEXT2019.pdf>). Link capacity information can be obtained from protocols such as SNMP, the SDN controller or topology files. In two deployments in the US we use NetFlow, sFlow and topology files. Information could also be pulled from other sources. For instance, today we discussed with Luis that if PCE is used, we could get path information from the traffic engineering database (TED). Perhaps Luis also wants to add to this discussion.

Thanks,
Jordi

---

From: Qin Wu <[email-masked]>
Date: Sun, 10 Apr 2022 11:08:49 +0000

Thanks Jordi for bringing this up on the list for further discussion.
I am wondering whether building Bottleneck structure can be seen as modeling technology and require AI and machine learning technologies to be involved? If the answer is yes, it might be worth exploring this in NMRG mailing list and provide input to
AI for network management work item in the NMRG.

Secondly, I am very interested how ALTO can be integrated with PCE? How ALTO can be used together with PCE for path computation and setup,  How ALTO exposed information can be better consumed by the client, either in network layer or transport layer or application layer?

Third, it might be also related to modeling technologies, I am wondering how flow information can be correlated and aggregated into network topology information and other ALTO information such as performance metrics? Is there any mechanism or
Guidance or principle, best practice on how difference data source can be integrated together based on implementation experience. Maybe Danny and Jordi can help clarify this from your experience, thanks.

-Qin
发件人: alto [mailto:[email-masked]] 代表 Jordi Ros Giralt
发送时间: 2022年4月8日 19:48
收件人: [email-masked]
主题: Re: [alto] I-Draft discussion - Supporting Bottleneck Structure Graphs in ALTO: Use Cases and Requirements

​

Thanks,

Jordi

________________________________
From: alto <[email-masked]<mailto:[email-masked]>> on behalf of Jordi Ros Giralt <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, March 24, 2022 21:36
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [alto] I-Draft discussion - Supporting Bottleneck Structure Graphs in ALTO: Use Cases and Requirements

[RY]

Thanks,
Jordi