Subject: [Anima] Fwd: Port and multicast address usage [Re: Anima@hackathon]

From: Brian E Carpenter <[email-masked]>
Date: Wed, 8 Feb 2017 07:52:55 +1300

Just some practical points for anyone planning to bring GRASP
code to the hackathon, attached. Also don't forget to register
for the hackathon - it's free, but they need to plan the snacks
and drinks:

https://www.ietf.org/registration/ietf98/hackathonregistration.py

   Brian

-------- Forwarded Message --------
Subject: Port and multicast address usage [Re: Anima@hackathon]
Date: Sun, 5 Feb 2017 17:49:56 +1300
From: Brian E Carpenter <[email-masked]>
Organization: University of Auckland
To: [email-masked]

Since we don't have any IANA allocations yet, Anima code
will need to use the following experimental values from
RFC 4727 at the hackathon:

IPv6 link-local multicast address:
ALL_GRASP_NEIGHBOR_6 = ff02::114

UDP & TCP port:
GRASP_LISTEN_PORT = 1021

Regards
  Brian

On 03/02/2017 17:42, Brian E Carpenter wrote:
> Some of us from the Anima WG will try to do interop stuff at the hackathon.
> 
> My prototype code is at https://www.cs.auckland.ac.nz/~brian/graspy/
> Hopefully others will contribute too.
> 
> Regards
>    Brian Carpenter
> 
>

---

From: Michael Richardson <[email-masked]>
Date: Thu, 09 Feb 2017 12:15:53 -0500

> GRASP_LISTEN_PORT = 1021

You pick a "system" port. It might be better for experimenters not to.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 10 Feb 2017 08:31:03 +1300

> You pick a "system" port. It might be better for experimenters not to.

But those are the only ports reserved for experimental use, afaik.

   Brian