Subject: Re: [Anima] Adoption call for draft-liu-anima-grasp-distribution (ends 01/27/2020)

From: Toerless Eckert <[email-masked]>
Date: Tue, 11 Feb 2020 00:12:33 +0100

We had 5 voices feedback (from non-authors) to support adoption of this
document, and no voices objecting. I think this qualifies for adoption
of the document.

Nevertheless, the supporting voices did indicate a range of improvements
they would like to see. So, jere is what i would propose:

Dear-authors:

A) Please add a section Open Issues, mark it as
[RFC-Editor: To Be removed before becoming RFC].
Make it contain the following text:

The following issues where identified by the WG when adopting the -00
draft version. These issues will be individually removed in upcoming
when they are resolved.

1. More reference to the use cases in the introduction.

2. Better explanation of the required context of the Connected-Car case:
Not applicable unless the ACP will be extended to the car, which may
not be desirable with the current ACP design, but maybe refocussing
on an "autonomous fleet" use-case (e.g.: all cars operated by some taxi
like service).

3. Consider use-case/example of firmware update.  By abstracting the location
of the firmware from the name of the firmware, while providing a way
to notify about it, this significantly supports distribution of firmware updates.
References to SUIT would appropriate.

4. Issues discussed in https://mailarchive.ietf.org/arch/msg/anima/_0fYQPBcLPt8xzQee7P4dILsn3A

5. Rethink/refine terminology, e.g.: "module" seems to be too prescriptive.
Refine proposed extensions.

6. I support adoption, but also support the suggestion (from IETF106)
Provide more protocol behavior description  instead of only
implementation / software module architecture description. 
Reduce the latter or provide better justification for their presence due
to explained interoperability requirements.

7. Better motivation in sections 1..4 of the proposed extensions

8. Consider moving examples from appendices into core-text . Ideally
craft a single use-case showing/applying all extensions (most simple use
case that uses them all).

9. Refine terminology to better match/reuse-the established terminology
from the pre-existing ANIMA documents.

B) Add changelog section, equally marked as to be removed before . For this
version -00 it should just list above section from A) to be new.

C) Designate in the authors list one or two main editors for the time
   being, doesn't have to be final, just whoever has the main edit pen
   from you.  Post this version as -00 with name
   draft-ietf-anima-grasp-distribution-00
   and replacing draft-liu-anima-grasp-distribution

   I will then approve that doc as WG chair.

D) Feel free to work on -01 and further. In the changelog, please
   describe for each change which of the above 9 points are addressed by
   the change and concentrate on those changes first before addressing
   further enhancements.

E) I would strongly suggest you authors consider to create a repo for
   this document under www.github.com/anima-wg It specifically makees
   it easier to open for each of the above 10 bullet points possible
   "Issues" where it would be easier to have focussed discusses.

   I am not a github is the only way groupie though, so please make sure
   all discussions are Cc'ed to the mailing list, even though it may primarily be on
   github to make then easier to track/find.

Cheers
    Toerless

On Mon, Jan 13, 2020 at 12:45:33PM +0100, Toerless Eckert wrote:
> This message starts a two-week adoption call, it ends on January 27th, 2020.
> 
> draft-liu-anima-grasp-distribution was progressed up to version -13 with
> the help of the WG, it was last presented at IETF106 with good interest.
> The draft is now clearly in scope of ANIMA charter 2 that was adopted
> around IETF106. The authors asked for adoption of the document.
> As far as the chairs heard, there was no objection in the room.
> 
> We therefore are asking the ANIMA working group for adoption of the following work:
> 
> Title:    Information Distribution in Autonomic Networking
> Name:     draft-liu-anima-grasp-distribution
> Authors:  B. Liu, X. Xiao, A. Hecker, S. Jiang, Z. Despotovic
> URL:      https://datatracker.ietf.org/doc/draft-liu-anima-grasp-distribution/
> 
> This document is intended to become a standards track ANIMA WG document.
> 
> Standard track is desired because it is meant to become the required
> small set of protocol extensions to the GRASP protocol in support of
> the self-organization of ASA.
> 
> Please express your support or rejection. If you think this document
> should _not_ be adopted, please also explicitly indicate the reasons.
> 
> For the ANIMA WG chairs, 
>     Toerless
> 
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

-- 
---
[email-masked]

---

From: "Liubing (Leo)" <[email-masked]>
Date: Thu, 13 Feb 2020 06:19:49 +0000

Hi Toerless,

Thanks a lot for summarizing the comments!
We'll revise a new version as you suggested, and upload it soon. We'll also try to maintain a github repo.

Best regards,
Bing

> -----Original Message-----
> From: Toerless Eckert [mailto:[email-masked]]
> Sent: Tuesday, February 11, 2020 7:13 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Anima] Adoption call for draft-liu-anima-grasp-distribution (ends
> 01/27/2020)
> 
> document, and no voices objecting. I think this qualifies for adoption of the
> document.
> 
> Nevertheless, the supporting voices did indicate a range of improvements they
> would like to see. So, jere is what i would propose:
> 
> Dear-authors:
> 
> The following issues where identified by the WG when adopting the -00 draft
> version. These issues will be individually removed in upcoming when they are
> resolved.
> 
> Not applicable unless the ACP will be extended to the car, which may not be
> desirable with the current ACP design, but maybe refocussing on an
> "autonomous fleet" use-case (e.g.: all cars operated by some taxi like service).
> 
> of the firmware from the name of the firmware, while providing a way to notify
> about it, this significantly supports distribution of firmware updates.
> 4. Issues discussed in
> https://mailarchive.ietf.org/arch/msg/anima/_0fYQPBcLPt8xzQee7P4dILsn3A
> 
> 6. I support adoption, but also support the suggestion (from IETF106) Provide
> more protocol behavior description  instead of only implementation / software
> module architecture description.
> Reduce the latter or provide better justification for their presence due to
> explained interoperability requirements.
> 
> 8. Consider moving examples from appendices into core-text . Ideally craft a
> single use-case showing/applying all extensions (most simple use case that uses
> them all).
> 
> 9. Refine terminology to better match/reuse-the established terminology from
> the pre-existing ANIMA documents.
> 
> > draft-liu-anima-grasp-distribution was progressed up to version -13
> > with the help of the WG, it was last presented at IETF106 with good interest.

---

From: Xun Xiao <[email-masked]>
Date: Wed, 19 Feb 2020 17:01:09 +0000

Dear Toerless,

Just followed Bing's reply, we were currently editing to first record all provided comments. We will update a new version for that soon. 

After that we will start to address all technical issues one by one and keep improving the draft.

Best Regards,

Xun Xiao (肖迅)
Advanced Wireless Technology Lab
Munich Research Center
Huawei Technologies Co.,Ltd.

-----Original Message-----
From: Anima [mailto:[email-masked]] On Behalf Of Liubing (Leo)
Sent: Thursday, 13 February 2020 07:20
To: Toerless Eckert <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [Anima] Adoption call for draft-liu-anima-grasp-distribution (ends 01/27/2020)

Hi Toerless,

Best regards,
Bing

> We had 5 voices feedback (from non-authors) to support adoption of 
> this document, and no voices objecting. I think this qualifies for 
> adoption of the document.
> 
> Nevertheless, the supporting voices did indicate a range of 
> improvements they would like to see. So, jere is what i would propose:
> 
> Dear-authors:
> 
> not be desirable with the current ACP design, but maybe refocussing on 
> an "autonomous fleet" use-case (e.g.: all cars operated by some taxi like service).
> 
> 3. Consider use-case/example of firmware update.  By abstracting the 
> location of the firmware from the name of the firmware, while 
> providing a way to notify about it, this significantly supports distribution of firmware updates.
> Reduce the latter or provide better justification for their presence 
> due to explained interoperability requirements.
> 
> craft a single use-case showing/applying all extensions (most simple 
> use case that uses them all).
> 
> 9. Refine terminology to better match/reuse-the established 
> terminology from the pre-existing ANIMA documents.
> 
> B) Add changelog section, equally marked as to be removed before . For 
> this version -00 it should just list above section from A) to be new.
> 
> > The draft is now clearly in scope of ANIMA charter 2 that was 
> > adopted around IETF106. The authors asked for adoption of the document.

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 24 Feb 2020 20:53:50 +0100

Thanks, Xun,

Send an email when you have a new version, just in case datatrackers
notification to the chairs for accepting the post with the WG name
is lost somewhere.

Cheers
    Toerless

On Wed, Feb 19, 2020 at 05:01:09PM +0000, Xun Xiao wrote:
> Xun Xiao (?$B>S?W)

-- 
---
[email-masked]

---

From: Xun Xiao <[email-masked]>
Date: Tue, 25 Feb 2020 10:38:34 +0000

Dear Toerless,

Thanks again for taking care of the adoption. As required, we have generated the version -00.

On behalf of all the other authors, we have uploaded the version -00 to datatracker. For some reasons, we did not get any notification of a successful upload. We hope we upload it correctly and you will get notified.

Please also find our replies to your email inline. Thanks a lot!

Best Regards,

Xun Xiao (肖迅)

-----Original Message-----
From: Toerless Eckert [mailto:[email-masked]] 
Sent: Tuesday, 11 February 2020 00:13
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Anima] Adoption call for draft-liu-anima-grasp-distribution (ends 01/27/2020)

We had 5 voices feedback (from non-authors) to support adoption of this document, and no voices objecting. I think this qualifies for adoption of the document.

Nevertheless, the supporting voices did indicate a range of improvements they would like to see. So, jere is what i would propose:

Dear-authors:

[XX] This is done by adding Appendix A in the draft version -00.

The following issues where identified by the WG when adopting the -00 draft version. These issues will be individually removed in upcoming when they are resolved.

2. Better explanation of the required context of the Connected-Car case:
Not applicable unless the ACP will be extended to the car, which may not be desirable with the current ACP design, but maybe refocussing on an "autonomous fleet" use-case (e.g.: all cars operated by some taxi like service).

3. Consider use-case/example of firmware update.  By abstracting the location of the firmware from the name of the firmware, while providing a way to notify about it, this significantly supports distribution of firmware updates.
References to SUIT would appropriate.

6. I support adoption, but also support the suggestion (from IETF106) Provide more protocol behavior description  instead of only implementation / software module architecture description. 
Reduce the latter or provide better justification for their presence due to explained interoperability requirements.

8. Consider moving examples from appendices into core-text . Ideally craft a single use-case showing/applying all extensions (most simple use case that uses them all).

9. Refine terminology to better match/reuse-the established terminology from the pre-existing ANIMA documents.

B) Add changelog section, equally marked as to be removed before . For this version -00 it should just list above section from A) to be new.

[XX] This is done by adding Appendix A in the draft version -00.

[XX] Bing Liu and me (Xun Xiao) were specified as Ed. In the author list and the draft name was also changed as required.

[XX] Thanks.

D) Feel free to work on -01 and further. In the changelog, please
   describe for each change which of the above 9 points are addressed by
   the change and concentrate on those changes first before addressing
   further enhancements.
[XX] Indeed, those comments are not completely independent, some of them may affect each other, so we were considering them as a whole and try to make a systematic revision in version -01. In parallel with version -00, we already started to work on the version -01, but need more time.

[XX] We tried to create a new repo there, but do we have access right to create a repository under anima-wg?

Cheers
    Toerless

--
---
[email-masked]