Subject: [Anima] Last Call: <draft-ietf-anima-autonomic-control-plane-24.txt> (An Autonomic Control Plane (ACP)) to Proposed Standard

From: The IESG <[email-masked]>
Date: Tue, 07 Apr 2020 06:34:32 -0700

The IESG has received a request from the Autonomic Networking Integrated
Model and Approach WG (anima) to consider the following document: - 'An
Autonomic Control Plane (ACP)'
  <draft-ietf-anima-autonomic-control-plane-24.txt> as Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits final
comments on this action. Please send substantive comments to the
[email-masked] mailing lists by 2020-04-21. Exceptionally, comments may
be sent to [email-masked] instead. In either case, please retain the beginning
of the Subject line to allow automated sorting.

Abstract

   Autonomic functions need a control plane to communicate, which
   depends on some addressing and routing.  This Autonomic Control Plane
   should ideally be self-managing, and as independent as possible of
   configuration.  This document defines such a plane and calls it the
   "Autonomic Control Plane", with the primary use as a control plane
   for autonomic functions.  It also serves as a "virtual out-of-band
   channel" for Operations, Administration and Management (OAM)
   communications over a network that provides automatically configured
   hop-by-hop authenticated and encrypted communications via
   automatically configured IPv6 even when the network is not
   configured, or misconfigured.

The file can be obtained via
https://datatracker.ietf.org/doc/draft-ietf-anima-autonomic-control-plane/

IESG discussion can be tracked via
https://datatracker.ietf.org/doc/draft-ietf-anima-autonomic-control-plane/ballot/

The following IPR Declarations may be related to this I-D:

   https://datatracker.ietf.org/ipr/2407/

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 8 Apr 2020 14:15:03 +1200

I have looked carefully at the diffs since the previous Last Call for this document and I believe that they all represent improvements. Obviously it's a very complex document and I have no doubt there will be future changes in the light of experience, but from my point of view it meets the requirements for a Proposed Standard (assuming normal copy-editing).

Specifically I've checked the parts that concern GRASP, as an author of the approved draft-ietf-anima-grasp-15, and they are correct in my opinion. In particular, I coded a demonstration of the two GRASP objectives defined in this draft a couple of years ago, showing that those definitions were correct and implementable. I have retested this demo today. Code at:
https://github.com/becarpenter/graspy/blob/master/ACPcontainer.py
https://github.com/becarpenter/graspy/blob/master/ACPnewby.py

Regards
   Brian Carpenter

On 08-Apr-20 01:34, The IESG wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 8 Apr 2020 05:36:37 +0000

Thank you Brian for the review: I agree with you about the improved quality and good to know about your implementation

-éric

-----Original Message-----
From: Brian E Carpenter <[email-masked]>
Date: Wednesday, 8 April 2020 at 04:15
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Eric Vyncke <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Anima] Last Call: <draft-ietf-anima-autonomic-control-plane-24.txt> (An Autonomic Control Plane (ACP)) to Proposed Standard

    
    Regards
       Brian Carpenter