Subject: Re: [Anima] Significant nits in draft-ietf-anima-bootstrapping-keyinfra-41

From: Brian E Carpenter <[email-masked]>
Date: Tue, 19 May 2020 08:48:20 +1200

Hi, I realise this is already in "RFC Ed Queue : MISSREF", but what's the plan for fixing the errors noted below?

Regards
   Brian Carpenter

On 28-Apr-20 13:44, Brian E Carpenter wrote:
> Hi,
> 
> Again thanks to Michael Richardson, here are some important nits in the GRASP examples in the BRSKI draft. The CDDL syntax is correct, but the examples need to be corrected as below. The errors are in nesting levels within the flood message, just two pairs of missing [].
> 
> I believe these can be corrected editorially, but the authors and shepherd need to take action, since the draft is in the RFC Editor queue.
> 
> In Figure 11:
> 
> OLD:
> 
>    [M_FLOOD, 12340815, h'fe800000000000000000000000000001', 180000,
>                ["AN_Proxy", 4, 1, ""],
>                [O_IPv6_LOCATOR,
>                  h'fe800000000000000000000000000001', IPPROTO_TCP, 4443]]
> 
> In Figure 12:
> 
> NEW:
> 
>    [M_FLOOD, 12340815, h'fe800000000000000000000000000001', 180000,
>               [["AN_Proxy", 4, 1, ""],
>                [O_IPv6_LOCATOR,
>                  h'fe800000000000000000000000000001', IPPROTO_TCP, 4443]]]
> 
> In Figure 12:
> 
> OLD:
> 
>    [M_FLOOD, 12340815, h'fda379a6f6ee00000200000064000001', 180000,
>                ["AN_join_registrar", 4, 255, "EST-TLS"],
>                [O_IPv6_LOCATOR,
>                  h'fda379a6f6ee00000200000064000001', IPPROTO_TCP, 8443]]
>         ]
> 
> NEW:
> 
>    [M_FLOOD, 12340815, h'fda379a6f6ee00000200000064000001', 180000,
>               [["AN_join_registrar", 4, 255, "EST-TLS"],
>                [O_IPv6_LOCATOR,
>                  h'fda379a6f6ee00000200000064000001', IPPROTO_TCP, 8443]]
>         ]
> 
> Regards
>    Brian
>

---

From: Warren Kumari <[email-masked]>
Date: Mon, 18 May 2020 16:57:55 -0400

The RFC Editor agreed that this (and the Updates) can both be handled
during the RFC Editor phase / AUTH48.

Of course, seeing as I didn't CC y'all on the email thread (to cut down on
clutter), and forgot to update this thread, you didn't know this --
apologies...

W

On Mon, May 18, 2020 at 4:48 PM Brian E Carpenter <
[email-masked]> wrote:

> > Again thanks to Michael Richardson, here are some important nits in the
> GRASP examples in the BRSKI draft. The CDDL syntax is correct, but the
> examples need to be corrected as below. The errors are in nesting levels
> within the flood message, just two pairs of missing [].
> >
> > I believe these can be corrected editorially, but the authors and
> shepherd need to take action, since the draft is in the RFC Editor queue.
> >
> > In Figure 11:
> >
> > OLD:
> >

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Michael Richardson <[email-masked]>
Date: Thu, 21 May 2020 21:40:20 -0400

RFC-editor, the diffs against XML (v3) for this document can be found at:
   https://github.com/anima-wg/anima-bootstrap/commit/3b70d50bab007f90fed971fdcc48ca96482a8d46#diff-f0a44b214cc91a0645f06f65da3e26b6

WG: I have posted these changes to the github, and I could post the XML as
-42 if told to, but I don't want to confuse anyone.

There are a four missing trailing periods fixed, btw.
There is some change in the reference file for ietf-netconf-keystore, which I think
is the result of a bug in the reference.foobar files (out of my
control). See the line 5736 diff.
I don't think the reference file should have that <t>, but I think the
XML->TXT throws that out, but the XML is authoritative now...

Brian E Carpenter <[email-masked]> wrote:
    > examples need to be corrected as below. The errors are in nesting
    > levels within the flood message, just two pairs of missing [].

I have updated the github and the generated XML (these examples were split
off into mostly easily maintained files).

tom petch <[email-masked]> wrote:
    > I note that part of the formal specification is in CDDL and while other
    > DDL - ASN.1, SMI, YANG - are bracketed with CODE BEGINS CODE ENDS - the
    > CDDL is not. I suspect that it should be - perhaps a note to the RFC
    > Editor is called for.

This mechanism is a homebrew insert-figures routine, and it didn't consider
CDDL.  I have renamed the files to .cddl, and adjusted the insert-figures.

    > In the Security Considerations I encounter MTIM which I suspect should
    > be MITM (and which needs expanding on first use in s.5).

    > In the YANG module, I see two references in square brackets which
    > suggests that they are in XML/HTML and not plain text whereas there is
    > a requirement for YANG modules to be in plain text so that they can be
    > extracted from the RFC.

If you are looking at the HTML-ized tools-version of the document, then it
expands all sorts of things.  All of the YANG is text as far as I can see.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Thu, 21 May 2020 22:17:31 -0400

>> be MITM (and which needs expanding on first use in s.5).

oops, I missed committing this one.