Subject: Re: [Anima] Significant nits in draft-ietf-anima-autonomic-control-plane-24

From: Brian E Carpenter <[email-masked]>
Date: Tue, 19 May 2020 08:46:14 +1200

Hi, will there be an update with these corrections soon? The draft has been "Waiting for AD Go-Ahead::Revised I-D Needed " for 27 days.

Regards
   Brian Carpenter

On 28-Apr-20 13:44, Brian E Carpenter wrote:
> Hi,
> 
> Thanks to Michael Richardson, we have found some important nits in the GRASP examples in the ACP draft. The CDDL syntax is correct, but the examples need to be corrected as below. The errors are in nesting levels within the flood message, and the naming
> of constants.
> 
> The draft is already in "Revised I-D Needed" so this can easily be fixed in the next draft.
> 
> In Figure 3:
> 
> OLD:
> 
>         [M_FLOOD, 12340815, h'fd89b714f3db0000200000064000001', 210000,
>             ["SRV.est", 4, 255 ],
>             [O_IPv6_LOCATOR,
>                  h'fd89b714f3db0000200000064000001', TCP, 443]
>         ]
> 
> NEW:
> 
>         [M_FLOOD, 12340815, h'fd89b714f3db0000200000064000001', 210000,
>            [["SRV.est", 4, 255 ],
>             [O_IPv6_LOCATOR,
>                  h'fd89b714f3db0000200000064000001', IPPROTO_TCP, 443]]
>         ]
> 
> 
> In Figure 5:
> 
> OLD:
> 
>         [M_FLOOD, 12340815, h'fe80000000000000c0011001feef0000', 210000,
>             ["AN_ACP", 4, 1, "IKEv2" ],
>             [O_IPv6_LOCATOR,
>                  h'fe80000000000000c0011001feef0000', UDP, 15000]
>             ["AN_ACP", 4, 1, "DTLS" ],
>             [O_IPv6_LOCATOR,
>                  h'fe80000000000000c0011001feef0000', UDP, 17000]
>         ]
> 
> NEW:
> 
>         [M_FLOOD, 12340815, h'fe80000000000000c0011001feef0000', 210000,
>            [["AN_ACP", 4, 1, "IKEv2" ],
>             [O_IPv6_LOCATOR,
>                  h'fe80000000000000c0011001feef0000', IPPROTO_UDP, 15000]],
>            [["AN_ACP", 4, 1, "DTLS" ],
>             [O_IPv6_LOCATOR,
>                  h'fe80000000000000c0011001feef0000', IPPROTO_UDP, 17000]]
>         ]
> 
> Regards
>    Brian
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 29 May 2020 15:01:45 +0200

Yes, sorry, i am working on it... *sigh*...

-- 
---
[email-masked]