Subject: Re: [Anima] BRSKI#43, Figure 5 YANG Tree diagram for Voucher-Request

From: "Werner, Thomas" <[email-masked]>
Date: Tue, 1 Sep 2020 07:58:52 +0000

Thanks, just one small change, the refinement of "voucher/pinned-domain-cert" should read: 

      refine "voucher/pinned-domain-cert" {
        mandatory false;
        description "A pinned-domain-cert field
                     is not valid in a voucher request, and
                     any occurrence MUST be ignored";
      }

Best regards
Thomas

-----Ursprüngliche Nachricht-----
Von: Michael Richardson <[email-masked]> 
Gesendet: Montag, 31. August 2020 22:01
An: [email-masked]
Cc: Werner, Thomas (CT RDA CST SEA-DE) <[email-masked]>
Betreff: Re: BRSKI#43, Figure 5 YANG Tree diagram for Voucher-Request

Thomas has pointed out that the "pinned-domain-cert" and "last-renewal-date"
fields which are defined in RFC8366 are not clearly specified for the voucher-request.

Neither are needed or appropriate in a voucher-request.
I have edited the YANG to include:

      refine "voucher/pinned-domain-cert" {
        mandatory false;
        description "A voucher-request field
                     is not valid in a voucher request, and
                     any occurrence MUST be ignored";
      }

      refine "voucher/last-renewal-date" {
        description "A last-renewal-date field
                     is not valid in a voucher request, and
                     any occurrence MUST be ignored";
      }

This is, I think, an editorial change.

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Tue, 01 Sep 2020 21:24:04 -0400

> description "A pinned-domain-cert field

Right. Copy and paste error!

here is the complete change:
   https://github.com/anima-wg/anima-bootstrap/commit/41dbb30bfd163b71818144a122291a83b50a85e0

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-