Subject: [Anima] Robert/Warren: BRSKI change - pls ask IETF - (Was: Re: ANIMA: WG call for consensus BRSKI "endpoint path" modification (was: Re: Status of renaming endpoint path?))

From: Toerless Eckert <[email-masked]>
Date: Wed, 16 Sep 2020 08:55:49 +0200

Dear Robert, Warren

ANIMA WG has rough consensus to integrate below diffs change into BRSKI.
Could one of you pls. start an IETF last call as discussed. I could not
find a template email for such a call, so i whipped up one myself,
maybe this helps.

Cheers
    Toerless (for ANIMA WG chairs)

---

Dear IETF

The IESG has received a request from the Autonomic Networking Integrated
Model and Approach WG (ANIMA) to integrate a limited change into the
following document (BRSKI):

https://datatracker.ietf.org/doc/draft-ietf-anima-bootstrapping-keyinfra/

The change is shown here:

https://www.ietf.org/rfcdiff?url1=draft-ietf-anima-bootstrapping-keyinfra-43&url2=draft-richardson-anima-brski-renamed-00

Explanation (from AIMA WG chairs):

  BRSKI originated as an extension of EST (RFC7030), which established the
  /.well-known/est registry. BRSKI-43 therefore uses extension to this
  registry. More recent followup work from BRSKI including, but not limited
  to, BRSKI-AE made it more obvious though, that BRSKI should have better
  established its own registry so it can easier be reused / expanded without
  having to assume EST. Therefore the above BRSKI diff (and BRSKI-AE) propose
  to introduce a /.well-known/brski registry.
  
  BRSKI-AE: https://tools.ietf.org/html/draft-ietf-anima-brski-async-enroll-00
  
The IESG plans to make a decision in the next few weeks, and solicits final                                                  
comments on on ONLY the changes proposed in the above diff (but no other comments
on BRSKI). Please send substantive comments to the [email-masked] mailing 
list by <DATE>. Exceptionally, comments may be sent to [email-masked] instead.
In either case, please retain the beginning of the Subject line to allow automated
sorting.               

-------- Original email thead on ANIMA-WG:

On Tue, Sep 01, 2020 at 03:59:06AM +0200, Toerless Eckert wrote:
> Dear ANIMA WG
> 
> This email starts a 2 week call for consensus to modify draft-ietf-anima-bootstrapping-keyinfra
> such that new well-known URIs introduced by BRSKI will use a /.well-known/brski
> prefix instead of the pre-existing /.well-known/est prefix.
> 
> The proposed change can be seen at the following rfcdiff URL:
> 
> https://www.ietf.org/rfcdiff?url1=draft-ietf-anima-bootstrapping-keyinfra-43&url2=draft-richardson-anima-brski-renamed-00
> 
> This consensus call will end on September 14, 23:59 UTC
> This consensus call is ONLY for said change and not for any other aspects of BRSKI.
> 
> If you have any objections to this change, please explain them by replying to
> this email during this period. If you agree with these changes please say so as well.
> 
> FYI: What would happen afterwards ?
> 
> a) If ANIMA does not have consensus, nothing more would happen, BRSKI would continue
>    stay unchanged in RFC editor queue waiting to be released by ACP draft 
> 
> b) If ANIMA WG has rough consensus on this change:
> 
> - Warren Kumari or Robert Wilton would start a 2 week IETF consensus call on the subject.
> - When not successful, see a)
> 
> -  When successful:
> 
> - BRSKI authors would rev' the BRSKI document with the proposed text change,
> - the responsible AD (Warren) would update the YES on the document
> - Mark Nottingham as the responsible expert for the impacted IANA registry would
>   have to agree on the proposed registry change (which according to prior emails
>   he seems to be)
> - IESG would approve the change, the rev'ed version of BRSKI would go into RFC Editor queue
> 
> According to Warrens prior emails (see below), this whole process should take ca. 5 weeks,
> which is shorter than the current queue length of RFC-editor, and that is still
> predicating that ACP draft is approved quickly by IESG (see below)
> 
> Hopefully i did no misrepresent any of the FYI steps.
> 
> Thank you very much
>     Toerless (for the ANIMA WG chairs).
> 
> P.S.: appended Warrens prior summary.
> 
> P.S.2.: Warren: I didn't send this mail earlier because from your writeup below it sounded
> as if my top priority should still be to work through 1922 lines of "this should be easy to fix"
> DISCUSS/COMMENTS from IESG against ACP to shorten the time BRSKI would have to wait in RFC
> editor queue - with or without this modification. But the increasing grouching level on
> the mailing list about this subject told me that this priorization was wrong. I apologize.
> 
> In-Reply-To: <[email-masked]>
> 
> On Mon, Aug 31, 2020 at 05:01:53PM -0400, Warren Kumari wrote:
> > Hi all,
> > 
> > Back in late July Steffan sent:
> > https://mailarchive.ietf.org/arch/msg/anima/jjusQdqzS3G4WbczolCxF0_YmQQ/
> > regarding renaming "Handling of endpoint path names (from BRSKI-AE
> > discussion today)".
> > 
> > Michael has a document ready to do this:
> > https://www.ietf.org/rfcdiff?url1=draft-ietf-anima-bootstrapping-keyinfra-43&url2=draft-richardson-anima-brski-renamed-00
> > 
> > Brian was concerned that this might add an unknown additional delay:
> > https://mailarchive.ietf.org/arch/msg/anima/3Ov2s8XxQ6pnQMp6PTd9_yDc-D0/
> > 
> > Luckily, if the WG does want to do this, we should be able to make it
> > happen without adding any delay (but we are running out of time...).
> > 
> > If the chairs kick off a consensus call, asking for objections **on
> > this change only**, then I can do a 2 week IETF LC, also asking for
> > objections **on this change only**.
> > 
> > I've already (mid-August) confirmed that the IESG is OK with this
> > process, so it would take [however long the Chairs choose to do the WG
> > consensus call for (1 week? 2 weeks?) ]  + [2 weeks IETF consensus
> > call] +[a few days of slop] = ~5 weeks...
> > 
> > This document is gated on (at least)
> > draft-ietf-anima-autonomic-control-plane (which will take some time to
> > wind its way through the RFC Ed process) so if this were to occur
> > soon, there would be no added delay...
> > 
> > Just FYI...
> > W
> > 
> > -- 
> > I don't think the execution is relevant when it was obviously a bad
> > idea in the first place.
> > This is like putting rabid weasels in your pants, and later expressing
> > regret at having chosen those particular rabid weasels and that pair
> > of pants.
> >    ---maf
> > 
> > _______________________________________________
> > Anima mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/anima
> 
> -- 
> ---
> [email-masked]
> 
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

-- 
---
[email-masked]

---

From: Warren Kumari <[email-masked]>
Date: Wed, 16 Sep 2020 12:00:04 -0400

Sent, and thank you for the text.

I also added a TL;DR summary - I suspect that the only people who will
care are already in the WG...

W

W