Subject: [Anima] join proxy documents

From: Michael Richardson <[email-masked]>
Date: Tue, 22 Sep 2020 16:06:49 -0400

first, I reposted
       Name:		draft-richardson-anima-state-for-joinrouter
       Revision:	03

It was done during the early days of BRSKI to collect some options in, but
was never intended to be published. I think that the reference.XXX file
disappeared.

second, I have edited

Name:		draft-vanderstok-anima-constrained-join-proxy
Revision:	04
Title:		Constrained Join Proxy for Bootstrapping Protocols
Document date:	2020-09-22
Group:		Individual Submission
Pages:		20
URL:            https://www.ietf.org/id/draft-vanderstok-anima-constrained-join-proxy-04.txt
Status:         https://datatracker.ietf.org/doc/draft-vanderstok-anima-constrained-join-proxy/
Html:           https://www.ietf.org/id/draft-vanderstok-anima-constrained-join-proxy-04.html
Htmlized:       https://tools.ietf.org/html/draft-vanderstok-anima-constrained-join-proxy-04
Diff:           https://www.ietf.org/rfcdiff?url2=draft-vanderstok-anima-constrained-join-proxy-04

a bunch and reposted it.

I have changed occurances of EST Server to "BRSKI Registrar", as I think that
is more accurate.
Did we really want to standardize the StateFUL join proxy?
Is it really interesting or relevant?  It seems trivial.
If we are, then we should contrast it.  An important clue is that it does not
behave any differently, FROM THE PLEDGE point of view.

The WG had expressed an interest in adopting this document, but the WG chairs
have not provided any clear guidance on where they we go.

This document could be merged into ietf-constrained-voucher, but I think we
made it a separate document because it is not needed on all networks, just
*constrained* multihop/MESH networks.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 24 Sep 2020 23:23:31 +0200

Inline

> Diff:           https://www.ietf.org/rfcdiff?url2=draft-vanderstok-anima-constrained-join-proxy-04

Ok, have to re-read to page in the context of these documents into my brain ;-)

> I have changed occurances of EST Server to "BRSKI Registrar", as I think that

Not in draft-richardson-anima-state-for-joinrouter from my quick read.

> Did we really want to standardize the StateFUL join proxy?

Uhmm... isn;t that what we're doing with BRSKI proper ? That's a stateful join proxy,
right ? Aka: your question seems to be missing some more context
(stndardize stateful join proxy for context XXXX... ?)

> have not provided any clear guidance on where they we go.

I thought we primarily had the issue of the named author having unfortunate issues
to drive the document. If you want to take on the ditors helm for it, then
the chairs will be happy to proactively see how to progress the document in the WG...

> *constrained* multihop/MESH networks.

Yes, we have some decisions to make wrt. how much to merge into fewer documents and
how much to keep the solution definition modular.

Given how we went through half a decade of probably too-big-documents in ANIMA,
as an individual conributor i would err on the side of more smaller documents, but
i guess as a WG chair i should just leave it to authors and rough consensus of the
WG.

Cheers
    Toerless

> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

-- 
---
[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Thu, 24 Sep 2020 21:31:33 -0400

Toerless Eckert <[email-masked]> wrote:
    >> I have changed occurances of EST Server to "BRSKI Registrar", as I
    >> think that is more accurate.

    > Not in draft-richardson-anima-state-for-joinrouter from my quick read.

No, that document is background and it is not intended for publication, and I
didn't change anything in it.

    > Uhmm... isn;t that what we're doing with BRSKI proper ? That's a
    > stateful join proxy, right ? Aka: your question seems to be missing
    > some more context (stndardize stateful join proxy for context
    > XXXX... ?)

> Group:		Individual Submission

The stateful method is same as BRSKI, but over CoAP, rather than HTTPS.
That's why I'm asking if it is at all useful to specify anything.

    >> Is it really interesting or relevant?  It seems trivial.  If we are,
    >> then we should contrast it.  An important clue is that it does not
    >> The WG had expressed an interest in adopting this document, but the WG
    >> chairs have not provided any clear guidance on where they we go.

    > I thought we primarily had the issue of the named author having
    > unfortunate issues to drive the document. If you want to take on the
    > ditors helm for it, then the chairs will be happy to proactively see
    > how to progress the document in the WG...

Peter, Panos and I are authors.
Yes, some of the authors had time constraints, but that's why we have more
than one author, isn't it?

    >> This document could be merged into ietf-constrained-voucher, but I
    >> think we made it a separate document because it is not needed on all
    >> networks, just *constrained* multihop/MESH networks.

    > Yes, we have some decisions to make wrt. how much to merge into fewer
    > documents and how much to keep the solution definition modular.

    > Given how we went through half a decade of probably too-big-documents
    > in ANIMA, as an individual conributor i would err on the side of more
    > smaller documents, but i guess as a WG chair i should just leave it to
    > authors and rough consensus of the WG.

Well, constrained-voucher started out as being constrained-RFC8366,
with the intention of having a constrained-BRSKI document.
(Direction towards: more documents).
During that period, we managed to split of est-coaps-ace, which is in the
RFC-editor queue.

Then constrained-voucher ate up constrained-BRSKI, and now it is bigger.

I would say, that the WG should adopt the work based upon what things it
wants to solve, and then if content needs to be shifted around, merged,
split, etc. then the WG can decide that.

---

From: Peter van der Stok <[email-masked]>
Date: Sun, 27 Sep 2020 13:02:36 +0200

Dear all,

After a long silence, I want to manifest my interest in both documents:
- constrained-voucher that extends and completes [ace]est-coaps to cover
all non-est brski cases using coap,
- contrained-join-proxy that standardizes the stateless proxy using coap
and coap discovery.

The first document is an anima WG document, which has progressed very
slowly waiting for keyinfra to conclude.
The second was intended as anima WG document once the new anima charter
was adopted.

The separation in two documents makes sense in my opinion.
I don't know why the join-proxy document has slided over the WG horizon.
I still hope that the WG wants to adopt join-proxy. 
Implementations of both douments are in progress at this moment.

cheerio, and thanks,

Peter van ders Stok

---

From: Sheng Jiang <[email-masked]>
Date: Mon, 28 Sep 2020 02:02:23 +0000

Hi, Peter,

Thanks for your email. With my chair-hat on, I can confirm that join-proxy is in the scope and interest of ANIMA WG. The chairs have a plan to adopt several documents after we completed the long-delayed RFC-tobe documents. Now, we are in the last step of it, hopefully: ACP document has last two small DISCUSSes, which in my opinion has been addressed by the latest update and we are waiting the ADs to clean them.

Thanks for your efforts and patient.

Sheng

From: Anima [mailto:[email-masked]] On Behalf Of Peter van der Stok
Sent: Sunday, September 27, 2020 7:03 PM
To: Michael Richardson <[email-masked]>
Cc: Toerless Eckert <[email-masked]>; [email-masked]
Subject: Re: [Anima] join proxy documents

Dear all,

After a long silence, I want to manifest my interest in both documents:
- constrained-voucher that extends and completes [ace]est-coaps to cover all non-est brski cases using coap,
- contrained-join-proxy that standardizes the stateless proxy using coap and coap discovery.

The first document is an anima WG document, which has progressed very slowly waiting for keyinfra to conclude.
The second was intended as anima WG document once the new anima charter was adopted.

The separation in two documents makes sense in my opinion.
I don't know why the join-proxy document has slided over the WG horizon. I still hope that the WG wants to adopt join-proxy.
Implementations of both douments are in progress at this moment.

cheerio, and thanks,

Peter van ders Stok

--
Michael Richardson <[email-masked]<mailto:[email-masked]>>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

_______________________________________________
Anima mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/anima