Subject: Re: [Apn] APN Use Cases

From: Michael McBride <[email-masked]>
Date: Wed, 9 Sep 2020 00:06:20 +0000

Hi Shuping,

> Some use cases in Edge Computing have been listed in the draft: https://tools.ietf.org/html/draft-liu-apn-edge-usecase-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-liu-apn-edge-usecase-00&data=02%7C01%7Cmichael.mcbride%40futurewei.com%7Cf593e2cb6fb746b6743508d8480e851b%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637338574514744971&sdata=EsCdSrWxSC1iYeTRRcrUJPKejwJrcIojU9Ud0V3AWdg%3D&reserved=0>

One of the findings, of a series of edge computing side meetings, was the need for standardized edge data discovery:

https://datatracker.ietf.org/doc/draft-mcbride-edge-data-discovery-overview/

Perhaps we can include an APN use case (or separate draft) where the network is aware of the applications data needs, is able to find the data and then compute on it. Something worth investigating anyway.

Thanks,
mike

From: Apn <[email-masked]> On Behalf Of Pengshuping (Peng Shuping)
Sent: Monday, August 24, 2020 2:17 AM
To: [email-masked]
Subject: [Apn] APN Use Cases

Dear all,

We have been exploring the use cases that could benefit from APN.

Some use cases in Edge Computing have been listed in the draft: https://tools.ietf.org/html/draft-liu-apn-edge-usecase-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-liu-apn-edge-usecase-00&data=02%7C01%7Cmichael.mcbride%40futurewei.com%7Cf593e2cb6fb746b6743508d8480e851b%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637338574514744971&sdata=EsCdSrWxSC1iYeTRRcrUJPKejwJrcIojU9Ud0V3AWdg%3D&reserved=0>
Some use cases in Game Acceleration have been listed in the draft: https://tools.ietf.org/html/draft-zhang-apn-acceleration-usecase-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-zhang-apn-acceleration-usecase-00&data=02%7C01%7Cmichael.mcbride%40futurewei.com%7Cf593e2cb6fb746b6743508d8480e851b%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637338574514744971&sdata=fqG9qPL6Pcb%2FLTcflrIYF6GHAdWP6vUOO1TQ5xW9BkI%3D&reserved=0>

What do you think about these use cases? What are the benefits that can be brought by APN? Would you like to share some other use cases that are valuable to you?

Thank you!

Best regards,
Shuping

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Wed, 9 Sep 2020 07:19:50 +0000

Hi Mike,

It sounds an interesting use case to make the network aware of the applications data needs.

Just to clarify first, what would be the "applications data needs" to be more specific? Any idea on how to express/formulate these data needs and integrate with APN?

Best regards,
Shuping

From: Michael McBride [mailto:[email-masked]]
Sent: Wednesday, September 9, 2020 8:06 AM
To: Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]
Subject: RE: APN Use Cases

Hi Shuping,

Thanks,
mike

From: Apn <[email-masked]<mailto:[email-masked]>> On Behalf Of Pengshuping (Peng Shuping)
Sent: Monday, August 24, 2020 2:17 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Apn] APN Use Cases

Dear all,

Thank you!

Best regards,
Shuping