Subject: Re: [Apn] APN Use Cases

From: Peng Liu<[email-masked]>
Date: 09 Sep 2020 15:45:05 +0800

Hi Mike and Shuping,

As the co-author of draft-liu-apn-edge-usecase-00,  I am also interested in the data discovery, and have some questions:

(1) It is easy to understand the process of discovering the device, and the process of computing after the data being generated, collected and forwarded. So what dose the data discovery means?

(2) From draft-mcbride-edge-data-discovery-overview, I can think of the potential combination of APN and data discovery may be that different types of data require different SLA guaranteed networks, such as general collected data, control data, and widely used video data. I wonder if this understanding is the "application data needs", or do you think there is a deeper combination?

We can have more discussion on them.

Thanks,

Peng

Peng Liu | 刘鹏

China Mobile | 移动研究院

mobile phone：13810146105

email:  [email-masked]

发件人: Pengshuping (Peng Shuping)

时间: 2020/09/09(星期三)15:19

收件人: Michael McBride;apn;

抄送人: Peng Liu;

主题: RE: APN Use Cases 

Hi Mike,  

It sounds an interesting use case to make the network aware of the applications data needs.  

Just to clarify first, what would be the “applications data needs” to be more specific? Any idea on how to express/formulate these data needs and integrate with APN? 

Best regards,   

Shuping  

 

From: Michael McBride [mailto:[email-masked]] 
 Sent: Wednesday, September 9, 2020 8:06 AM
 To: Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]
 Subject: RE: APN Use Cases   

Hi Shuping, 

> Some use cases in Edge Computing have been listed in the draft:  https://tools.ietf.org/html/draft-liu-apn-edge-usecase-00 

One of the findings, of a series of edge computing side meetings, was the need for standardized edge data discovery: 

https://datatracker.ietf.org/doc/draft-mcbride-edge-data-discovery-overview/ 

Perhaps we can include an APN use case (or separate draft) where the network is aware of the applications data needs, is able to find the data and then compute on it. Something worth investigating  anyway.  

Thanks, 

mike 

From: Apn <[email-masked]> On Behalf Of Pengshuping (Peng Shuping)
 Sent: Monday, August 24, 2020 2:17 AM
 To: [email-masked]
 Subject: [Apn] APN Use Cases   

Dear all, 

We have been exploring the use cases that could benefit from APN.  

Some use cases in Edge Computing have been listed in the draft:  https://tools.ietf.org/html/draft-liu-apn-edge-usecase-00 

Some use cases in Game Acceleration have been listed in the draft:  https://tools.ietf.org/html/draft-zhang-apn-acceleration-usecase-00 

What do you think about these use cases? What are the benefits that can be brought by APN? Would you like to share some other use cases that are valuable to you?  

Thank you! 

Best regards,  

Shuping

---

From: Michael McBride <[email-masked]>
Date: Wed, 9 Sep 2020 16:46:03 +0000

Hello,

>(1) It is easy to understand the process of discovering the device, and the process of computing after the data being generated, collected and forwarded. So what dose the data discovery means?

MM: Data discovery here means discovering data objects in flight, in storage, in memory, in cache, etc. Why? Given the sheer volume of data (particularly with IoT), once we locate the desired data we can make decisions based on it. We have a companion draft which discusses this as well: draft-mcbride-data-discovery-problem-statement-00. We could provide a standardized way of locating, capturing, classifying and transforming data in order to generate insights and recommendations to APN machinery.

>(2) From draft-mcbride-edge-data-discovery-overview, I can think of the potential combination of APN and data discovery may be that different types of data require different SLA guaranteed networks,…

MM: Yes exactly. Different SLA. Also applications may be able to make decisions we haven’t thought of based upon type and location of data throughout a network.

Thanks,
Mike

Thanks,
Peng

Peng Liu | 刘鹏
China Mobile | 移动研究院
mobile phone：13810146105
email:  [email-masked]<mailto:[email-masked]>

发件人: Pengshuping (Peng Shuping)<mailto:[email-masked]>
时间: 2020/09/09(星期三)15:19
收件人: Michael McBride<mailto:[email-masked]>;apn<mailto:[email-masked]>;
抄送人: Peng Liu<mailto:[email-masked]>;
主题: RE: APN Use Cases
Hi Mike,

Best regards,
Shuping

From: Michael McBride [mailto:[email-masked]]
Sent: Wednesday, September 9, 2020 8:06 AM
To: Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: APN Use Cases

Hi Shuping,

> Some use cases in Edge Computing have been listed in the draft: https://tools.ietf.org/html/draft-liu-apn-edge-usecase-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-liu-apn-edge-usecase-00&data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C593fe383c2cb403f2fc508d854945199%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637352343310011116&sdata=xqGxTWqnpw1U84x6zaiR%2F05CFjQkb9fwGuby2pEe3zw%3D&reserved=0>

https://datatracker.ietf.org/doc/draft-mcbride-edge-data-discovery-overview/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mcbride-edge-data-discovery-overview%2F&data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C593fe383c2cb403f2fc508d854945199%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637352343310021109&sdata=RF5r6TsLaxwCZdax12cSNR0qmPPmwyWn4k5f%2F5JfQkM%3D&reserved=0>

Thanks,
mike

From: Apn <[email-masked]<mailto:[email-masked]>> On Behalf Of Pengshuping (Peng Shuping)
Sent: Monday, August 24, 2020 2:17 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Apn] APN Use Cases

Dear all,

Some use cases in Edge Computing have been listed in the draft: https://tools.ietf.org/html/draft-liu-apn-edge-usecase-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-liu-apn-edge-usecase-00&data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C593fe383c2cb403f2fc508d854945199%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637352343310021109&sdata=gbbF0LPEoCB0hxoIN0ePoCqEVPBvmxVUz6LZWepaNi8%3D&reserved=0>
Some use cases in Game Acceleration have been listed in the draft: https://tools.ietf.org/html/draft-zhang-apn-acceleration-usecase-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-zhang-apn-acceleration-usecase-00&data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C593fe383c2cb403f2fc508d854945199%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637352343310031106&sdata=vc9%2FAX2kOnFPHVXHVx01RT7cmUobSDv60r95eUUU1jA%3D&reserved=0>

Thank you!

Best regards,
Shuping