Subject: [Apn] APN presentation @INTAREA

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Fri, 12 Mar 2021 15:34:30 +0000

Hi Folks,

Please find below the FAQs I listed in the slides but did not get time to present. Your comments and feedback are very much welcomed. Thank you!

You can also find the slides here. There are also some information for your references at the end of the slides.
https://datatracker.ietf.org/meeting/110/materials/slides-110-intarea-application-aware-networking-apn-02

1. Are there any applications that can benefit from APN?
I would like to ask how many of us have experienced the Meetecho issues in this IETF and the virtual ones before. This is one of the applications that can benefit from APN. :)

In this IETF, we had a hackathon "Application-aware G-SRv6 networking", which shows the improvements that can be achieved with APN, using which the traffic is steered into the appropriate SRv6 path [1]. The results are going to be presented and demonstrated in the INFOCOM2021. There was also the first demonstration of APN in the INFOCOM2020 [2].

[1]https://github.com/APN-Community/IETF-110-Hackathon-Demo/blob/master/Application-aware_G-SRv6_networking__Demo_and_Test.pdf
[2]https://ieeexplore.ieee.org/abstract/document/9162934

2. How APN can help resolve the QoE issues?
As shown in the APN demonstrations, we can see the differences/improvements which APN can make in the network. QoE is complex and has many impacting factors including the terminal, access, and network. APN aims to provide ways to improve the QoE within the network.

3. Who is to set the APN attribute?
It is the network edge device such as CPE (Customer Premises Equipment) not the application.

4. How to set the APN attribute?
There are many possible ways that can be used to classify the traffic flow at the network edge, e.g., the N-tuples as defined in the MEF70 and the AI technologies. An APN attribute can be derived by using the match items published in MEF70 as well as the access port in the edge device.

5. How the APN attribute is used in the network?
The APN attribute is carried in the data packet's header, and it can be used in the various nodes/service functions along the network path to enforce the policies on the differentiated traffic flow, e.g.,
1) at the headend to steer into corresponding path satisfying SLAs
2) at the midpoint to collect corresponding performance measurement data
3) at the service function to execute particular policies

Best regards,
Shuping

---

From: Bob Hinden <[email-masked]>
Date: Fri, 12 Mar 2021 07:49:14 -0800

Hi Shuping,

> On Mar 12, 2021, at 7:34 AM, Pengshuping (Peng Shuping) <[email-masked]> wrote:
> 
> Hi Folks,
> 

In your int area presentation, I think you said that APN was for limited domains.  There was a bullet that said:

     APN works within a limited trusted domain.

How would that then apply to Meetecho?  Meetecho needs to work across the whole Internet.

Bob

> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Fri, 12 Mar 2021 16:01:53 +0000

Hi Bob, 

Please also look at the second FAQ. 

"QoE is complex and has many impacting factors including the terminal, access, and network. APN aims to provide ways to improve the QoE within the network." 

Thank you! 

Best regards, 
Shuping 

> -----Original Message-----
> From: Bob Hinden [mailto:[email-masked]]
> Sent: Friday, March 12, 2021 11:49 PM
> To: Pengshuping (Peng Shuping) <[email-masked]>
> Cc: Bob Hinden <[email-masked]>; [email-masked]; [email-masked]
> Subject: Re: [Int-area] APN presentation @INTAREA
> 
> Hi Shuping,
> 
> > Please find below the FAQs I listed in the slides but did not get time to
> present. Your comments and feedback are very much welcomed. Thank you!
> >
> > I would like to ask how many of us have experienced the Meetecho issues
> in this IETF and the virtual ones before. This is one of the applications that
> can benefit from APN. :)
> 
> > In this IETF, we had a hackathon "Application-aware G-SRv6 networking",
> which shows the improvements that can be achieved with APN, using which
> the traffic is steered into the appropriate SRv6 path [1]. The results are going
> to be presented and demonstrated in the INFOCOM2021. There was also the
> first demonstration of APN in the INFOCOM2020 [2].
> >
> >
> [1]https://github.com/APN-Community/IETF-110-Hackathon-Demo/blob/m
> aster/Application-aware_G-SRv6_networking__Demo_and_Test.pdf
> > As shown in the APN demonstrations, we can see the
> differences/improvements which APN can make in the network. QoE is
> complex and has many impacting factors including the terminal, access, and
> network. APN aims to provide ways to improve the QoE within the network.
> >
> > There are many possible ways that can be used to classify the traffic flow
> at the network edge, e.g., the N-tuples as defined in the MEF70 and the AI
> technologies. An APN attribute can be derived by using the match items
> published in MEF70 as well as the access port in the edge device.
> >
> > The APN attribute is carried in the data packet's header, and it can be used
> in the various nodes/service functions along the network path to enforce the
> policies on the differentiated traffic flow, e.g.,

---

From: Bob Hinden <[email-masked]>
Date: Fri, 12 Mar 2021 09:49:12 -0800

Shuping,

> On Mar 12, 2021, at 8:01 AM, Pengshuping (Peng Shuping) <[email-masked]> wrote:
> 
> Hi Bob,
> 
> "QoE is complex and has many impacting factors including the terminal, access, and network. APN aims to provide ways to improve the QoE within the network.”

I don’t think that answers my question.   I also noted on slide 4 it said:

   • APN is not about identifying the application to or within the network

It seems to me it could be easily used to do just that.   Is there any protection to keep that from happening?

Bob

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Mon, 15 Mar 2021 08:52:21 +0000

Hi Bob, 

Please see in line. 

> From: Apn [mailto:[email-masked]] On Behalf Of Bob Hinden
> Sent: Saturday, March 13, 2021 1:49 AM
> Cc: [email-masked]; Bob Hinden <[email-masked]>; [email-masked]
> Subject: Re: [Apn] [Int-area] APN presentation @INTAREA
> 
> Shuping,
> 
> > "QoE is complex and has many impacting factors including the terminal,
> access, and network. APN aims to provide ways to improve the QoE within
> the network.”
> 
> I don’t think that answers my question. 

The end-to-end path of these video conferencing type of applications will start from terminals, go through the access and network, and then the data centers. I meant that APN works within the network domain. I meant that APN can help improve the QoE within the network part. APN can also help to diagnose whether the deterioration of the QoE happens within the network and where inside the network. 

>  I also noted on slide 4 it said:
> 

It can actually happen no matter whether there is APN. This is out of the scope of APN. We believe that the network operation must obey the regulation. 

Best regards, 
Shuping 

> >>> You can also find the slides here. There are also some information
> >>> for your
> >> references at the end of the slides.
> >>>
> >> https://datatracker.ietf.org/meeting/110/materials/slides-110-intarea
> >> -appli
> >> cation-aware-networking-apn-02
> >>>
> >> in this IETF and the virtual ones before. This is one of the
> >> applications that can benefit from APN. :)
> >>
> >> In your int area presentation, I think you said that APN was for
> >> limited domains.  There was a bullet that said:
> >>
> >> How would that then apply to Meetecho?  Meetecho needs to work
> across
> >> the whole Internet.
> >>
> >> Bob
> >>
> >>
> >>>
> >> which shows the improvements that can be achieved with APN, using
> >> which the traffic is steered into the appropriate SRv6 path [1]. The
> >> results are going to be presented and demonstrated in the
> >> INFOCOM2021. There was also the first demonstration of APN in the
> INFOCOM2020 [2].
> >>>
> >>>
> >>
> >> complex and has many impacting factors including the terminal,
> >> access, and network. APN aims to provide ways to improve the QoE
> within the network.
> >>>
> >>> It is the network edge device such as CPE (Customer Premises
> >>> Equipment)
> >> not the application.
> >>>
> >> at the network edge, e.g., the N-tuples as defined in the MEF70 and
> >> the AI technologies. An APN attribute can be derived by using the
> >> match items published in MEF70 as well as the access port in the edge
> device.
> >>>
> >> in the various nodes/service functions along the network path to
> >> enforce the policies on the differentiated traffic flow, e.g.,