Subject: [Apn] should add the gap analysis for GENEVE (RFC8926)

From: Linda Dunbar <[email-masked]>
Date: Thu, 18 Mar 2021 23:56:19 +0000

Shuping, et al,

I think that the draft-peng-apn-scope-gap-analysis should add the gap analysis for GENEVE (RFC8926).

GENEVE has been used very widely among Cloud networks. For example, you can have a GENEVE encapsulated flows to Firewalls. You can attach App related Meta data to the GENEVE header, so that the nodes along the way can do the needed processing.

Geneve Header:
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |Ver|  Opt Len  |O|C|    Rsvd.  |          Protocol Type        |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |        Virtual Network Identifier (VNI)       |    Reserved   |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |                                                               |
      ~                    Variable-Length Options                    ~
      |                                                               |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

If there are reasons that GENEVE can't be used, it is better to document those reasons in the Gap analysis.

Linda Dunbar

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Fri, 19 Mar 2021 08:24:20 +0000

Hi Linda,

Thank you!

GENEVE can be taken into account when carrying the APN attribute. The encapsulation with it seems more to be a solution that needs to be developed rather than a gap analysis to be added. How do you think?

Best regards,
Shuping

From: Linda Dunbar [mailto:[email-masked]]
Sent: Friday, March 19, 2021 7:56 AM
To: [email-masked]; [email-masked]
Subject: should add the gap analysis for GENEVE (RFC8926)

Shuping, et al,

Geneve Header:

Linda Dunbar

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 19 Mar 2021 15:48:19 +0000

ShuPing,

When you say "needs to be developed", do you mean mapping the APN-ID and APN-Associated-Parameters into the GENEVE TLV?

For example, the App-AWARE ID from the draft-li-6man-app-aware-ipv6-network-02 can be specified as a Sub-TLV to GENEVE header.

Linda

From: Pengshuping (Peng Shuping) <[email-masked]>
Sent: Friday, March 19, 2021 3:24 AM
To: Linda Dunbar <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: should add the gap analysis for GENEVE (RFC8926)

Hi Linda,

Thank you!

Best regards,
Shuping

From: Linda Dunbar [mailto:[email-masked]]
Sent: Friday, March 19, 2021 7:56 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: should add the gap analysis for GENEVE (RFC8926)

Shuping, et al,

Geneve Header:

Linda Dunbar

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Sat, 20 Mar 2021 02:10:43 +0000

Hi Linda,

Yes, this is what I meant.

The draft-li-6man-app-aware-ipv6-network-02 gives an example of the encapsulation of the APN attribute in the IPv6 data plane.

Since you mentioned GENEVE, have you seen some scenarios that could use APN in GENEVE?

Thank you!

Best Regards,
Shuping

From: Linda Dunbar [mailto:[email-masked]]
Sent: Friday, March 19, 2021 11:48 PM
To: Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: should add the gap analysis for GENEVE (RFC8926)

ShuPing,

Linda

From: Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, March 19, 2021 3:24 AM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: should add the gap analysis for GENEVE (RFC8926)

Hi Linda,

Thank you!

Best regards,
Shuping

Shuping, et al,

Geneve Header:

Linda Dunbar

---

From: Linda Dunbar <[email-masked]>
Date: Sat, 20 Mar 2021 03:30:50 +0000

ShuPing,

GENEVE is to carry metadata associated with the packet. Metadata can be location information, compute information, service ID, App category, etc..
One open source project even used the GENEVE to replace HTTP for IoT devices that don't support Web browser to communicate with other devices.

Linda

From: Pengshuping (Peng Shuping) <[email-masked]>
Sent: Friday, March 19, 2021 9:11 PM
To: Linda Dunbar <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: should add the gap analysis for GENEVE (RFC8926)

Hi Linda,

Thank you!

Best Regards,
Shuping

From: Linda Dunbar [mailto:[email-masked]]
Sent: Friday, March 19, 2021 11:48 PM
To: Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: should add the gap analysis for GENEVE (RFC8926)

ShuPing,

Linda

Hi Linda,

Thank you!

Best regards,
Shuping

Shuping, et al,

Geneve Header:

Linda Dunbar

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Mon, 22 Mar 2021 01:39:26 +0000

Hi Linda,

I was wondering about the concrete usage scenarios since I am not familiar with those with GENEVE. For example, in what scenario carrying what information to do what?

Any references on the IoT case you mentioned about?

Thank you!

Best regards,
Shuping

From: Linda Dunbar [mailto:[email-masked]]
Sent: Saturday, March 20, 2021 11:31 AM
To: Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: should add the gap analysis for GENEVE (RFC8926)

ShuPing,

Linda

Hi Linda,

Thank you!

Best Regards,
Shuping

ShuPing,

Linda

Hi Linda,

Thank you!

Best regards,
Shuping

Shuping, et al,

Geneve Header:

Linda Dunbar

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 23 Mar 2021 03:16:21 +0000

Shuping,

Here is one example: for 5G Edge Computing, the edge devices have limited capacity. It can use GENEVE to carry information about the characteristics of the App, such as Types, Edge device information, etc.
Linda

From: Pengshuping (Peng Shuping) <[email-masked]>
Sent: Sunday, March 21, 2021 8:39 PM
To: Linda Dunbar <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: should add the gap analysis for GENEVE (RFC8926)

Hi Linda,

Thank you!

Best regards,
Shuping

ShuPing,

Linda

Hi Linda,

Thank you!

Best Regards,
Shuping

ShuPing,

Linda

Hi Linda,

Thank you!

Best regards,
Shuping

Shuping, et al,

Geneve Header:

Linda Dunbar

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Wed, 24 Mar 2021 02:25:53 +0000

Thank you, Linda!

When we start exploring the solution using GENEVE, we would need to know more about the use cases. Thank you for the information!

BR,
Shuping

From: Linda Dunbar [mailto:[email-masked]]
Sent: Tuesday, March 23, 2021 11:16 AM
To: Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: should add the gap analysis for GENEVE (RFC8926)

Shuping,

Hi Linda,

Thank you!

Best regards,
Shuping

ShuPing,

Linda

Hi Linda,

Thank you!

Best Regards,
Shuping

ShuPing,

Linda

Hi Linda,

Thank you!

Best regards,
Shuping

Shuping, et al,

Geneve Header:

Linda Dunbar

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 29 Mar 2021 04:53:35 -0400

Hi Shuping

This is in similar context to use of VXLAN-GPE to carry APN APP ID marking
information

https://datatracker.ietf.org/doc/html/draft-ietf-nvo3-vxlan-gpe-11

   The capabilities of the VXLAN-GPE protocol can be extended by
   defining next protocol "shim" headers that are used to implement new
   data plane functions.  For example, Group-Based Policy (GBP) or In-
   situ Operations, Administration, and Maintenance (IOAM) metadata
   functionalities can be added as specified in
   [I-D.lemon-vxlan-lisp-gpe-gbp
<https://datatracker.ietf.org/doc/html/draft-ietf-nvo3-vxlan-gpe-11#ref-I-D.lemon-vxlan-lisp-gpe-gbp>]
and
   [I-D.brockners-ippm-ioam-vxlan-gpe
<https://datatracker.ietf.org/doc/html/draft-ietf-nvo3-vxlan-gpe-11#ref-I-D.brockners-ippm-ioam-vxlan-gpe>].

GENEVE

https://tools.ietf.org/html/rfc8926

Work such as "VL2: A Scalable and Flexible Data Center Network" [VL2
<https://tools.ietf.org/html/rfc8926#ref-VL2>]
   and "NVO3 Data Plane Requirements" [NVO3-DATAPLANE
<https://tools.ietf.org/html/rfc8926#ref-NVO3-DATAPLANE>] have
described
   some of the properties that the data plane must have to support
   network virtualization.  However, one additional defining requirement
   is the need to carry metadata (e.g., system state) along with the
   packet data; example use cases of metadata are noted below.  The use
   of some metadata is certainly not a foreign concept -- nearly all
   protocols used for network virtualization have at least 24 bits of
   identifier space as a way to partition between tenants.  This is
   often described as overcoming the limits of 12-bit VLANs; when seen
   in that context or any context where it is a true tenant identifier,
   16 million possible entries is a large number.  However, the reality
   is that the metadata is not exclusively used to identify tenants, and
   encoding other information quickly starts to crowd the space.  In
   fact, when compared to the tags used to exchange metadata between
   line cards on a chassis switch, 24-bit identifiers start to look
   quite small.  There are nearly endless uses for this metadata,
   ranging from storing input port identifiers for simple security
   policies to sending service-based context for advanced middlebox
   applications that terminate and re-encapsulate Geneve traffic.

You can see some similarities between the two NVO3 overlays GENEVE and
VXLAN-GPE both having the ability carry metadata and so would be perfect
for DC environment to carry APN ID in the metadata field for the endpoint
characteristics signaling to the network.

Kind Regards

Gyan

On Tue, Mar 23, 2021 at 10:26 PM Pengshuping (Peng Shuping) <
[email-masked]> wrote:

> Thank you, Linda!
>
>
>
> When we start exploring the solution using GENEVE, we would need to know
> more about the use cases. Thank you for the information!
>
>
>
> BR,
>
> Shuping
>
>
>
> *From:* Linda Dunbar [mailto:[email-masked]]
> *Sent:* Tuesday, March 23, 2021 11:16 AM
> *To:* Pengshuping (Peng Shuping) <[email-masked]>;
> [email-masked]; [email-masked]
> *Subject:* RE: should add the gap analysis for GENEVE (RFC8926)
>
>
>
> Shuping,
>
>
>
> Here is one example: for 5G Edge Computing, the edge devices have limited
> capacity. It can use GENEVE to carry information about the characteristics
> of the App, such as Types, Edge device information, etc.
>
> Linda
>
>
>
>
>
> *From:* Pengshuping (Peng Shuping) <[email-masked]>
> *Sent:* Sunday, March 21, 2021 8:39 PM
> *To:* Linda Dunbar <[email-masked]>;
> [email-masked]; [email-masked]
> *Subject:* RE: should add the gap analysis for GENEVE (RFC8926)
>
>
>
> Hi Linda,
>
>
>
> I was wondering about the concrete usage scenarios since I am not familiar
> with those with GENEVE. For example, in what scenario carrying what
> information to do what?
>
>
>
> *From:* Linda Dunbar [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* Saturday, March 20, 2021 11:31 AM
> *To:* Pengshuping (Peng Shuping) <[email-masked]>;
> [email-masked]; [email-masked]
> *Subject:* RE: should add the gap analysis for GENEVE (RFC8926)
>
>
>
> ShuPing,
>
>
>
> GENEVE is to carry metadata associated with the packet. Metadata can be
> location information, compute information, service ID, App category, etc..
>
> One open source project even used the GENEVE to replace HTTP for IoT
> devices that don’t support Web browser to communicate with other devices.
>
>
>
> Linda
>
>
>
> *From:* Pengshuping (Peng Shuping) <[email-masked]>
> *Sent:* Friday, March 19, 2021 9:11 PM
> *To:* Linda Dunbar <[email-masked]>;
> [email-masked]; [email-masked]
> *Subject:* RE: should add the gap analysis for GENEVE (RFC8926)
>
>
>
> Hi Linda,
>
>
>
> The draft-li-6man-app-aware-ipv6-network-02 gives an example of the
> encapsulation of the APN attribute in the IPv6 data plane.
>
>
>
> *From:* Linda Dunbar [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* Friday, March 19, 2021 11:48 PM
> *To:* Pengshuping (Peng Shuping) <[email-masked]>;
> [email-masked]; [email-masked]
> *Subject:* RE: should add the gap analysis for GENEVE (RFC8926)
>
>
>
> ShuPing,
>
>
>
> When you say “needs to be developed”, do you mean mapping the APN-ID and
> APN-Associated-Parameters into the GENEVE TLV?
>
>
>
> For example, the App-AWARE ID from the
> draft-li-6man-app-aware-ipv6-network-02 can be specified as a Sub-TLV to
> GENEVE header.
>
>
>
> Linda
>
>
>
> *From:* Pengshuping (Peng Shuping) <[email-masked]>
> *Sent:* Friday, March 19, 2021 3:24 AM
> *To:* Linda Dunbar <[email-masked]>;
> [email-masked]; [email-masked]
> *Subject:* RE: should add the gap analysis for GENEVE (RFC8926)
>
>
>
> Hi Linda,
>
>
>
> Thank you!
>
>
>
> GENEVE can be taken into account when carrying the APN attribute. The
> encapsulation with it seems more to be a solution that needs to be
> developed rather than a gap analysis to be added. How do you think?
>
>
>
> Best regards,
>
> Shuping
>
>
>
> *From:* Linda Dunbar [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* Friday, March 19, 2021 7:56 AM
> *To:* [email-masked]; [email-masked]
> *Subject:* should add the gap analysis for GENEVE (RFC8926)
>
>
>
> Shuping, et al,
>
>
>
> GENEVE has been used very widely among Cloud networks. For example, you
> can have a GENEVE encapsulated flows to Firewalls. You can attach App
> related Meta data to the GENEVE header, so that the nodes along the way can
> do the needed processing.
>
>
>
>
>
>
>
> Geneve Header:
>
> If there are reasons that GENEVE can’t be used, it is better to document
> those reasons in the Gap analysis.
>
>
>
> Linda Dunbar
> --
> Apn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apn
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Wed, 31 Mar 2021 02:55:23 +0000

Hi Gyan,

Thank you for this information. I agree with your following statements. 

"You can see some similarities between the two NVO3 overlays GENEVE and VXLAN-GPE both having the ability carry metadata and so would be perfect for DC environment to carry APN ID in the metadata field for the endpoint characteristics signaling to the network."

Any concrete use cases that could potentially use APN ID with either VxLAN-GPE or GENEVE? 

I also copied NOV3. Hope experts could help here. Thank you! 

Best reards, 
Shuping 

-----Original Message-----
From: Gyan Mishra [mailto:[email-masked]] 
Sent: Monday, March 29, 2021 4:54 PM
To: Pengshuping (Peng Shuping) <[email-masked]>
Cc: Linda Dunbar <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Apn] should add the gap analysis for GENEVE (RFC8926)

Hi Shuping

This is in similar context to use of VXLAN-GPE to carry APN APP ID marking information

GENEVE

Work such as "VL2: A Scalable and Flexible Data Center Network" [VL2 <https://tools.ietf.org/html/rfc8926#ref-VL2>]
   and "NVO3 Data Plane Requirements" [NVO3-DATAPLANE <https://tools.ietf.org/html/rfc8926#ref-NVO3-DATAPLANE>] have described

You can see some similarities between the two NVO3 overlays GENEVE and VXLAN-GPE both having the ability carry metadata and so would be perfect for DC environment to carry APN ID in the metadata field for the endpoint characteristics signaling to the network.

Kind Regards

Gyan

On Tue, Mar 23, 2021 at 10:26 PM Pengshuping (Peng Shuping) < [email-masked]> wrote:

> Thank you, Linda!
>
>
>
> When we start exploring the solution using GENEVE, we would need to 
> know more about the use cases. Thank you for the information!
>
>
>
> BR,
>
> Shuping
>
>
>
> Here is one example: for 5G Edge Computing, the edge devices have 
> limited capacity. It can use GENEVE to carry information about the 
> characteristics of the App, such as Types, Edge device information, etc.
>
> Linda
>
>
>
>
>
> I was wondering about the concrete usage scenarios since I am not 
> familiar with those with GENEVE. For example, in what scenario 
> carrying what information to do what?
>
>
>
> GENEVE is to carry metadata associated with the packet. Metadata can 
> be location information, compute information, service ID, App category, etc.

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 31 Mar 2021 01:11:57 -0400

Hi Shuping

My thoughts were that in any Data Center NVO3 environment the APN ID can be
introduced by the host or in this case can be injected with a policy as
metadata into the NVO3 overlay GENEVE or VXLN-GPE at the leaf tunnel
endpoint that does the encapsulation / decapsulation of the overlay
header.  The App ID encoded as metadata into a Group policy ID shim header
for VXLAN-GPE and for GENEVE in the data plane extensibility in TLV options
format for future innovations such as APN.

The APP ID would provide the signaling for fine grain network treatment and
mapping to SRv6 SR-TE color mapping instantiation to achieve the desired
application network treatment QOE.

Kind Regards

Gyan

On Tue, Mar 30, 2021 at 10:55 PM Pengshuping (Peng Shuping) <
[email-masked]> wrote:

> "You can see some similarities between the two NVO3 overlays GENEVE and
> characteristics signaling to the network."
>
> Cc: Linda Dunbar <[email-masked]>; [email-masked];
> [email-masked]
> <
> https://datatracker.ietf.org/doc/html/draft-ietf-nvo3-vxlan-gpe-11#ref-I-D.lemon-vxlan-lisp-gpe-gbp
> >]
> and
> <
> https://datatracker.ietf.org/doc/html/draft-ietf-nvo3-vxlan-gpe-11#ref-I-D.brockners-ippm-ioam-vxlan-gpe
> >].
>
>
> GENEVE
>
> Work such as "VL2: A Scalable and Flexible Data Center Network" [VL2 <
> https://tools.ietf.org/html/rfc8926#ref-VL2>]
>    and "NVO3 Data Plane Requirements" [NVO3-DATAPLANE <
> https://tools.ietf.org/html/rfc8926#ref-NVO3-DATAPLANE>] have described
-- 

*Gyan Mishra*

*M 301 502-1347*

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 31 Mar 2021 01:19:28 -0400

Hi Shuping

In the DC model the SRv6 SR-TE tenant overlay coloring provides the
underpinning to the discrete underlay path being instantiated by SRv6 based
on the coloring provided by the metadata encoded in the APP ID in the NVO3
overlay encapsulation injected at the leaf via local policy.

We are basically applying the network slicing concept to the Data Center
NVO3 fabric overlay signaled by the APN APP ID.

I just made that up ..but my guess is that is how it would work.

Kind Regards

Gyan

On Wed, Mar 31, 2021 at 1:11 AM Gyan Mishra <[email-masked]> wrote:

>
> Hi Shuping
>
> My thoughts were that in any Data Center NVO3 environment the APN ID can
> be introduced by the host or in this case can be injected with a policy as
> The APP ID would provide the signaling for fine grain network treatment
> and mapping to SRv6 SR-TE color mapping instantiation to achieve the
> desired application network treatment QOE.
>
> Kind Regards
>
> Gyan
>
>

*Gyan Mishra*

*M 301 502-1347*

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 31 Mar 2021 15:23:40 +0000

Gyan, ShuPing,

GENEVE and VxLAN-GPE encapsulated packets added by DC Leaf nodes can also be across different DCs, as long as the Leaf nodes in those DCs agree upon the meaning of the Metadata carried by the GENEVE/VxLAN-GPE headers.

Is the "agreement of the meaning of the metadata" what APN wants to achieve?

Linda Dunbar

From: Gyan Mishra <[email-masked]>
Sent: Wednesday, March 31, 2021 12:12 AM
To: Pengshuping (Peng Shuping) <[email-masked]>
Cc: Linda Dunbar <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Apn] should add the gap analysis for GENEVE (RFC8926)

Hi Shuping

My thoughts were that in any Data Center NVO3 environment the APN ID can be introduced by the host or in this case can be injected with a policy as metadata into the NVO3 overlay GENEVE or VXLN-GPE at the leaf tunnel endpoint that does the encapsulation / decapsulation of the overlay header.  The App ID encoded as metadata into a Group policy ID shim header for VXLAN-GPE and for GENEVE in the data plane extensibility in TLV options format for future innovations such as APN.

The APP ID would provide the signaling for fine grain network treatment and mapping to SRv6 SR-TE color mapping instantiation to achieve the desired application network treatment QOE.

Kind Regards

Gyan

On Tue, Mar 30, 2021 at 10:55 PM Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Gyan,

Best reards,
Shuping

-----Original Message-----
From: Gyan Mishra [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, March 29, 2021 4:54 PM
To: Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>
Cc: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Apn] should add the gap analysis for GENEVE (RFC8926)

Hi Shuping

https://datatracker.ietf.org/doc/html/draft-ietf-nvo3-vxlan-gpe-11<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-nvo3-vxlan-gpe-11&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322516427%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=aZ5ap7Dp55Q7S3roP5TVIa9e0Tz63b3D9BLtNSWQ7yc%3D&reserved=0>

   The capabilities of the VXLAN-GPE protocol can be extended by
   defining next protocol "shim" headers that are used to implement new
   data plane functions.  For example, Group-Based Policy (GBP) or In-
   situ Operations, Administration, and Maintenance (IOAM) metadata
   functionalities can be added as specified in
   [I-D.lemon-vxlan-lisp-gpe-gbp
<https://datatracker.ietf.org/doc/html/draft-ietf-nvo3-vxlan-gpe-11#ref-I-D.lemon-vxlan-lisp-gpe-gbp<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-nvo3-vxlan-gpe-11%23ref-I-D.lemon-vxlan-lisp-gpe-gbp&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322516427%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=QRUEjf7X%2Fj1ctXJFw%2BGibNZsjypfJXp%2BbfuM%2FYFNDaM%3D&reserved=0>>]
and
   [I-D.brockners-ippm-ioam-vxlan-gpe
<https://datatracker.ietf.org/doc/html/draft-ietf-nvo3-vxlan-gpe-11#ref-I-D.brockners-ippm-ioam-vxlan-gpe<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-nvo3-vxlan-gpe-11%23ref-I-D.brockners-ippm-ioam-vxlan-gpe&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322526419%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=f%2FHmrh6UBBqlb%2FO3VHzHV9THyosfZiquhd5R51Y6sB4%3D&reserved=0>>].

GENEVE

https://tools.ietf.org/html/rfc8926<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc8926&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322526419%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=jkSRcdX7aD8lnZL7Xi%2F0fEdb%2Fm36xxXVJmBuXWLwemk%3D&reserved=0>

Work such as "VL2: A Scalable and Flexible Data Center Network" [VL2 <https://tools.ietf.org/html/rfc8926#ref-VL2<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc8926%23ref-VL2&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322536413%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=LyTsOdYLRhjEqNU0hzsvwa0cBLPs3AcONZz%2FK6n8wQ8%3D&reserved=0>>]
   and "NVO3 Data Plane Requirements" [NVO3-DATAPLANE <https://tools.ietf.org/html/rfc8926#ref-NVO3-DATAPLANE<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc8926%23ref-NVO3-DATAPLANE&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322536413%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=jLyFl7x6bNgLQs12prSqcgXqiWrPDfQi2Wng0zXV06Q%3D&reserved=0>>] have described

Kind Regards

Gyan

On Tue, Mar 23, 2021 at 10:26 PM Pengshuping (Peng Shuping) < [email-masked]<mailto:[email-masked]>> wrote:

> *From:* Linda Dunbar [mailto:[email-masked]<mailto:[email-masked]>]
> *To:* Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>;
> [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
> *From:* Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>
> *To:* Linda Dunbar <[email-masked]<mailto:[email-masked]>>;
> [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
> *From:* Linda Dunbar [mailto:[email-masked]<mailto:[email-masked]>
> <[email-masked]<mailto:[email-masked]>>]
> *To:* Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>;
> [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322546405%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=rpM6pXB%2Ftu1myw4XkGfeWIt%2FuGZruoBhSznmGGyqJFk%3D&reserved=0>

Gyan Mishra

Network Solutions Architect

Email [email-masked]<mailto:[email-masked]>

M 301 502-1347

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 31 Mar 2021 13:28:19 -0400

Hi Linda

Good point and I agree on DCI use case.

Thanks

Gyan

On Wed, Mar 31, 2021 at 11:23 AM Linda Dunbar <[email-masked]>
wrote:

> Gyan, ShuPing,
>
>
>
> GENEVE and VxLAN-GPE encapsulated packets added by DC Leaf nodes can also
> be across different DCs, as long as the Leaf nodes in those DCs agree upon
> the meaning of the Metadata carried by the GENEVE/VxLAN-GPE headers.
>
>
>
> Is the “agreement of the meaning of the metadata” what APN wants to
> achieve?
>
>
>
> Linda Dunbar
>
>
>
> *From:* Gyan Mishra <[email-masked]>
> *Sent:* Wednesday, March 31, 2021 12:12 AM
> *To:* Pengshuping (Peng Shuping) <[email-masked]>
> *Cc:* Linda Dunbar <[email-masked]>; [email-masked];
> [email-masked]; [email-masked]
> *Subject:* Re: [Apn] should add the gap analysis for GENEVE (RFC8926)
>
>
>
>
>
> Hi Shuping
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-nvo3-vxlan-gpe-11&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322516427%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=aZ5ap7Dp55Q7S3roP5TVIa9e0Tz63b3D9BLtNSWQ7yc%3D&reserved=0>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-nvo3-vxlan-gpe-11%23ref-I-D.lemon-vxlan-lisp-gpe-gbp&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322516427%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=QRUEjf7X%2Fj1ctXJFw%2BGibNZsjypfJXp%2BbfuM%2FYFNDaM%3D&reserved=0>
> >]
> and
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-nvo3-vxlan-gpe-11%23ref-I-D.brockners-ippm-ioam-vxlan-gpe&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322526419%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=f%2FHmrh6UBBqlb%2FO3VHzHV9THyosfZiquhd5R51Y6sB4%3D&reserved=0>
> >].
>
>
> GENEVE
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc8926&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322526419%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=jkSRcdX7aD8lnZL7Xi%2F0fEdb%2Fm36xxXVJmBuXWLwemk%3D&reserved=0>
>
> https://tools.ietf.org/html/rfc8926#ref-VL2
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc8926%23ref-VL2&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322536413%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=LyTsOdYLRhjEqNU0hzsvwa0cBLPs3AcONZz%2FK6n8wQ8%3D&reserved=0>
> >]
> https://tools.ietf.org/html/rfc8926#ref-NVO3-DATAPLANE
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc8926%23ref-NVO3-DATAPLANE&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322536413%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=jLyFl7x6bNgLQs12prSqcgXqiWrPDfQi2Wng0zXV06Q%3D&reserved=0>>]
> have described
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Ce0bea3c9320f407f2ba108d8f40388fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527643322546405%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=rpM6pXB%2Ftu1myw4XkGfeWIt%2FuGZruoBhSznmGGyqJFk%3D&reserved=0>
>
> *Gyan Mishra*
>
> *Network Solutions Architect *
>
-- 

*Gyan Mishra*

*M 301 502-1347*