Subject: Re: [Apn] APN vs. Network Slicing

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Sun, 1 Aug 2021 13:19:24 +0000

Hi Shuping,

Can you confirm if the purpose of APN is to mark traffic and achieve traffic/service differentiation at fine granularity levels?

Jeffrey

From: Pengshuping (Peng Shuping) <[email-masked]>
Sent: Friday, July 30, 2021 5:48 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: APN vs. Network Slicing

[External Email. Be cautious of content]

Sorry to Jim that I jumped in.

Hi Jeffrey,

You have been explaining about what network slicing can do or does. But that is really up to the network slicing people to figure out. There have been several years for people to clarify the concept and consolidate the various terminologies even now. Here we only talk about APN.

APN and network slicing are two things. They don’t have to have any relationships, and they do not conflict each other.

The only connection is that APN provides a way to steer some traffic into a particular network slicing based on an operator’s control and its customer’s consent.

Thank you!

Best regards,
Shuping

From: Apn [mailto:[email-masked]] On Behalf Of Jeffrey (Zhaohui) Zhang
Sent: Saturday, July 31, 2021 5:28 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Apn] APN vs. Network Slicing

Hi Jim,

To follow up on your comments about APN vs. Slicing, here are some points that I did not have time to exchange during the BoF.

- While slicing does involve setting aside/up resources, that is the means to meet specific requirements for traffic delivery.
- Traffic delivered in network slices are identified by some identifiers so that network nodes knows how to forward them to meet the requirements. Combined with "slice aggregate" concept introduced in draft-bestbar-xxx drafts, fine granularity can be achieved down to flow level (vs. slice level).

In short, the goal of APN and slicing are the same (or slicing covers even more). Additionally, it is not that slicing is a use case of APN. It's the other way around - slicing does what APN want to do.

I could not get my one-page slide shared to better illustrate my point that APN problem domain/solution are already covered by IETF slicing, but let me post the text from that slide here. The sub-bullets are text quoted from the network slicing framework https://datatracker.ietf.org/doc/html/draft-ietf-teas-ietf-network-slices<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-ietf-teas-ietf-network-slices__;!!NEt6yMaO-gk!RZR3mujfa7CCp7jmAHOTCi_ZXcyrnydLZ7RvaRrrlVukirIaMTJXMMadmHNKhBhW$>。

*        Ongoing IETF Network Slicing work already addresses the problem domain and solution
*        An IETF Network Slice provides the required connectivity between different entities in RAN and CN segments of an end-to-end network slice, with a specific performance commitment.
*        It is intended that IETF Network Slices can be created to meet specific requirements, typically expressed as bandwidth, latency, latency variation, and other desired or required characteristics.
*        An IETF Network Slice combines the connectivity resource requirements and associated network behaviors such as bandwidth, latency, jitter, and network functions with other resource behaviors such as compute and storage availability.
*        Term "Slice" refers to a set of characteristics and behaviors that separate one type of user-traffic from another.  IETF Network Slice assumes that an underlying network is capable of ... fulfilling all or some of SLOs to all of the traffic in the slice or to specific flows
*        Many approaches are currently being worked on to support IETF Network Slices in IP and MPLS networks with or without the use of Segment Routing.  Most of these approaches utilize a way of marking packets so that network nodes can apply specific routing and forwarding behaviors to packets that belong to different IETF Network Slices. Different mechanisms for marking packets have been proposed (including using MPLS labels and Segment Rouing segment IDs)
*        The realization can be achieved in a form of either physical or logical connectivity using VPNs, virtual networks (VNs), or a variety of tunneling technologies such as Segment Routing, MPLS, etc.
*        Slice Aggregate concept (similar to DiffServ Behavior Aggregate) in draft-bestbar is about identifying some or all traffic in a slice using opaque numbers and providing corresponding forwarding treatment
*        Forwarding/steering should be based on opaque numbers not structured APN IDs

Thanks.
Jeffrey

Juniper Business Use Only

Juniper Business Use Only

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 1 Aug 2021 21:08:43 +0100

Pardon me for jumping in.

Here is what I think I have observed that shows similarity and difference
between network slicing and APN.

In network slicing, network resources are partitioned to “guarantee” a
specific level of service. Customer traffic that is to receive that service
from the network is classified onto that network slice. Quite how the
network distinguishes that the traffic belongs to the slice is dependent on
the network data plane, but almost certainly requires the traffic to be
marked in a way that identifies it with the slice. For example, in an
MPLS-TE network, the traffic might be placed onto an LSP that belongs to the
slice so that transit nodes will associate the incoming {interface, label}
with the slice and its reserved resources. In this sense, classification
happens at the edge of the network, and there is a clear separation of
behaviors in the network based on the “slice identifier.”

In APN, customer traffic is also classified at the edge of the network, and
is marked with an APN attribute that indicates the behavior that is desired
within the network. I don’t believe that marking the traffic with an APN
attribute is a guarantee of a service level (in my understanding of the APN
docs), but it is a request that network nodes behave according to certain
policies. And different nodes could be configured to behave differently:
node A might be configured to treat APN attributes 1 and 3 the same, but to
treat 2 differently, while node B might treat 2 and 3 the same, but 1
differently.

At the same time, the proposal seems to be that the APN attribute *can* be
treated like an opaque number (making it look like a slice identifier), but
it is constructed by setting subfields (yet to be defined) so that transit
nodes may determine common actions on a set of APN attributes that all have
the same setting of one of the subfields.

Furthermore, I think that network slicing is intended to apply to all
on-path links and nodes, while APN can be limited to “key” points in the
network that need to apply “policy.”

Thus, APN is closed to “DiffServ on steroids” while network slicing is
closer to “virtual TE networks”. But, if you wanted to stretch the
definitions to their absolute limits, you *might* call APN “soft slicing”.
I don’t think I would like to go that far.

However, I would observe that the APN attribute (if it existed) could be
used as a slice identifier, while a slice identifier probably can’t do all
the things that APN sets out to do.

Best,

Adrian

From: Apn <[email-masked]> On Behalf Of Jeffrey (Zhaohui) Zhang
Sent: 01 August 2021 14:19
To: Pengshuping (Peng Shuping) <[email-masked]>;
[email-masked]
Cc: [email-masked]
Subject: Re: [Apn] APN vs. Network Slicing

Hi Shuping,

Can you confirm if the purpose of APN is to mark traffic and achieve
traffic/service differentiation at fine granularity levels?

Jeffrey

From: Pengshuping (Peng Shuping) <[email-masked]>
Sent: Friday, July 30, 2021 5:48 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>;
[email-masked]
Cc: [email-masked]
Subject: RE: APN vs. Network Slicing

Hi Jeffrey,

You have been explaining about what network slicing can do or does. But that
is really up to the network slicing people to figure out. There have been
several years for people to clarify the concept and consolidate the various
terminologies even now. Here we only talk about APN.

APN and network slicing are two things. They don’t have to have any
relationships, and they do not conflict each other.

The only connection is that APN provides a way to steer some traffic into a
particular network slicing based on an operator’s control and its
customer’s consent.

Thank you!

Best regards,

Shuping

From: Apn [mailto:[email-masked]] On Behalf Of Jeffrey (Zhaohui) Zhang
Sent: Saturday, July 31, 2021 5:28 AM
To: [email-masked] <mailto:[email-masked]>
Cc: [email-masked] <mailto:[email-masked]>
Subject: [Apn] APN vs. Network Slicing

Hi Jim,

To follow up on your comments about APN vs. Slicing, here are some points
that I did not have time to exchange during the BoF.

- While slicing does involve setting aside/up resources, that is the means
to meet specific requirements for traffic delivery.

- Traffic delivered in network slices are identified by some identifiers so
that network nodes knows how to forward them to meet the requirements.
Combined with "slice aggregate" concept introduced in draft-bestbar-xxx
drafts, fine granularity can be achieved down to flow level (vs. slice
level).

In short, the goal of APN and slicing are the same (or slicing covers even
more). Additionally, it is not that slicing is a use case of APN. It's the
other way around - slicing does what APN want to do.

I could not get my one-page slide shared to better illustrate my point that
APN problem domain/solution are already covered by IETF slicing, but let me
post the text from that slide here. The sub-bullets are text quoted from the
network slicing framework
<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-ietf
-teas-ietf-network-slices__;!!NEt6yMaO-gk!RZR3mujfa7CCp7jmAHOTCi_ZXcyrnydLZ7
RvaRrrlVukirIaMTJXMMadmHNKhBhW$>
https://datatracker.ietf.org/doc/html/draft-ietf-teas-ietf-network-slices。

*        Ongoing IETF Network Slicing work already addresses the problem
domain and solution

*        An IETF Network Slice provides the required connectivity between
different entities in RAN and CN segments of an end-to-end network slice,
with a specific performance commitment.

*        It is intended that IETF Network Slices can be created to meet
specific requirements, typically expressed as bandwidth, latency, latency
variation, and other desired or required characteristics.

*        An IETF Network Slice combines the connectivity resource
requirements and associated network behaviors such as bandwidth, latency,
jitter, and network functions with other resource behaviors such as compute
and storage availability.

*        Term "Slice" refers to a set of characteristics and behaviors that
separate one type of user-traffic from another.  IETF Network Slice assumes
that an underlying network is capable of ... fulfilling all or some of SLOs
to all of the traffic in the slice or to specific flows

*        Many approaches are currently being worked on to support IETF
Network Slices in IP and MPLS networks with or without the use of Segment
Routing.  Most of these approaches utilize a way of marking packets so that
network nodes can apply specific routing and forwarding behaviors to packets
that belong to different IETF Network Slices. Different mechanisms for
marking packets have been proposed (including using MPLS labels and Segment
Rouing segment IDs)

*        The realization can be achieved in a form of either physical or
logical connectivity using VPNs, virtual networks (VNs), or a variety of
tunneling technologies such as Segment Routing, MPLS, etc.

*        Slice Aggregate concept (similar to DiffServ Behavior Aggregate) in
draft-bestbar is about identifying some or all traffic in a slice using
opaque numbers and providing corresponding forwarding treatment

*        Forwarding/steering should be based on opaque numbers not
structured APN IDs

Thanks.

Jeffrey

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Mon, 2 Aug 2021 01:24:27 +0000

Thank you, Adrian, for your precise understanding and clear explanation.

Best Regards,
Shuping

From: Adrian Farrel [mailto:[email-masked]]
Sent: Monday, August 2, 2021 4:09 AM
To: 'Jeffrey (Zhaohui) Zhang' <zzhang=[email-masked]>; Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: [Apn] APN vs. Network Slicing

Here is what I think I have observed that shows similarity and difference between network slicing and APN.

In network slicing, network resources are partitioned to “guarantee” a specific level of service. Customer traffic that is to receive that service from the network is classified onto that network slice. Quite how the network distinguishes that the traffic belongs to the slice is dependent on the network data plane, but almost certainly requires the traffic to be marked in a way that identifies it with the slice. For example, in an MPLS-TE network, the traffic might be placed onto an LSP that belongs to the slice so that transit nodes will associate the incoming {interface, label} with the slice and its reserved resources. In this sense, classification happens at the edge of the network, and there is a clear separation of behaviors in the network based on the “slice identifier.”

In APN, customer traffic is also classified at the edge of the network, and is marked with an APN attribute that indicates the behavior that is desired within the network. I don’t believe that marking the traffic with an APN attribute is a guarantee of a service level (in my understanding of the APN docs), but it is a request that network nodes behave according to certain policies. And different nodes could be configured to behave differently: node A might be configured to treat APN attributes 1 and 3 the same, but to treat 2 differently, while node B might treat 2 and 3 the same, but 1 differently.

At the same time, the proposal seems to be that the APN attribute *can* be treated like an opaque number (making it look like a slice identifier), but it is constructed by setting subfields (yet to be defined) so that transit nodes may determine common actions on a set of APN attributes that all have the same setting of one of the subfields.

Furthermore, I think that network slicing is intended to apply to all on-path links and nodes, while APN can be limited to “key” points in the network that need to apply “policy.”

Thus, APN is closed to “DiffServ on steroids” while network slicing is closer to “virtual TE networks”. But, if you wanted to stretch the definitions to their absolute limits, you *might* call APN “soft slicing”. I don’t think I would like to go that far.

However, I would observe that the APN attribute (if it existed) could be used as a slice identifier, while a slice identifier probably can’t do all the things that APN sets out to do.

Best,
Adrian

From: Apn <[email-masked]<mailto:[email-masked]>> On Behalf Of Jeffrey (Zhaohui) Zhang
Sent: 01 August 2021 14:19
To: Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Apn] APN vs. Network Slicing

Hi Shuping,

Jeffrey

From: Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, July 30, 2021 5:48 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: APN vs. Network Slicing

Hi Jeffrey,

Thank you!

Best regards,
Shuping

Hi Jim,

・        Ongoing IETF Network Slicing work already addresses the problem domain and solution
・        An IETF Network Slice provides the required connectivity between different entities in RAN and CN segments of an end-to-end network slice, with a specific performance commitment.
・        It is intended that IETF Network Slices can be created to meet specific requirements, typically expressed as bandwidth, latency, latency variation, and other desired or required characteristics.
・        An IETF Network Slice combines the connectivity resource requirements and associated network behaviors such as bandwidth, latency, jitter, and network functions with other resource behaviors such as compute and storage availability.
・        Term "Slice" refers to a set of characteristics and behaviors that separate one type of user-traffic from another.  IETF Network Slice assumes that an underlying network is capable of ... fulfilling all or some of SLOs to all of the traffic in the slice or to specific flows
・        Many approaches are currently being worked on to support IETF Network Slices in IP and MPLS networks with or without the use of Segment Routing.  Most of these approaches utilize a way of marking packets so that network nodes can apply specific routing and forwarding behaviors to packets that belong to different IETF Network Slices. Different mechanisms for marking packets have been proposed (including using MPLS labels and Segment Rouing segment IDs)
・        The realization can be achieved in a form of either physical or logical connectivity using VPNs, virtual networks (VNs), or a variety of tunneling technologies such as Segment Routing, MPLS, etc.
・        Slice Aggregate concept (similar to DiffServ Behavior Aggregate) in draft-bestbar is about identifying some or all traffic in a slice using opaque numbers and providing corresponding forwarding treatment
・        Forwarding/steering should be based on opaque numbers not structured APN IDs

Thanks.
Jeffrey

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 2 Aug 2021 01:51:33 +0000

Hi Adrian,

> However, I would observe that the APN attribute (if it existed) could be used as a slice identifier, while a slice identifier probably can’t do all the things that APN sets out to do.

My understanding is the opposite - Slicing offers more than what APN does :-)

Out camping now so can’t elaborate on phone but will come back with more.

Jeffrey

Sent from my iPhone

On Aug 1, 2021, at 4:09 PM, Adrian Farrel <[email-masked]> wrote:

Best,
Adrian

From: Apn <[email-masked]> On Behalf Of Jeffrey (Zhaohui) Zhang
Sent: 01 August 2021 14:19
To: Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [Apn] APN vs. Network Slicing

Hi Shuping,

Jeffrey

Hi Jeffrey,

Thank you!

Best regards,
Shuping

Hi Jim,

·        Ongoing IETF Network Slicing work already addresses the problem domain and solution
·        An IETF Network Slice provides the required connectivity between different entities in RAN and CN segments of an end-to-end network slice, with a specific performance commitment.
·        It is intended that IETF Network Slices can be created to meet specific requirements, typically expressed as bandwidth, latency, latency variation, and other desired or required characteristics.
·        An IETF Network Slice combines the connectivity resource requirements and associated network behaviors such as bandwidth, latency, jitter, and network functions with other resource behaviors such as compute and storage availability.
·        Term "Slice" refers to a set of characteristics and behaviors that separate one type of user-traffic from another.  IETF Network Slice assumes that an underlying network is capable of ... fulfilling all or some of SLOs to all of the traffic in the slice or to specific flows
·        Many approaches are currently being worked on to support IETF Network Slices in IP and MPLS networks with or without the use of Segment Routing.  Most of these approaches utilize a way of marking packets so that network nodes can apply specific routing and forwarding behaviors to packets that belong to different IETF Network Slices. Different mechanisms for marking packets have been proposed (including using MPLS labels and Segment Rouing segment IDs)
·        The realization can be achieved in a form of either physical or logical connectivity using VPNs, virtual networks (VNs), or a variety of tunneling technologies such as Segment Routing, MPLS, etc.
·        Slice Aggregate concept (similar to DiffServ Behavior Aggregate) in draft-bestbar is about identifying some or all traffic in a slice using opaque numbers and providing corresponding forwarding treatment
·        Forwarding/steering should be based on opaque numbers not structured APN IDs

Thanks.
Jeffrey

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 3 Aug 2021 19:46:16 +0000

Hi Adrian,

Please see zzh> below.

From: Adrian Farrel <[email-masked]>
Sent: Sunday, August 1, 2021 4:09 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; 'Pengshuping (Peng Shuping)' <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: [Apn] APN vs. Network Slicing

Zzh> https://datatracker.ietf.org/doc/html/draft-li-apn-problem-statement-usecases-04#section-4 says:

   2.  Application-aware information and network service provisioning
       matching providing fine-granularity network service provisioning
       (traffic operations) and SLA guarantee based on the APN attribute
       carried in APN packets.  According to the APN attribute,
       appropriate network services are selected, provisioned, and
       provided to the demanding applications to satisfy their service
       requirements.
Zzh> I read SLA guarantee and service requirement satisfaction in the above text 😊                                                              .
Zzh> To achieve SLA guarantee we need two things: a) traffic marking 2) resource provisioning. Network slicing provides both of them, and slice aggregate concept in draft-bestbar brings that to sub-slice level (flows or flow aggregates).

Zzh> I don’t think network slicing (plus the slice aggregate in draft-bestbar) excludes that “different nodes could be configured to behave differently”. Once the traffic is marked properly, how a node treats the traffic is up to the corresponding forwarding state on that node and network slicing certainly does not preclude certain nodes from having additional forwarding behavior.
Zzh> I also assume that the key purpose of APN is not to apply different behavior on different nodes. It is orthogonal – W/ or w/o APN or slicing, different nodes can apply different behavior.
Zzh> Per APN problem statement draft:

       According to the APN attribute,

       appropriate network services are selected, provisioned, and

       provided to the demanding applications to satisfy their service

       requirements.
Zzh> To me that matches the slicing well:

   Term "Slice" refers to a set of characteristics and behaviours that

   separate one type of user-traffic from another.

Zzh> Defining subfields and forwarding based on subfields makes forwarding more complicated, and makes it harder to introduce changes. What if a new subfield is needed after ASIC has already been spun?
Zzh> In the early days of BIER design, it was insisted that the forwarding only uses an opaque number as the forwarding table ID to determine which BIER forwarding table to use, instead of parsing the ID as a <subdomain-id, bit-string-length, setid> tuple. That proved to be an excellent design choice.

Zzh> For *SLA guarantee* that APN sets out to do, I suppose we’d want to apply forwarding behavior to all on-path links and nodes, unless the purpose is not SLA guarantee but just ‘limited to “key” points in the network that need to apply “policy”’. Even in the latter case, it can be considered as a “default/best-effort slice” with certain nodes provisioned with additional forwarding state to apply different “policy” based on the traffic identifier, which can be down to sub-slice (flow or flow aggregate) level as specified in the draft-bestbar documents.

Zzh> The slice aggregate identifier (in draft-bestbar, which is built on top of network slicing) can do anything that APN sets out to do in my opinion 😊
Zzh> Thanks.
Zzh> Jeffrey

Best,
Adrian

Hi Shuping,

Jeffrey

Hi Jeffrey,

Thank you!

Best regards,
Shuping

Hi Jim,

Thanks.
Jeffrey

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Wed, 4 Aug 2021 06:09:08 +0000

It is a wrong interpretation. The subject of that sentence is “matching”.

The second key element of APN is “matching”, that is, the matching of the APN attribute to network services. Network slicing is one of the network services, and network slicing can be used to guarantee SLA.

APN here is to help the operator of a network to steer some of the traffic tagged with an APN attribute to a certain network slice based on the SLA agreement with its customer.

Also, the assumption “the key purpose of APN is not to apply different behavior on different nodes” is not correct. It is the opposite.

Shuping

From: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
Sent: Wednesday, August 4, 2021 3:46 AM
To: [email-masked]; Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: [Apn] APN vs. Network Slicing

Hi Adrian,

Please see zzh> below.

From: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, August 1, 2021 4:09 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; 'Pengshuping (Peng Shuping)' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Apn] APN vs. Network Slicing

       requirements.

Best,
Adrian

Hi Shuping,

Jeffrey

Hi Jeffrey,

Thank you!

Best regards,
Shuping

Hi Jim,

Thanks.
Jeffrey

---

From: David Lake <[email-masked]>
Date: Wed, 4 Aug 2021 09:03:25 +0000

At least in the case of 5G, the network slice will already have been indicated in the Slice ID as part of the UE attach to the gNB.   Part of that may be to steer packets into a specific MPLS TE group between gNB and aggregation/pre-aggregation point but essentially the NSSI is a collection of over-the-air scheduling and walled-garden resources in shared infrastructure.

Personally I think we probably already have enough buttons-to-press in the transport and far too many tunnels.  Each tunnel will cost money to process (why do we not have an economic model of packet handling?) and 5G/6G adds more.   We need to redress the balance between payload and overhead especially when it gets to IoT/mMTC.

What we are missing is a tight connection between the required customer outcome and the manner by which that contract is built.   And by customer, I mean me sitting at home or on my mobile.

If I require (and am willing to enter into an SLA for including paying extra for) a defined outcome for my application, then how do I describe that desire to the infrastructure (and that includes more than just the pipes) and how is that defined/settled across the delivery chain?

That to me is ‘policy’ which should be ‘Application Aware.’

If APN is simply another marker in the packet to describe ’something’ then a) what is that something, b) who sets it c) how does it impact the experience of the end-user.    Also at that point, quite honestly, APN=VPN=MPLS=NSID.  They all appear to be parallel ways of doing the same thing but we have a very poor definition of what that thing is!

When you talk about an SLA, who are the actors?  Guarantee to WHOM?   Frankly, I’d have quite happily paid an uplift over the past few months to have some of my Zoom sessions delivered with lower latency to my students but I’m not given that choice by any operator today (plus we have a multi-domain problem so the policy needs to exist above individual operators either transport or application remembering that the applications are now being deployed within the network (MEC, COIN, etc).)

David

On 4 Aug 2021, at 07:09, Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>> wrote:

Shuping

To: [email-masked]<mailto:[email-masked]>; Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Hi Adrian,

Please see zzh> below.

To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; 'Pengshuping (Peng Shuping)' <[email-masked]<mailto:[email-masked]>>;[email-masked]<mailto:[email-masked]>

Zzh> https://datatracker.ietf.org/doc/html/draft-li-apn-problem-statement-usecases-04#section-4<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-li-apn-problem-statement-usecases-04%23section-4&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C5bcb207fc18540a8d41c08d9570e6c64%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637636541750974108%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Ei%2B%2Byx%2BJkc94ySRBuAx7C28rkw0eDet7lkPF%2B85NrDc%3D&reserved=0> says:

Zzh> I read SLA guarantee and service requirement satisfaction in the above text😊                                                              .

       requirements.

Best,
Adrian

Hi Shuping,

Jeffrey

Hi Jeffrey,

Thank you!

Best regards,
Shuping

Hi Jim,

I could not get my one-page slide shared to better illustrate my point that APN problem domain/solution are already covered by IETF slicing, but let me post the text from that slide here. The sub-bullets are text quoted from the network slicing framework https://datatracker.ietf.org/doc/html/draft-ietf-teas-ietf-network-slices<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-teas-ietf-network-slices__%3B!!NEt6yMaO-gk!RZR3mujfa7CCp7jmAHOTCi_ZXcyrnydLZ7RvaRrrlVukirIaMTJXMMadmHNKhBhW%24&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C5bcb207fc18540a8d41c08d9570e6c64%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637636541750984102%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ZrS%2FCJWtClpXnED%2FhJxbnynosShbIjVMUxRCCPhjNME%3D&reserved=0>。

•        Ongoing IETF Network Slicing work already addresses the problem domain and solution
•        An IETF Network Slice provides the required connectivity between different entities in RAN and CN segments of an end-to-end network slice, with a specific performance commitment.
•        It is intended that IETF Network Slices can be created to meet specific requirements, typically expressed as bandwidth, latency, latency variation, and other desired or required characteristics.
•        An IETF Network Slice combines the connectivity resource requirements and associated network behaviors such as bandwidth, latency, jitter, and network functions with other resource behaviors such as compute and storage availability.
•        Term "Slice" refers to a set of characteristics and behaviors that separate one type of user-traffic from another.  IETF Network Slice assumes that an underlying network is capable of ... fulfilling all or some of SLOs to all of the traffic in the slice or to specific flows
•        Many approaches are currently being worked on to support IETF Network Slices in IP and MPLS networks with or without the use of Segment Routing.  Most of these approaches utilize a way of marking packets so that network nodes can apply specific routing and forwarding behaviors to packets that belong to different IETF Network Slices. Different mechanisms for marking packets have been proposed (including using MPLS labels and Segment Rouing segment IDs)
•        The realization can be achieved in a form of either physical or logical connectivity using VPNs, virtual networks (VNs), or a variety of tunneling technologies such as Segment Routing, MPLS, etc.
•        Slice Aggregate concept (similar to DiffServ Behavior Aggregate) in draft-bestbar is about identifying some or all traffic in a slice using opaque numbers and providing corresponding forwarding treatment
•        Forwarding/steering should be based on opaque numbers not structured APN IDs

Thanks.
Jeffrey

--
Apn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apn

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 5 Aug 2021 16:04:40 +0000

Hi Shuping,

Talking about “subject of that sentence”, I don’t find the verb. Should “providing” be “provides”?

Assuming it is “… matching provides fine-granularity network service provisioning
       (traffic operations) and SLA guarantee based on the APN attribute
       carried in APN packets.”

Where “matching” is between “Application-aware information and network service provisioning”.

So is the following an accurate scope of APN?

  1.  Marking traffic
  2.  Matching marked traffic to network service to provide SLA guarantee
  3.  Measurement of network performance

Jeffrey

From: Pengshuping (Peng Shuping) <[email-masked]>
Sent: Wednesday, August 4, 2021 2:09 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [Apn] APN vs. Network Slicing

Shuping

Hi Adrian,

Please see zzh> below.

Zzh> https://datatracker.ietf.org/doc/html/draft-li-apn-problem-statement-usecases-04#section-4<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-li-apn-problem-statement-usecases-04*section-4__;Iw!!NEt6yMaO-gk!VgpF2q5pDlnHT2o_kApq17IvzoHQ9tr4XUm0f613O6JbnWmpx8NijR2KzK8kQ6aA$> says:

       requirements.

Best,
Adrian

Hi Shuping,

Jeffrey

Hi Jeffrey,

Thank you!

Best regards,
Shuping

Hi Jim,

Thanks.
Jeffrey