Subject: [art] "identifier" relation type

From: Herbert Van de Sompel <[email-masked]>
Date: Thu, 3 Aug 2017 10:47:34 +0200

hi all,

Yesterday, I submitted the following I-D:

"Identifier: A Link Relation to Convey a Preferred URI for Referencing"

You can find it in the datatracker at:

https://datatracker.ietf.org/doc/draft-vandesompel-identifier/

A pretty HTML version is at:

http://signposting.org/identifier/spec/

The GitHub repository is at:

https://github.com/hvdsomp/signposting

This effort is related to the "Signposting the Scholarly Web" effort, see
http://signposting.org/

Feedback is welcome.

Greetings

Herbert Van de Sompel

-- 
Herbert Van de Sompel
Digital Library Research & Prototyping
Los Alamos National Laboratory, Research Library
http://public.lanl.gov/herbertv/
http://orcid.org/0000-0002-0715-6126

==

---

From: "Manger, James" <[email-masked]>
Date: Fri, 4 Aug 2017 00:04:47 +0000

> https://datatracker.ietf.org/doc/draft-vandesompel-identifier/

The choice of “identifier” as the label couldn’t be more generic. How about using something that is a tad more specific & descriptive, such as “ref-id” or “reference” or “canonicalref”? “canonicalref” has the cute benefit of putting its descriptions near (in an alphabetically-sorted list) to those of “canonical” and “bookmark” that are only subtly different.

https://www.iana.org/assignments/link-relations/link-relations.xhtml

bookmark        Gives a permanent link to use for bookmarking purposes.
canonical         Designates the preferred version of a resource (the IRI and its contents).
canonicalref    Gives a permanent link for the purpose of referencing the resource.

--
James Manger

---

From: Martin Thomson <[email-masked]>
Date: Fri, 4 Aug 2017 12:13:12 +1000

> canonicalref    Gives a permanent link for the purpose of referencing the

Given the title of the I-D as "A Link Relation to Convey a Preferred
URI for Referencing", and its similarity to the definition for
"canonical", and the explanation in the draft regarding "canonical",
this doesn't seem right.

Maybe you could approach this differently and use "alternate" and
defined a new preferred attribute to that.