Subject: Re: [Asrg] Sender Authentication technology lookup

From: cw <[email-masked]>
Date: Fri, 30 Apr 2004 22:36:25 +0100

Apologies for the double post.
I assumed the first email wasn't going through as I sent it with the wrong from address.

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: cw <[email-masked]>
Date: Fri, 30 Apr 2004 13:41:15 +0100

In the process of writing a report that I am currently working on, I'm sure I read somewhere on one of the lists or hundreds of documents that I have read that someone mentioned a problem with having all these different proposals.

The problem is that the recipient has no way of knowing which sender authentication scheme that the claimed sender supports if any. Would it be sensible and viable to have a standard put to be 'suggested' in the most forceful way to the different developers to include some common lookup functionality.

ie something along the lines of a single text record in the DNS zone of the likes of "sender-authentication scheme: X" where X is a published unique identifier for each technology.

That would solve recipients having to guess or try all the different technologies until they get a match. If the record doesn't exist then the client should assume sender authentication is not supported on that domain.

Does that sound sensible?

Regards,
Colin.