Subject: Re: I-D ACTION:draft-nottingham-http-link-header-01.txt

From: Julian Reschke <[email-masked]>
Date: Mon, 05 May 2008 17:39:05 +0200

Jamie Lokier wrote:
> ...
> How about:
> 
>     Generic-Link: URL=value
> 
> Which is required to be written in exactly that form, the URN denotes
> the relation type, and the URN is always unquoted, absolute, and in
> a canonical form.
> 
> It seems to satisfy the same easy parsing and substitution
> requirements that motivate foo-Link, while providing the flexibility
> of URNs for unregistered relation types.
> ...

What I'm missing a bit in this discussion is the fact that the Link 
header already is specified, deployed and supported by some UAs (such as 
Firefox (*) and Opera AFAIK).

Thus I'd really prefer to *extend* it in a backwards-compatible way (as 
proposed by Mark N.) instead of inventing something new.

BR, Julian

(*) for instance: 
<http://developer.mozilla.org/en/docs/Link_prefetching_FAQ>

---

From: Julian Reschke <[email-masked]>
Date: Tue, 06 May 2008 13:51:41 +0200

Phil Archer wrote:
> I decided to try and test this out. To which end I created a simple page 
> at [1] that does not have an HTML link to a stylesheet but then 
> configured the server to include such a link using HTTP.
> 
> The results show that IE and Firefox do not implement HTTP Link but that 
> Opera 9 does. However... the link you give to the Firefox Link 
> Pre-fetching FAQ is interesting.
> ...

Hm. You're sending:

Link: <styles.css>; /="/"; rel="stylesheet" type="text/css"; 
title="Style Sheet";

Shouldn't that be:

Link: <styles.css>; rel="stylesheet"; type="text/css"; title="Style Sheet";

?

BR, Julian

---

From: "Anne van Kesteren" <[email-masked]>
Date: Tue, 06 May 2008 12:42:21 +0100

On Tue, 06 May 2008 12:38:09 +0100, Phil Archer <[email-masked]> wrote:
> Meanwhile, by using rel="stylesheet", my HTTP Link header pointing to  
> the stylesheet is ignored by Firefox.

Works fine for me:

   http://id.annevankesteren.nl/

-- 
Anne van Kesteren
<http://annevankesteren.nl/>
<http://www.opera.com/>

---

From: Julian Reschke <[email-masked]>
Date: Tue, 06 May 2008 14:33:05 +0200

Phil Archer wrote:
> Sorry...
> 
> OK, I've removed the /="/" but but I still get the same results - 
> Firefox doesn't recognise the stylesheet link.
> 
> So why does it work with Anne's page?
> 
> His header is
> 
> Link: <fancy.css>; rel=stylesheet
> 
> mine is now
> 
> Link: <styles.css>; rel="stylesheet" type="text/css"; title="Style Sheet";
> 
> So it looks like I should try removing the quotes around stylesheet, or 
> may the type and title? ... whichever, the two implementations (Firefox 
> and Opera) are not in alignment. C'ést la vie I guess.

There's still a ";" missing between rel= and type=.

BR, Julian