Subject: Re: I-D Action:draft-brown-versioning-link-relations-05.txt

From: Julian Reschke <[email-masked]>
Date: Mon, 07 Dec 2009 15:38:35 +0100

Hi,

FYI - I have now requested registration and publication as Informational 
RFC. If nothing unexpected happens, this could mean that the draft gets 
to IETF Last Call in the next few weeks.

Best regards, Julian

[email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : Link Relations for Simple Version Navigation
> 	Author(s)       : A. Brown, et al.
> 	Filename        : draft-brown-versioning-link-relations-05.txt
> 	Pages           : 13
> 	Date            : 2009-12-07
> 
> This specification defines Atom link relations for navigation between
> a resource and its versions.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-brown-versioning-link-relations-05.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Julian Reschke <[email-masked]>
Date: Mon, 07 Dec 2009 15:38:35 +0100

Hi,

Best regards, Julian

---

From: Jan Algermissen <[email-masked]>
Date: Wed, 09 Dec 2009 23:26:40 +0100

Julian,

when visiting the Dublin Core Web site, I was wondering if the draft  
should clarify whether the intended semantics around 'version' refer  
to versioning systems only or if they could be used in a broader  
context such as multiple versions of a 'work'.

Dublin Core for example defines relationships around the concept of  
'versions', e.g. http://purl.org/dc/terms/isVersionOf

IOW, there might be a situation when I have multiple versions of a  
resource that are not related to 'putting the resource under version  
control' but rather are the result of the evolution of the content.  
Such versions might even reside on different servers, managed by  
different authorities.

Do you feel the draft's semantics of 'version' covers this use case?  
Or not?

Jan

On Dec 7, 2009, at 3:38 PM, Julian Reschke wrote:

>
> Hi,
>
> FYI - I have now requested registration and publication as  
> Informational RFC. If nothing unexpected happens, this could mean  
> that the draft gets to IETF Last Call in the next few weeks.
>
> Best regards, Julian
>
>

--------------------------------------
Jan Algermissen

Mail: [email-masked]
Blog: http://algermissen.blogspot.com/
Home: http://www.jalgermissen.com
--------------------------------------

---

From: Jan Algermissen <[email-masked]>
Date: Wed, 09 Dec 2009 23:26:40 +0100

Julian,

Jan

---

From: Geoffrey M Clemm <[email-masked]>
Date: Wed, 9 Dec 2009 20:53:05 -0500

Putting something under version control really doesn't mean anything 
beyond having multiple versions of the resource.
There are of course a variety of other features supported by many 
versioning servers, but having a version history is the lowest common 
denominator.

So yes, this draft would apply to the case you describe, as long as 
multiple separately addressable versions of the resource are provided.

Cheers,
Geoff

---

From: Geoffrey M Clemm <[email-masked]>
Date: Wed, 9 Dec 2009 20:53:05 -0500

Cheers,
Geoff

---

From: Julian Reschke <[email-masked]>
Date: Fri, 11 Dec 2009 12:13:55 +0100

Geoffrey M Clemm wrote:
> ...

Agreed.

At least for the link relations that support the navigation between 
versions it really doesn't matter whether internally a version control 
system was used. (For the working-copy related relations things may be 
different because they somehow imply authorability of a resource).

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Fri, 11 Dec 2009 12:13:55 +0100

Agreed.

Best regards, Julian