Subject: [AVT] dynamic payload type

From: "kiran lati" <[email-masked]>
Date: 24 Oct 2001 10:00:37 -0000

Hi,

Can any one tell me the clear definition of Dynamic payload type means.

-Kiran 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Wed, 24 Oct 2001 11:19:02 -0400

>Can any one tell me the clear definition of Dynamic payload type means.

A static payload type has a fixed mapping between the payload format and
the payload type number. For example, H261 video is always number 31 and
PCMU audio is always 0.

A dynamic payload type is one where the mapping is defined during session
setup, often using SIP or RTSP. For example, you might find that the SDP 
in the SIP/RTSP message includes:
	m=audio 49000 RTP/AVP 121
	a=rtpmap:121 G7221/16000
meaning that the G.722.1 codec is assigned payload type 121.

The RTP profile in use specifies which payload types may be used for
dynamic assignment, and which have static assignments. See RFC 1890 for
example, for the RTP/AVP rules.

Colin

---

From: Kim Le <[email-masked]>
Date: Wed, 24 Oct 2001 10:47:46 -0700

It's an RTP type that can be used for anything.  Ie ip phones send DTMF
over an agreed number within the dynmoic range.  Typically they use 101 or
100.

-Kim

kiran lati wrote:

> rtp mailing list
> [email-masked]
> http://www.vovida.org/mailman/listinfo/rtp

---

From: "Marshall Eubanks" <[email-masked]>
Date: Wed, 24 Oct 2001 14:04:38 -0400

On Wed, 24 Oct 2001 11:19:02 -0400
> the payload type number. For example, H261 video is

Hi Colin et al.;

   While we are on this subject, here is a question that
keeps coming up here :

Can dynamic types be used to resolve conflicts among a
static type. The 
particular case here is MPEG-1/2 Layers I, II and III, which
all
have the same static type (14). A Layer II player (i.e.,
QuickTime) cannot
play Layer III, and has no way of distinguishing between
Layer II and III given
the one static type. This gives rise to the notion of using
a dynamic type
mapping to resolve this.

Is this an allowed use of the protocol ?

Regards

Marshall Eubanks

---

From: Colin Perkins <[email-masked]>
Date: Wed, 24 Oct 2001 19:07:20 -0400

--> "Marshall Eubanks" writes:
>Can dynamic types be used to resolve conflicts among a static type. The
>particular case here is MPEG-1/2 Layers I, II and III, which all have the
>same static type (14). A Layer II player (i.e., QuickTime) cannot play
>Layer III, and has no way of distinguishing between Layer II and III given
>the one static type. This gives rise to the notion of using a dynamic type
>mapping to resolve this.
>

Seems reasonable to me, but it really depends on the signalling (are you
able to signal which subset of the parameters you want to use?)

Colin