Subject: [AVT] simple question concerning the RTP from a neophyte

From: [email-masked]
Date: Wed, 7 Nov 2001 11:47:33 -0800

I apologize for wasting the time of the list on this simple question, but it is the only way I can see to get an answer.

In the case where a host is the originator of an RTP packet what are the values of the following?

CSRC count (my guess would be that this should be zero)

CSRC, if present at all.  My guess would be that in this case there would be no contributing source identifiers

Thank you very much

Stephen McRobert

If mankind minus one were of one opinion, then mankind is no more justified
in silencing the one than the one - if he had the power - would be
justified in silencing mankind. -John Stuart Mill, philosopher and
economist (1806-1873)

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www1.ietf.org/mailman/listinfo/avt

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 7 Nov 2001 22:24:33 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, November 07, 2001 2:48 PM
> To: [email-masked]
> Subject: [AVT] simple question concerning the RTP from a neophyte
> 
> 
> I apologize for wasting the time of the list on this simple 
> question, but it is the only way I can see to get an answer.
> 

Host is any machine connected to the Internet. I assume, however, you are
talking about a single user PC or something equivalent.

> CSRC count (my guess would be that this should be zero)

If a single user is sending media, CRSRC count is zero and CSRC list is not
present. These fields are used for mixers that combine media from several
users.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com