Subject: [AVT] SRTP question

From: "Peter Barany" <[email-masked]>
Date: Mon, 26 Nov 2001 11:39:53 -0600

Hello colleagues,

A quick question regarding the SRTP Internet draft
(draft-ietf-avt-srtp-01.txt) if anyone has the answer:

Q: In Section 3 "SRTP Overview" of the draft the Figure 1 illustrates the
format of the SRTP packet (with the only difference from an RTP packet being
the addition of the optional SPI and authentication tag at the end of the
packet). Does the payload have to be padded in order for the optional SPI
and/or authentication tags to be used properly?

Thanks.

Regards,

Peter Barany
IP Multimedia Standards and Research
Nortel Networks
+1-972-685-2471 (Office)
+1-972-684-3775 (Fax)
+1-972-467-8346 (Mobile)
e-mail: [email-masked]

---

From: "Elisabetta Carrara (ERA)" <[email-masked]>
Date: Mon, 26 Nov 2001 19:23:53 +0100

Hi
I think there was a discussion about this during the London meeting, and
that the answer was no, we use the profile.
 
BTW, SRTP-02 has not the SPI anymore. The new version of the draft was submitted 
close to the deadline, so it will take maybe same days to appear.
 
thanks,
/Elisabetta

-----Original Message-----
From: Peter Barany [mailto:[email-masked]]
Sent: den 26 november 2001 18:40
To: [email-masked]'
Subject: [AVT] SRTP question

Hello colleagues, 

A quick question regarding the SRTP Internet draft (draft-ietf-avt-srtp-01.txt) if anyone has the answer: 

Q: In Section 3 "SRTP Overview" of the draft the Figure 1 illustrates the format of the SRTP packet (with the only difference from an RTP packet being the addition of the optional SPI and authentication tag at the end of the packet). Does the payload have to be padded in order for the optional SPI and/or authentication tags to be used properly?

Thanks. 

Regards, 

Peter Barany 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www1.ietf.org/mailman/listinfo/avt