Subject: RE: [AVT] The storage format of EVRC/SMV vocoder (resent)

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Tue, 6 May 2003 09:36:18 +0200

Hi all,

The EVRC/SMV draft was put on hold at the IANA while the file
format issue was discussed, but should we not be ready to let
it go now, as originally intended? The format we have worked 
on for a few years now is actually used as file format, and
we should complete our work on that. Whether to address the
qcp format separately must be left independent of the evrc/smv
standard.

Let's finally get the EVRC/SMV file format out!

BR
/Lars-Erik

> -----Original Message-----
> From: Jae-Yong Lee [mailto:[email-masked]]
> Sent: den 1 maj 2003 10:58
> To: Adam Li; Colin Perkins
> Cc: [email-masked]; Scott Bradner; Allison Mankin; 
> [email-masked];
> [email-masked]; [email-masked]; ??? (E-mail); ???
> (E-mail); ??? (E-mail); ??? (E-mail)
> Subject: RE: [AVT] The storage format of EVRC/SMV vocoder (resent) 
> 
> 
> Hello all,
> 
> I regret not being able to respond earlier.
> It took some time to contact all the Korean operators and reconfirm 
> their opinions related to this issue.
> As the representative of Korean operators (SKT/KTF/LGT) for file 
> format issues in 3GPP2, I'd like to clarify the current situation for
> Korean operators and deliver our opinions on this issue. 
> (I cc:ed relevant people from the operators.)
> 
> >> My information on the implementation of the evrc-smv 
> draft's format 
> >> is that Nextreaming uses this as an internal intermediate format 
> >> prior to generating ".3g2" files (as specified in the 3GPP2 FFMS 
> >> specification, which include both formats).  
> 
> This is not correct.
> The EVRC storage format described in the evrc-smv draft is utilized 
> for Korean operators in such way as described in the current 3GPP2 
> FFMS specification, which is actually the only way for EVRC media 
> storage in the 3GPP2 multimedia file format (.3g2).
> The way of storing EVRC media in .3g2 file is exactly same as the 
> way described in the evrc-smv draft except for the magic number, 
> "#!EVRC\n", which will not be included in the .3g2 file format. 
> That is conceptually same as AMR storage in 3GPP file format. 
> One of the most important rationale behind this is to facilitate the 
> conversion of 3GPP2 files from/to EVRC-only files (.3g2 <-> .evc),
> which may be very helpful for some applications, e.g., MMS.
> 
> Having said that, Nextreaming is not the only one that implements 
> and uses it. The relevant terminal and system vendors for Korean 
> operators have completed implementation based on this format and 
> verified interop. 
> Korean operators (also many others in 3GPP2 as far as I understand) 
> have been waiting for the evrc-smv draft with the storage 
> method to be 
> approved as an RFC and are looking forward to it.
> We also share the opinion that the evrc-smv internet draft is
> independent
> of the possible registration of MIME type for .qcp. 
> 
> BR,
> 
> Jay
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Tue, 06 May 2003 09:01:06 -0400

Lars-Erik,

The draft has been released, and is just waiting for the RFC Editor and
IANA to finish their work.

Colin