Subject: [bess] qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

From: Loa Andersson <[email-masked]>
Date: Sun, 3 Apr 2022 13:58:15 +0800

Authors,

When the draft-mpmz-bess-mup-safi were presented at IETF 113, Linda 
asked a question. The audio was bad, but I think Linda asked "VPN 3GPP 
and and VPN6, uses totally different address, how are they
inter-worked?" I could not hear your answer, can you please repeat here?

Wim asked about the relationship to 3GPP. I think your answer was that 
since you are not changing anything in the 3GPP specifications there is 
no problem. That might be correct, but I think it would be prudent to 
let 3GPP know what we are doing.

/Loa

-- 
Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 4 Apr 2022 16:47:14 +0000

Thanks to Loa for reminding me of the questions. 

Actually my question is more fundamental. The 3GPP Mobility Management Function manages the IP address assignments to UEs. Traffic from UEs are tunneled by GTP tunnel between the eNB and UPF. Many UPF has NAT, so the IP network might not see the UE's actual IP addresses. 

Question 1: is draft-mpmz-bess-mup-safi managing the IP address from UPF? Or the actual UEs' IP addresses? 
Question 2: If it is the IP addresses from the UPF, many flows from different UEs are aggregated to one IP. What the BGP extension for Mobile User Plan do? 

Thank you very much. 
Linda

-----Original Message-----
From: Loa Andersson <[email-masked]> 
Sent: Sunday, April 3, 2022 12:58 AM
To: [email-masked]; Linda Dunbar <[email-masked]>; [email-masked]
Cc: BESS <[email-masked]>
Subject: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Authors,

When the draft-mpmz-bess-mup-safi were presented at IETF 113, Linda asked a question. The audio was bad, but I think Linda asked "VPN 3GPP and and VPN6, uses totally different address, how are they inter-worked?" I could not hear your answer, can you please repeat here?

Wim asked about the relationship to 3GPP. I think your answer was that since you are not changing anything in the 3GPP specifications there is no problem. That might be correct, but I think it would be prudent to let 3GPP know what we are doing.

/Loa

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 4 Apr 2022 23:47:20 +0000

Hi Linda, Loa,

Consider a traditional 5G deployment with all necessary NFs, including a central UPF. SMF signals to the UPF on N4 interface. AMF signals to gNBs on N2 interface. The N3 transport (between gNBs and the UPF) is via an IPVPN over a transport infrastructure. There are PEs next to the gNBs and the UPF. The PEs are not 3GPP functions. 

Now replace that UPF with the following: MUP controller, a group of MUP GWs and a MUP PE. The MUP GWs are just the previous PEs next to the gNBs. The MUP PE is just the previous PE next to the replaced UPF. The UPF is no longer needed, but from SMF and gNB's point of view it is still there.

With this replacement, there is no N2/N4 change. gNBs still send GTP packets to the old UPF address; it's just that the GTP packets will be intercepted by the GWs as if the UPF address is a local one. They still receive GTP packets as if being sent from the previous UPF.

The BGP signaling translates N4 signaling to BGP messages. The N4 signaling could include the UE addresses that are managed by the SMF; it could also be that the previous central UPF was managing the UE addresses itself. In either case, the MUP controller will signal the UE addresses (as host routes) to the MUP GWs - whether assigned by the SMF or assigned by the MUP controller (if the addresses were managed by the UPF before).

Jeffrey

Juniper Business Use Only

-----Original Message-----
From: Linda Dunbar <[email-masked]> 
Sent: Monday, April 4, 2022 12:47 PM
To: Loa Andersson <[email-masked]>; [email-masked]; [email-masked]
Cc: BESS <[email-masked]>
Subject: RE: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

[External Email. Be cautious of content]

Thank you very much.
Linda

-----Original Message-----
From: Loa Andersson <[email-masked]>
Sent: Sunday, April 3, 2022 12:58 AM
To: [email-masked]; Linda Dunbar <[email-masked]>; [email-masked]
Cc: BESS <[email-masked]>
Subject: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Authors,

/Loa

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 5 Apr 2022 16:23:36 +0000

Jeffrey, 

You are talking about changing the 3GPP architecture: replacing UPF by MUP and MUP GW, enabling BGP signaling, etc. have you discussed this architecture at 3GPP S2 group? 

Linda

-----Original Message-----
From: Jeffrey (Zhaohui) Zhang <[email-masked]> 
Sent: Monday, April 4, 2022 6:47 PM
To: Linda Dunbar <[email-masked]>; Loa Andersson <[email-masked]>; [email-masked]; [email-masked]
Cc: BESS <[email-masked]>
Subject: RE: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Hi Linda, Loa,

Jeffrey

-----Original Message-----
From: Linda Dunbar <[email-masked]> 
Sent: Monday, April 4, 2022 12:47 PM
To: Loa Andersson <[email-masked]>; [email-masked]; [email-masked]
Cc: BESS <[email-masked]>
Subject: RE: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Thank you very much.
Linda

-----Original Message-----
From: Loa Andersson <[email-masked]>
Sent: Sunday, April 3, 2022 12:58 AM
To: [email-masked]; Linda Dunbar <[email-masked]>; [email-masked]
Cc: BESS <[email-masked]>
Subject: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Authors,

/Loa

---

From: Keyur Patel <[email-masked]>
Date: Tue, 5 Apr 2022 18:45:22 +0000

Hi Linda,

To be clear – We are not replacing the UPF. The UPF still remains in the network. We are also not changing anything that is defined in 3GPP architecture.

Best Regards,
Keyur

From: BESS <[email-masked]> on behalf of Linda Dunbar <[email-masked]>
Date: Tuesday, April 5, 2022 at 9:24 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>, Loa Andersson <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Cc: BESS <[email-masked]>
Subject: Re: [bess] qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113
Jeffrey,

Linda

-----Original Message-----
From: Jeffrey (Zhaohui) Zhang <[email-masked]>
Sent: Monday, April 4, 2022 6:47 PM
To: Linda Dunbar <[email-masked]>; Loa Andersson <[email-masked]>; [email-masked]; [email-masked]
Cc: BESS <[email-masked]>
Subject: RE: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Hi Linda, Loa,

Jeffrey

-----Original Message-----
From: Linda Dunbar <[email-masked]>
Sent: Monday, April 4, 2022 12:47 PM
To: Loa Andersson <[email-masked]>; [email-masked]; [email-masked]
Cc: BESS <[email-masked]>
Subject: RE: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Thank you very much.
Linda

-----Original Message-----
From: Loa Andersson <[email-masked]>
Sent: Sunday, April 3, 2022 12:58 AM
To: [email-masked]; Linda Dunbar <[email-masked]>; [email-masked]
Cc: BESS <[email-masked]>
Subject: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Authors,

/Loa

--
Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64
_______________________________________________
BESS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bess

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 7 Apr 2022 18:26:17 +0000

Jeffery and Keyur,

5G has distributed UPFs, UPFs can collocate with gNB. Therefore, there might not be a router between gNB and UPFs.

All the traffic out of UPFs (on N6 interfaces) are carried by IP networks.

So what does MUP do?

Linda

From: Keyur Patel <[email-masked]>
Sent: Tuesday, April 5, 2022 1:45 PM
To: Linda Dunbar <[email-masked]>; Jeffrey (Zhaohui) Zhang <[email-masked]>; Loa Andersson <[email-masked]>; [email-masked]; [email-masked]
Cc: BESS <[email-masked]>
Subject: Re: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Hi Linda,

To be clear - We are not replacing the UPF. The UPF still remains in the network. We are also not changing anything that is defined in 3GPP architecture.

Best Regards,
Keyur

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 5, 2022 at 9:24 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>, Loa Andersson <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: BESS <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113
Jeffrey,

Linda

-----Original Message-----
From: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>
Sent: Monday, April 4, 2022 6:47 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Loa Andersson <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: BESS <[email-masked]<mailto:[email-masked]>>
Subject: RE: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Hi Linda, Loa,

Jeffrey

-----Original Message-----
From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Sent: Monday, April 4, 2022 12:47 PM
To: Loa Andersson <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: BESS <[email-masked]<mailto:[email-masked]>>
Subject: RE: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Thank you very much.
Linda

-----Original Message-----
From: Loa Andersson <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, April 3, 2022 12:58 AM
To: [email-masked]<mailto:[email-masked]>; Linda Dunbar <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: BESS <[email-masked]<mailto:[email-masked]>>
Subject: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Authors,

/Loa

--
Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert                          [email-masked]<mailto:[email-masked]>
Bronze Dragon Consulting             phone: +46 739 81 21 64
_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbess&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C590b38b4c2e04a1f7c5608da173472a6%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637847811282280388%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=3bk9ofBw2Tolg2r4nLiTY5n6m2j7%2FDlN%2ByEki7Bhwws%3D&reserved=0>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 7 Apr 2022 21:36:08 +0000

Linda,

In the central PSA UPF model, the gNB-UPF N3 interface is over an IP network that is typically implemented as a VPN (referred to as N3VPN). It has PEs close to gNBs and UPFs. What this draft does is moving the central PSA UPF functionality to the MUP GWs (which are N3VPN PEs close to the gNBs).

This is similar to the vanilla/traditional but distributed PSA UPFs that use vanilla N4 signaling, though the difference is that it is based on routers and BGP signaling. It's another way of doing distributed UPF. It may be desired by some operators/vendors, and it is transparent to 3GPP architecture and signaling (as far as SMF/gNBs are concerned, they are still interacting with a centralized PSA UPF even though it is realized by a collection of <MUP Controller, MUP GWs, MUP PE>).

Jeffrey

Juniper Business Use Only
From: Linda Dunbar <[email-masked]>
Sent: Thursday, April 7, 2022 2:26 PM
To: Keyur Patel <[email-masked]>; Jeffrey (Zhaohui) Zhang <[email-masked]>; Loa Andersson <[email-masked]>; [email-masked]; [email-masked]
Cc: BESS <[email-masked]>
Subject: RE: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Jeffery and Keyur,

So what does MUP do?

Linda

From: Keyur Patel <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, April 5, 2022 1:45 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; Loa Andersson <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: BESS <[email-masked]<mailto:[email-masked]>>
Subject: Re: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Hi Linda,

Best Regards,
Keyur

Linda

-----Original Message-----
From: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>
Sent: Monday, April 4, 2022 6:47 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Loa Andersson <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: BESS <[email-masked]<mailto:[email-masked]>>
Subject: RE: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Hi Linda, Loa,

Jeffrey

-----Original Message-----
From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Sent: Monday, April 4, 2022 12:47 PM
To: Loa Andersson <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: BESS <[email-masked]<mailto:[email-masked]>>
Subject: RE: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Thank you very much.
Linda

-----Original Message-----
From: Loa Andersson <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, April 3, 2022 12:58 AM
To: [email-masked]<mailto:[email-masked]>; Linda Dunbar <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: BESS <[email-masked]<mailto:[email-masked]>>
Subject: qquestion om draft-mpmz-bess-mup-saf at the bess meeting at IETF 113

Authors,

/Loa

https://www.ietf.org/mailman/listinfo/bess<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbess&data=04*7C01*7Clinda.dunbar*40futurewei.com*7C590b38b4c2e04a1f7c5608da173472a6*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637847811282280388*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&sdata=3bk9ofBw2Tolg2r4nLiTY5n6m2j7*2FDlN*2ByEki7Bhwws*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!UZMvgFx5FTG01uH0Cz8SjDErKF0UOQvbJsO3-4LgcFRCn6OV0IOb3NXHyabYep7I$>