Subject: [clue] Area Scale Millimeters

From: Roni Even <[email-masked]>
Date: Sun, 16 Oct 2011 21:31:43 +0200

Hi,

The default for Area Scale Millimeters is no physical scale. During the
Interim meeting my understanding was the even though there is no physical
scale there is some scale since the numbers reported can be used to find the
relation in the x direction between the different areas and between an area
and a gap. For example an area of (0,25) is half the size of an area
(25,75). 

This also imply that x(0,50) is twice the size of y(0,25) for two dimension.
If this is the understanding also of the authors of the draft than I am not
sure why it is easier to use no physical scale since you need some scale to
have the correct proportions between axis

Regards

Roni Even

---

From: "Brian Baldino (bbaldino)" <[email-masked]>
Date: Mon, 17 Oct 2011 10:17:01 -0700

Hey Roni,

Not sure I understand how you're saying that a relative scale requires
as much detail as an absolute scale (millimeters).  If I don't care (or
don't know) the dimensions of my room in millimeters, but I know it's
divided up into thirds, it's easy for me to describe the 3 areas of
capture as {(0,32),(33,65),(66,99)} or even {(0,1),(1,2),(2,3)}.  Both
of those areas of capture tell the renderer spatial ordering which may
be all that is required for some devices.

-Brian

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Roni Even
Sent: Sunday, October 16, 2011 12:32 PM
To: [email-masked]
Subject: [clue] Area Scale Millimeters

Hi,

The default for Area Scale Millimeters is no physical scale. During the
Interim meeting my understanding was the even though there is no
physical scale there is some scale since the numbers reported can be
used to find the relation in the x direction between the different areas
and between an area and a gap. For example an area of (0,25) is half the
size of an area (25,75). 

This also imply that x(0,50) is twice the size of y(0,25) for two
dimension. If this is the understanding also of the authors of the draft
than I am not sure why it is easier to use no physical scale since you
need some scale to have the correct proportions between axis

Regards

Roni Even

---

From: Stephen Botzko <[email-masked]>
Date: Mon, 17 Oct 2011 13:30:43 -0400

I agree.  For instance, if you aren't particularly interested in actual size
display or gaps between captures, you could simply use capture pixels as
your relative scale.  So it is possible to get some utility (e.g. adjacency
at least) without any measurements at all.

I expect we would use physical MM scale in our signaling.  I'd rather know
if a far-end is using a true physical scale, or not - since in the latter
case I would defeat any re-scaling/cropping to get true size.

Steve B.

On Mon, Oct 17, 2011 at 1:17 PM, Brian Baldino (bbaldino) <
[email-masked]> wrote:

>  Hey Roni,****
>
> Not sure I understand how you’re saying that a relative scale requires as
> much detail as an absolute scale (millimeters).  If I don’t care (or don’t
> know) the dimensions of my room in millimeters, but I know it’s divided up
> into thirds, it’s easy for me to describe the 3 areas of capture as
> {(0,32),(33,65),(66,99)} or even {(0,1),(1,2),(2,3)}.  Both of those areas
> of capture tell the renderer spatial ordering which may be all that is
> required for some devices.****
>
> ** **
>
> -Brian****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *Roni Even
> *Sent:* Sunday, October 16, 2011 12:32 PM
> *To:* [email-masked]
> *Subject:* [clue] Area Scale Millimeters****
>
> ** **
>
> Hi,****
>
> (25,75). ****
> than I am not sure why it is easier to use no physical scale since you need
> some scale to have the correct proportions between axis****
>
> Regards****
>
> Roni Even****
>
> ** **
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>
>

---

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 17 Oct 2011 11:11:24 -0700

I agree too.  To further clarify a point Roni brought up in the meeting last week, the intent is for the scale to be the same linear scale in all dimensions (x,y, z), even if you don't know it is millimeters.  So the range 0 to 32 has the same length as the range 33 to 65.  The physical scale would be either millimeters or undefined, not some other unit of measurement.

Mark

From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephen Botzko
Sent: Monday, October 17, 2011 1:31 PM
To: Brian Baldino (bbaldino)
Cc: [email-masked]
Subject: Re: [clue] Area Scale Millimeters

I agree.  For instance, if you aren't particularly interested in actual size display or gaps between captures, you could simply use capture pixels as your relative scale.  So it is possible to get some utility (e.g. adjacency at least) without any measurements at all.

I expect we would use physical MM scale in our signaling.  I'd rather know if a far-end is using a true physical scale, or not - since in the latter case I would defeat any re-scaling/cropping to get true size.

Steve B.

On Mon, Oct 17, 2011 at 1:17 PM, Brian Baldino (bbaldino) <[email-masked]<mailto:[email-masked]>> wrote:
Hey Roni,
Not sure I understand how you're saying that a relative scale requires as much detail as an absolute scale (millimeters).  If I don't care (or don't know) the dimensions of my room in millimeters, but I know it's divided up into thirds, it's easy for me to describe the 3 areas of capture as {(0,32),(33,65),(66,99)} or even {(0,1),(1,2),(2,3)}.  Both of those areas of capture tell the renderer spatial ordering which may be all that is required for some devices.

-Brian

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Roni Even
Sent: Sunday, October 16, 2011 12:32 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [clue] Area Scale Millimeters

Hi,
The default for Area Scale Millimeters is no physical scale. During the Interim meeting my understanding was the even though there is no physical scale there is some scale since the numbers reported can be used to find the relation in the x direction between the different areas and between an area and a gap. For example an area of (0,25) is half the size of an area (25,75).
This also imply that x(0,50) is twice the size of y(0,25) for two dimension. If this is the understanding also of the authors of the draft than I am not sure why it is easier to use no physical scale since you need some scale to have the correct proportions between axis
Regards
Roni Even

_______________________________________________
clue mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/clue

---

From: Christian Groves <[email-masked]>
Date: Tue, 18 Oct 2011 09:50:59 +1100

Is the issue that even though we say the scale is "relative" it does in 
fact relate to something physical? i.e. in Brian's examples even though 
the scale is relative the areas are physically 1/3rd of the room.

Roni, is your concern that we need to specify that the scale must be 
linear and consistent between all axis?

Regards, Christian

On 18/10/2011 5:11 AM, Duckworth, Mark wrote:
>
> I agree too. To further clarify a point Roni brought up in the meeting 
> last week, the intent is for the scale to be the same linear scale in 
> all dimensions (x,y, z), even if you don’t know it is millimeters. So 
> the range 0 to 32 has the same length as the range 33 to 65. The 
> physical scale would be either millimeters or undefined, not some 
> other unit of measurement.
>
> Mark
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of *Stephen Botzko
> *Sent:* Monday, October 17, 2011 1:31 PM
> *To:* Brian Baldino (bbaldino)
> *Cc:* [email-masked]
> *Subject:* Re: [clue] Area Scale Millimeters
>
> I agree. For instance, if you aren't particularly interested in actual 
> size display or gaps between captures, you could simply use capture 
> pixels as your relative scale. So it is possible to get some utility 
> (e.g. adjacency at least) without any measurements at all.
>
> I expect we would use physical MM scale in our signaling. I'd rather 
> know if a far-end is using a true physical scale, or not - since in 
> the latter case I would defeat any re-scaling/cropping to get true size.
>
> Steve B.
>
> On Mon, Oct 17, 2011 at 1:17 PM, Brian Baldino (bbaldino) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
> Hey Roni,
>
> Not sure I understand how you’re saying that a relative scale requires 
> as much detail as an absolute scale (millimeters). If I don’t care (or 
> don’t know) the dimensions of my room in millimeters, but I know it’s 
> divided up into thirds, it’s easy for me to describe the 3 areas of 
> *From:[email-masked] <mailto:[email-masked]> 
> [mailto:[email-masked] <mailto:[email-masked]>] *On 
> Behalf Of *Roni Even
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* [clue] Area Scale Millimeters
>
> Hi,
>
> The default for Area Scale Millimeters is no physical scale. During 
> the Interim meeting my understanding was the even though there is no 
> used to find the relation in the x direction between the different 
> areas and between an area and a gap. For example an area of (0,25) is 
> half the size of an area (25,75).
>
> dimension. If this is the understanding also of the authors of the 
> draft than I am not sure why it is easier to use no physical scale 
> since you need some scale to have the correct proportions between axis
>
> Regards
>
> Roni Even
>
>
> [email-masked] <mailto:[email-masked]>

---

From: Roni Even <[email-masked]>
Date: Tue, 18 Oct 2011 00:56:38 +0200

Brian,

This is very easy if you use only one dimension. If you use two dimensions
it will mean that 0 to 32 in X direction is the same size as 0 to 32 in the
Y direction. I think this will require some unit to do the actual
measurement otherwise how does the sender of the information know that they
are the same size. A third of the room in X direction is not the same size
of third of the room in Y direction.

I can agree that relative scale is easier if you are using just X
coordinates and want to convey only the spatial order in the X direction.
My question was if this is enough as a default information from the sender,
my view is that it is not. Having some absolute values will be more helpful
for scaling or cropping.

Roni

From: Brian Baldino (bbaldino) [mailto:[email-masked]] 
Sent: Monday, October 17, 2011 7:17 PM
To: Roni Even; [email-masked]
Subject: RE: [clue] Area Scale Millimeters

Hey Roni,

Not sure I understand how you're saying that a relative scale requires as
much detail as an absolute scale (millimeters).  If I don't care (or don't
know) the dimensions of my room in millimeters, but I know it's divided up
into thirds, it's easy for me to describe the 3 areas of capture as
{(0,32),(33,65),(66,99)} or even {(0,1),(1,2),(2,3)}.  Both of those areas
of capture tell the renderer spatial ordering which may be all that is
required for some devices.

-Brian

From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni
Even
Sent: Sunday, October 16, 2011 12:32 PM
To: [email-masked]
Subject: [clue] Area Scale Millimeters

Hi,

Regards

Roni Even

---

From: Roni Even <[email-masked]>
Date: Tue, 18 Oct 2011 01:00:40 +0200

Ho Christian,
Yes, so I believe that in order to support a scale that is linear and
consistent between all axis we define some absolute measurement even if we
do not call it mm.
If we go this way, having a real value like mm will help the receiver to
scale and crop since it knows what are the real sizes of the reported areas.
The discussion is also about what is the minimum default that should be
supported.
Roni

> -----Original Message-----
> Christian Groves
> Sent: Tuesday, October 18, 2011 12:51 AM
> To: [email-masked]
> > all dimensions (x,y, z), even if you don't know it is millimeters. So

---

From: "Brian Baldino (bbaldino)" <[email-masked]>
Date: Mon, 17 Oct 2011 16:10:53 -0700

Christian had a good point and I think I mis-spoke a bit.  I did not
mean to associate them with thirds of the "room", only to imply that
they were of equal size.

I still see your point though, Roni (about multiple dimensions).  But
certainly not all endpoints/devices will want to describe themselves in
multiple dimensions either, right?  I think that forcing implementers to
always describe their devices in accurate millimeters will be a burden
(and sometimes impossible).  

-Brian

From: Roni Even [mailto:[email-masked]] 
Sent: Monday, October 17, 2011 3:57 PM
To: Brian Baldino (bbaldino); [email-masked]
Subject: RE: [clue] Area Scale Millimeters

Brian,

This is very easy if you use only one dimension. If you use two
dimensions it will mean that 0 to 32 in X direction is the same size as
0 to 32 in the Y direction. I think this will require some unit to do
the actual measurement otherwise how does the sender of the information
know that they are the same size. A third of the room in X direction is
not the same size of third of the room in Y direction.

I can agree that relative scale is easier if you are using just X
coordinates and want to convey only the spatial order in the X
direction.   My question was if this is enough as a default information
from the sender, my view is that it is not. Having some absolute values
will be more helpful for scaling or cropping.

Roni

Hey Roni,

-Brian

Hi,

Regards

Roni Even