Subject: [clue] the presentation use case

From: <[email-masked]>
Date: Fri, 7 Oct 2011 11:25:16 +0000

Hi

I will not be able to attend physically to the interim meeting.

However I had a comment on the presentation use case, which I still consider we need to agree on. 
In the use case draft, the presentation use case is restricted to the video based solution. To me, it should be modified so that:
- It does not restrict the solution to the video
- It includes the need to share any kind of documents (including complex documents such as excel sheets) and the ability to have remote control

See below the discussion.

Regards,
Stéphane.

-----Message d'origine-----
De : Paul Kyzivat [mailto:[email-masked]] 
Envoyé : vendredi 12 août 2011 17:31
À : CAZEAUX Stephane RD-BIZZ-CAE
Cc : [email-masked]
Objet : Re: [clue] Comment on the presentation use case

On 8/12/11 4:48 AM, [email-masked] wrote:
> Hi Paul,
>
> I understand your suggestion, and I am aware that it could be a solution. It certainly makes sense, but I am not sure of how it could be integrated in CLUE. To me, this is a matter of application integration, at application level.
>
> My suggestion is that we should think of a solution that provides more satisfying collaboration within telepresence, with the same level of interoperability and multistream interaction as presentation video stream provides, but with more satisfying quality (video is not suitable for all kinds of shared documents) and more collaborative features.
> I don't think that the kind of relationship that you suggest is the only solution.

IMO the main thing is to not constrain the mechanism used for 
collaboration/web sharing. That stuff is evolving at "web speed". 
Anything you nail down that is constraining will be obsolete before it 
gets out.

(I've been looking more at RTCWEB recently, and I'm wondering if perhaps 
CLUE ought to be based on that.)

	Thanks,
	Paul (as individual)

> Stephane.
>
>
> -----Message d'origine-----
> De : Paul Kyzivat [mailto:[email-masked]]
> Envoyé : lundi 8 août 2011 21:23
> À : CAZEAUX Stephane RD-BIZZ-CAE
> Cc : [email-masked]
> Objet : Re: [clue] Comment on the presentation use case
>
> On 8/8/11 11:56 AM, [email-masked] wrote:
>> Hi,
>>
>> To me, it should be part of the telepresence protocols at least to enable the interoperability, as the presentation based on video stream allows it.
>>
>> The point is that video stream is not convenient for the use cases I suggested. But it does not necessarily mean that we should bundle a full data sharing protocol with telepresence. Something simpler, like the RFB option of draft-garcia-mmusic-sdp-collaboration, could be a candidate.
>
> What I was suggesting is that maybe it would make sense to turn those
> relationships "inside out".
>
> For instance when I use a collaboration tool like Webex, the
> collaboration is set up first via the web, and defines the set of
> participants. Then a voice session can be added. For pragmatic reasons,
> the voice conferencing seems to be pretty distinct. (I'm not certain how
> webex handles video. I suspect it is doing it via the web, not the
> telephony conference.)
>
> Its not hard to imagine the same sort of setup, but with a multiparty
> telepresence session instead of the traditional voice conference. In
> such a case, you would probably want the collaboration tool (webex, or
> whatever) to mediate the UI for the web collaboration, the roster, etc.
> It might delegate a lot of that to the telepresence infrastructure.
>
> But that does raise some questions about how all the components fit
> together. Is there a single screen for the collaboration session in a
> telepresence room? What about input to that - keyboard, mouse, etc.? Or
> do we assume that each person in the room has their own computer with
> input, display, etc. and maybe a way to slave the web collaboration
> session to one or more of the big displays in the room?
>
> What probably *can't* be done right now is nail down a particular web
> collaboration service (e.g. Webex) or protocol. That does complicate
> slaving the collaboration session to a screen, unless its done by having
> someone connect a video connection to their own computer.
>
> 	Thanks,
> 	Paul
>
>> Stephane.
>>
>>
>> -----Message d'origine-----
>> De : [email-masked] [mailto:[email-masked]] De la part de Paul Kyzivat
>> Envoyé : jeudi 28 juillet 2011 13:41
>> À : CHATRAS Bruno RD-CORE-ISS
>> Cc : [email-masked]
>> Objet : Re: [clue] Comment on the presentation use case
>>
>> On 7/28/11 2:37 AM, [email-masked] wrote:
>>> I think we should take a look to
>>> http://tools.ietf.org/html/draft-garcia-mmusic-sdp-collaboration-00
>>
>> Maybe. But that is almost orthogonal to what I was suggesting.
>>
>> 	THanks,
>> 	Paul
>> 	(as individual)
>>
>>> Bruno
>>>
>>>> -----Message d'origine-----
>>>> De : [email-masked] [mailto:[email-masked]] De la part de
>>>> Paul Kyzivat
>>>> Envoyé : jeudi 28 juillet 2011 06:05
>>>> À : Roni Even
>>>> Cc : [email-masked]
>>>> Objet : Re: [clue] Comment on the presentation use case
>>>>
>>>> On 7/27/11 11:28 PM, Roni Even wrote:
>>>>> Hi,
>>>>> HTTP is not defining a common data sharing protocol. WebEx may be
>>>> carried
>>>>> over HTTP but the data sharing application is not standard. What I
>>>> meant is
>>>>> that it can either be something that is a common data sharing
>>>> protocol or
>>>>> something that is carried as an RTP payload which require some common
>>>>> defined protocol on top.
>>>>
>>>> I was being a bit tongue in cheek, though not entirely.
>>>> Of course you are right - that if you want to push data to everybody
>>>> you
>>>> need more.
>>>>
>>>> But data sharing by pointing a video camera at a piece of paper is a
>>>> tad
>>>> out of date. Connecting the video port on a user's computer as a video
>>>> source and distributing it with the other video is better than that.
>>>> But
>>>> its not nearly as convenient as webex or any of its competitors.
>>>>
>>>> It isn't entirely clear that its *necessary* to bundle the data sharing
>>>> application with the telepresence protocols. Its kind of limiting since
>>>> the web apps evolve very rapidly. Perhaps we should be doing the
>>>> opposite of that: providing a way to embed the control of the
>>>> telepresence system into a web app.
>>>>
>>>> 	Thanks,
>>>> 	Paul
>>>>
>>>>>> -----Original Message-----
>>>>>> From: [email-masked] [mailto:[email-masked]] On Behalf
>>>> Of
>>>>>> Paul Kyzivat
>>>>>> Sent: Thursday, July 28, 2011 1:29 AM
>>>>>> To: [email-masked]
>>>>>> Subject: Re: [clue] Comment on the presentation use case
>>>>>>
>>>>>> On 7/27/11 6:07 PM, Roni Even wrote:
>>>>>>> Hi Stephane,
>>>>>>>
>>>>>>> Is there a standard protocol that is used for conveying this
>>>>>>> information, is it RTP based.
>>>>>>
>>>>>> AFAIK this is often http. (E.g. webex)
>>>>>>
>>>>>>> To me this is a separate application that can be integrated in the
>>>>>>> application level and not as part of the multistream.
>>>>>>
>>>>>> I guess this depends on whether the support for it is integrated
>>>> into
>>>>>> the "room", or is just incidental equipment brought by the users,
>>>> not
>>>>>> formally related to the telepresence session.
>>>>>>
>>>>>> 	Thanks,
>>>>>> 	Paul
>>>>>> 	(speaking as an individual)
>>>>>>
>>>>>>> Roni
>>>>>>>
>>>>>>> [email-masked] [mailto:[email-masked]] *On Behalf Of
>>>>>>> [email-masked]
>>>>>>> *Sent:* Thursday, July 21, 2011 2:33 PM
>>>>>>> *To:* [email-masked]
>>>>>>> *Subject:* [clue] Comment on the presentation use case*
>>>>>>>
>>>>>>> **
>>>>>>>
>>>>>>> *Hi,*
>>>>>>>
>>>>>>> **
>>>>>>>
>>>>>>> *The presentation use case as described in the use-cases document
>>>> is
>>>>>>> based on the assumption that the presentation stream relies on a
>>>>>> video
>>>>>>> stream, and is limited to usage of presentation video streams. But
>>>> we
>>>>>>> could also consider collaborative use cases, meaningful for
>>>>>>> telepresence, which are not covered by the existing text.*
>>>>>>>
>>>>>>> *I propose to complete the existing text as follows:*
>>>>>>>
>>>>>>> **
>>>>>>>
>>>>>>> *Furthermore, although most today's systems use video streams for
>>>>>>> presentations, there are use cases where this is not suitable. For
>>>>>> example:*
>>>>>>>
>>>>>>> *- The professor which shares an electronic whiteboard (could be a
>>>>>>> whiteboard application on a PC, with screen capture of the PC)
>>>> where
>>>>>> all
>>>>>>> students can participate. Students will take control of the shared
>>>>>>> whiteboard in turns.*
>>>>>>>
>>>>>>> *- In a multipoint meeting, a shared document can be kept always
>>>>>> visible
>>>>>>> in a screen, while other documents are presented on other screens
>>>>>> (with
>>>>>>> possible in turns presentation). For instance, for the purpose of
>>>>>> shared
>>>>>>> design document, notes taking, polls, etc. A shared document
>>>> implies
>>>>>>> that all participants can modify it in turns.*
>>>>>>>
>>>>>>> *"*
>>>>>>>
>>>>>>> **
>>>>>>>
>>>>>>> **
>>>>>>>
>>>>>>> *St ephane. v>
>>>>>>> *
>>>>>>>
>>>>>>> *
>>>>>>> *
>>>>>>>
>>>>>>> *_______________________________________________
>>>>>>> clue mailing list
>>>>>>> [email-masked]
>>>>>>> https://www.ietf.org/mailman/listinfo/clue
>>>>>>> *
>>>>>>
>>>>>> _______________________________________________
>>>>>> clue mailing list
>>>>>> [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/clue
>>>>>
>>>>>
>>>>
>>>> _______________________________________________
>>>> clue mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/clue
>>>
>>
>> _______________________________________________
>> clue mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/clue
>>
>
>

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 7 Oct 2011 10:50:50 -0700

Hi Stéphane,

The CLUE framework is intended to handle any media type that is carried over RTP.  The framework document should be relating to "media captures" and "media streams" in general, except when there is a need to be more specific about video or audio or any other media type.  There are probably some places in the document where it would be better to be more general, to make sure it applies to any media type where appropriate.

So if you want to send excel sheet data over RTP, then CLUE should be able to handle it regarding associating it with audio or giving it some spatial relationship to other media streams, for example.

I think this is as far as CLUE should go with regard to document sharing.  I think additional use cases about document sharing are not relevant to CLUE.  My thinking is based on this statement from the CLUE charter:

"The focus of this work is on multiple RTP audio and video streams.  Other media types may be considered, however development of methodologies for them is not within the scope of this work."

Regards,
Mark Duckworth

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Friday, October 07, 2011 7:25 AM
> To: [email-masked]
> Subject: [clue] the presentation use case
> 
> Hi
> 
> In the use case draft, the presentation use case is restricted to the
> video based solution. To me, it should be modified so that:
> - It includes the need to share any kind of documents (including
> complex documents such as excel sheets) and the ability to have remote
> control
> 
> > I understand your suggestion, and I am aware that it could be a
> solution. It certainly makes sense, but I am not sure of how it could
> be integrated in CLUE. To me, this is a matter of application
> integration, at application level.
> >
> > My suggestion is that we should think of a solution that provides
> more satisfying collaboration within telepresence, with the same level
> of interoperability and multistream interaction as presentation video
> stream provides, but with more satisfying quality (video is not
> suitable for all kinds of shared documents) and more collaborative
> features.
> >> To me, it should be part of the telepresence protocols at least to
> enable the interoperability, as the presentation based on video stream
> allows it.
> >>
> >> The point is that video stream is not convenient for the use cases I
> suggested. But it does not necessarily mean that we should bundle a
> full data sharing protocol with telepresence. Something simpler, like
> the RFB option of draft-garcia-mmusic-sdp-collaboration, could be a
> candidate.
> >

Subject: [clue] the presentation use case
From: "[email-masked]" <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Fri, 7 Oct 2011 04:25:16 -0700
List-Id: CLUE - ControLling mUltiple streams for TElepresence <clue.ietf.org>

Hi

Regards,
Stéphane.

-----Message d'origine-----
De : Paul Kyzivat [mailto:[email-masked]]
Envoyé : vendredi 12 août 2011 17:31
À : CAZEAUX Stephane RD-BIZZ-CAE
Cc : [email-masked]
Objet : Re: [clue] Comment on the presentation use case

        Thanks,
        Paul (as individual)

---

From: Roni Even <[email-masked]>
Date: Fri, 07 Oct 2011 20:15:33 +0200

Hi, Stephane,
I think that by saying video, audio and real-time text we mean any media
that is carried over RTP starting with a SIP call. When talking about other
collaboration I am not sure how they are negotiate the sharing protocol and
what is the call setup. Can you provide more input on the call flow to
establish other data transport that is not using RTP. This will be helpful
if we want to describe a use case.

Thanks
Roni

> Sent: Friday, October 07, 2011 1:25 PM
> To: [email-masked]

---

From: <[email-masked]>
Date: Mon, 10 Oct 2011 17:29:48 +0000

Hi,

Thus I still think that the use case, as currently described, is too restrictive. One could think that only the video based presentation is considered within the use cases, while we probably all agree that CLUE is more generic. Could it be appropriate to indicate explicitly in the use case that other solutions for document sharing could also be considered in the future?

Stéphane.

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Duckworth, Mark
Envoyé : vendredi 7 octobre 2011 19:51
À : [email-masked]
Objet : Re: [clue] the presentation use case

Hi Stéphane,

Regards,
Mark Duckworth

> Of [email-masked]
> De : Paul Kyzivat [mailto:[email-masked]] Envoyé : vendredi 12 
> août 2011 17:31 À : CAZEAUX Stephane RD-BIZZ-CAE Cc : [email-masked] 
> (I've been looking more at RTCWEB recently, and I'm wondering if 
> perhaps CLUE ought to be based on that.)
> 
> 	Thanks,
> 	Paul (as individual)
> 
> > Stephane.
> >
> >
> > De : Paul Kyzivat [mailto:[email-masked]] Envoyé : lundi 8 
> > août 2011 21:23 À : CAZEAUX Stephane RD-BIZZ-CAE Cc : [email-masked] 
> > What I was suggesting is that maybe it would make sense to turn 
> > those relationships "inside out".
> >
> > Its not hard to imagine the same sort of setup, but with a 
> > multiparty telepresence session instead of the traditional voice 
> > conference. In such a case, you would probably want the 
> > collaboration tool (webex,
> or
> > together. Is there a single screen for the collaboration session in 
> > a telepresence room? What about input to that - keyboard, mouse, etc.?
> Or
> > do we assume that each person in the room has their own computer 
> > with input, display, etc. and maybe a way to slave the web 
> > collaboration session to one or more of the big displays in the room?
> >
> > What probably *can't* be done right now is nail down a particular 
> > web collaboration service (e.g. Webex) or protocol. That does 
> > complicate slaving the collaboration session to a screen, unless its 
> > done by
> having
> >> De : [email-masked] [mailto:[email-masked]] De la 
> >> part
> de Paul Kyzivat
> >> Envoyé : jeudi 28 juillet 2011 13:41 À : CHATRAS Bruno RD-CORE-ISS 
> >> Cc : [email-masked] Objet : Re: [clue] Comment on the presentation 
> >> use case
> >>
> >>>> Envoyé : jeudi 28 juillet 2011 06:05 À : Roni Even Cc : 
> >>>> [email-masked] Objet : Re: [clue] Comment on the presentation use 
> >>>> case
> >>>>
> >>>> But data sharing by pointing a video camera at a piece of paper 
> >>>> is
> a
> >>>> tad

---

From: "Allyn Romanow (allyn)" <[email-masked]>
Date: Mon, 10 Oct 2011 11:33:36 -0700

Hi Stephane, 
Could you supply the text that you would like to have added? It would good to be very specific, rather than general, since that what the use cases are - the specific scenarios of interest to you.

Since xcel (over RTP) was your example, and as Mark said, it is currently covered, I'm not sure exactly what case you have in mind that is either not already covered or in scope for the current charter.

Thanks,
Allyn

> Sent: Monday, October 10, 2011 10:30 AM
> To: [email-masked]
> Subject: Re: [clue] the presentation use case
> 
> Hi,
> 
> Thus I still think that the use case, as currently described, is too
> restrictive. One could think that only the video based presentation is
> considered within the use cases, while we probably all agree that CLUE
> is more generic. Could it be appropriate to indicate explicitly in the
> use case that other solutions for document sharing could also be
> considered in the future?
> 
> Stéphane.
> 
> Duckworth, Mark
> The CLUE framework is intended to handle any media type that is carried
> over RTP.  The framework document should be relating to "media
> captures" and "media streams" in general, except when there is a need
> to be more specific about video or audio or any other media type.
> There are probably some places in the document where it would be better
> to be more general, to make sure it applies to any media type where
> appropriate.
> 
> So if you want to send excel sheet data over RTP, then CLUE should be
> able to handle it regarding associating it with audio or giving it some
> spatial relationship to other media streams, for example.
> 
> I think this is as far as CLUE should go with regard to document
> sharing.  I think additional use cases about document sharing are not
> relevant to CLUE.  My thinking is based on this statement from the CLUE
> charter:
> 
> "The focus of this work is on multiple RTP audio and video streams.
> Other media types may be considered, however development of
> methodologies for them is not within the scope of this work."
> 
> Regards,
> Mark Duckworth
> 
> > > the voice conferencing seems to be pretty distinct. (I'm not
> certain
> > how
> > >>> http://tools.ietf.org/html/draft-garcia-mmusic-sdp-collaboration-
> 0
> > >>> 0
> > >>
> > part de
> > >>>>> over HTTP but the data sharing application is not standard.
> What
> > I
> > >>>> meant is
> > >>>> application with the telepresence protocols. Its kind of
> limiting
> > since
> > >>>>>>> To me this is a separate application that can be integrated
> in
> > the
> > >>>>>>> based on the assumption that the presentation stream relies
> on
> > a
> > >>>>>> video
> > >>>>>>> stream, and is limited to usage of presentation video
> streams.
> > But
> > >>>> we
> > >>>>>>> presentations, there are use cases where this is not
> suitable.
> > For
> > >>>>>> example:*
> > >>>>>>>
> > >>>>>>> possible in turns presentation). For instance, for the
> purpose
> > of
> > >>>>>> shared

---

From: <[email-masked]>
Date: Mon, 10 Oct 2011 16:53:26 +0000

Hi,

Stéphane.

-----Message d'origine-----

Hi Stéphane,

Regards,
Mark Duckworth

---

From: Stephen Botzko <[email-masked]>
Date: Mon, 10 Oct 2011 18:29:09 -0400

I think the reason for considering video-based presentations within CLUE is
that they create additional RTP media streams (potentially audio and video)
that need to be accounted for.  Other methods are certainly not precluded.
I am not sure why you think a note is needed, or how it would influence
protocol design.

Stephen Botzko

On Mon, Oct 10, 2011 at 12:53 PM, <[email-masked]> wrote:

> considered within the use cases, while we probably all agree that CLUE is
> more generic. Could it be appropriate to indicate explicitly in the use case
> that other solutions for document sharing could also be considered in the
> future?
>
> Stéphane.
>
> over RTP.  The framework document should be relating to "media captures" and
> "media streams" in general, except when there is a need to be more specific
> about video or audio or any other media type.  There are probably some
> places in the document where it would be better to be more general, to make
> sure it applies to any media type where appropriate.
>
> So if you want to send excel sheet data over RTP, then CLUE should be able
> to handle it regarding associating it with audio or giving it some spatial
> relationship to other media streams, for example.
>
> I think this is as far as CLUE should go with regard to document sharing.
>  I think additional use cases about document sharing are not relevant to
> CLUE.  My thinking is based on this statement from the CLUE charter:
>
> "The focus of this work is on multiple RTP audio and video streams.  Other
> media types may be considered, however development of methodologies for them
> is not within the scope of this work."
>
> Regards,
> Mark Duckworth
>

---

From: <[email-masked]>
Date: Mon, 24 Oct 2011 07:58:53 +0000

Hi,

Sorry for the delay in the response.

My point does not concern what kind of document can be conveyed in the presentation stream, but the fact that the use case assumes that the presentation stream is a _video_ presentation stream (i.e. presentation is coded using a video codec). The example of the excel doc aims to highlight that video coding is not convenient to the readability of such document.

A proposal is to use the wording "stream" or "presentation stream" instead of "video stream", "video presentation stream" or "presentation video" in the section 3.4, so that the use case is more agnostic to the solution.

Stephane.

-----Message d'origine-----
De : Allyn Romanow (allyn) [mailto:[email-masked]] 
Envoyé : lundi 10 octobre 2011 20:34
À : CAZEAUX Stephane RD-BIZZ-CAE; [email-masked]
Objet : RE: [clue] the presentation use case

Hi Stephane, 

Thanks,
Allyn

---

From: Roni Even <[email-masked]>
Date: Mon, 24 Oct 2011 10:59:01 +0200

Hi Stephane,
Thanks for the clarification. I will change the text to use presentation
stream.
Roni

> Sent: Monday, October 24, 2011 9:59 AM
> To: [email-masked]; [email-masked]
> My point does not concern what kind of document can be conveyed in the
> presentation stream, but the fact that the use case assumes that the
> presentation stream is a _video_ presentation stream (i.e. presentation
> is coded using a video codec). The example of the excel doc aims to
> highlight that video coding is not convenient to the readability of
> such document.
> 
> A proposal is to use the wording "stream" or "presentation stream"
> instead of "video stream", "video presentation stream" or "presentation
> video" in the section 3.4, so that the use case is more agnostic to the
> solution.
> 
> Stephane.
> 
> Could you supply the text that you would like to have added? It would
> good to be very specific, rather than general, since that what the use
> cases are - the specific scenarios of interest to you.
> 
> Since xcel (over RTP) was your example, and as Mark said, it is
> currently covered, I'm not sure exactly what case you have in mind that
> is either not already covered or in scope for the current charter.
> 
> Thanks,
> Allyn
> 
> > > > I don't think that the kind of relationship that you suggest is
> the
> > > only solution.
> > >
> > > >> The point is that video stream is not convenient for the use
> cases
> > > >> I
> > > > whatever) to mediate the UI for the web collaboration, the
> roster,
> > > etc.
> > > >>>>> HTTP is not defining a common data sharing protocol. WebEx
> may
> > > >>>>> be
> > > >>>> carried
> > > >>>>> something that is carried as an RTP payload which require
> some
> > > common
> > > >>>>> defined protocol on top.
> > > >>>>
> > > >>>> out of date. Connecting the video port on a user's computer as
> a
> > > video
> > > >>>> It isn't entirely clear that its *necessary* to bundle the
> data
> > > sharing
> > > >>>>>> From: [email-masked] [mailto:[email-masked]]
> On
> > > Behalf
> > > >>>> Of
> > > >>>>>> Paul Kyzivat
> > > >>>>>>> *Furthermore, although most today's systems use video
> streams
> > > for
> > > >>>>>>> *- The professor which shares an electronic whiteboard
> (could
> > > be a