Subject: [COSE] Registering Brainpool curves for COSE

From: Mike Jones <[email-masked]>
Date: Tue, 3 Mar 2020 22:53:34 +0000

The working group ISO/IEC JTC 001/SC 17 "Cards and security devices for personal identification" Mobile Driver's License (mDL) specification uses the Brainpool curves defined in RFC 5639, M. Lochter et. al., Elliptic Curve Cryptography (ECC) Brainpool Standard Curves and Curve Generation, March 2010 with COSE.  Thus, it would like to have curve identifiers registered for them.  Specifically, these curves and intended registration information are:

brainpoolP256r1 RFC 5639 -65537 ECDH/ECDSA
brainpoolP320r1 RFC 5639 -65538 ECDH/ECDSA
brainpoolP384r1 RFC 5639 -65539 ECDH/ECDSA
brainpoolP512r1 RFC 5639 -65540 ECDH/ECDSA

Is the best way to register these curves to create an Internet Draft and submit it to the COSE working group or would you suggest another course to accomplish this?

                                                                Thanks,
                                                                -- Mike

---

From: Jim Schaad <[email-masked]>
Date: Tue, 3 Mar 2020 21:03:07 -0800

For myself, I do not believe that the IETF has any interest in the Brainpool
curves.   The different ways would be:

1.	Submit a document in the COSE WG - no something I would be
interested in
2.	Submit a document to the ISE - a reasonable way forward in my
opinion
3.	Just put the IANA registrations in to the ISO/ICE document and send
a request to IANA for registration - my preferred way forward.

Jim

From: COSE <[email-masked]> On Behalf Of Mike Jones
Sent: Tuesday, March 3, 2020 2:54 PM
To: [email-masked]
Cc: Anthony Nadalin <[email-masked]>
Subject: [COSE] Registering Brainpool curves for COSE

The working group ISO/IEC JTC 001/SC 17 "Cards and security devices for
personal identification" Mobile Driver's License (mDL) specification uses
the Brainpool curves defined in RFC 5639, M. Lochter et. al., Elliptic Curve
Cryptography (ECC) Brainpool Standard Curves and Curve Generation, March
2010 with COSE..  Thus, it would like to have curve identifiers registered
for them.  Specifically, these curves and intended registration information
are:

Is the best way to register these curves to create an Internet Draft and
submit it to the COSE working group or would you suggest another course to
accomplish this?

                                                                Thanks,

                                                                -- Mike

---

From: Mike Jones <[email-masked]>
Date: Wed, 4 Mar 2020 16:55:36 +0000

Thanks, Jim.  We'll go with route number 3 then.

                                                       -- Mike

From: Jim Schaad <[email-masked]>
Sent: Tuesday, March 3, 2020 9:03 PM
To: Mike Jones <[email-masked]>; [email-masked]
Cc: Anthony Nadalin <[email-masked]>
Subject: [EXTERNAL] RE: [COSE] Registering Brainpool curves for COSE

For myself, I do not believe that the IETF has any interest in the Brainpool curves.   The different ways would be:

  1.  Submit a document in the COSE WG - no something I would be interested in
  2.  Submit a document to the ISE - a reasonable way forward in my opinion
  3.  Just put the IANA registrations in to the ISO/ICE document and send a request to IANA for registration - my preferred way forward.

Jim

From: COSE <[email-masked]<mailto:[email-masked]>> On Behalf Of Mike Jones
Sent: Tuesday, March 3, 2020 2:54 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Anthony Nadalin <[email-masked]<mailto:[email-masked]>>
Subject: [COSE] Registering Brainpool curves for COSE

The working group ISO/IEC JTC 001/SC 17 "Cards and security devices for personal identification" Mobile Driver's License (mDL) specification uses the Brainpool curves defined in RFC 5639, M. Lochter et. al., Elliptic Curve Cryptography (ECC) Brainpool Standard Curves and Curve Generation, March 2010 with COSE..  Thus, it would like to have curve identifiers registered for them.  Specifically, these curves and intended registration information are:

                                                                Thanks,
                                                                -- Mike

---

From: Jim Schaad <[email-masked]>
Date: Wed, 4 Mar 2020 09:54:19 -0800

Just remember - IANA assigns numbers.   If you need a testing number before
IANA has done so, use a number less than -65536

From: Mike Jones <[email-masked]> 
Sent: Wednesday, March 4, 2020 8:56 AM
To: Jim Schaad <[email-masked]>; [email-masked]
Cc: Anthony Nadalin <[email-masked]>
Subject: RE: [EXTERNAL] RE: [COSE] Registering Brainpool curves for COSE

                                                       -- Mike

From: Jim Schaad <[email-masked] <mailto:[email-masked]> > 
Sent: Tuesday, March 3, 2020 9:03 PM
To: Mike Jones <[email-masked]
<mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]>

Cc: Anthony Nadalin <[email-masked] <mailto:[email-masked]> >
Subject: [EXTERNAL] RE: [COSE] Registering Brainpool curves for COSE

Jim

From: COSE <[email-masked] <mailto:[email-masked]> > On Behalf
Of Mike Jones
Sent: Tuesday, March 3, 2020 2:54 PM
To: [email-masked] <mailto:[email-masked]> 
Cc: Anthony Nadalin <[email-masked] <mailto:[email-masked]> >
Subject: [COSE] Registering Brainpool curves for COSE

                                                                Thanks,

                                                                -- Mike