Subject: [Crisp] comments on iris-dreg-05

From: David Blacka <[email-masked]>
Date: Fri, 2 Apr 2004 17:23:10 -0500

I've sent some language and clarification issues to the authors directly, but 
I also came up with something that could use wider group input:

In sections 3.1.3 and 3.1.4 (<findDomainsByName> and <findDomainsByIDNName>)  
there is both a <namePart> element containing (possibly) a <beginsWith> and 
<endsWith> element.  There is also a <baseDomain> element.  This led to the 
question about <endsWith>: do the contents of <endsWith> include the 
<baseDomain> or not?

If looking for "foo*bar.com", should you say:

  <baseDomain>com</baseDomain>
  <namePart>
    <beginsWith>foo</beginsWith>
    <endsWith>bar</endsWith>
  </namePart>

?  or is it <endsWith>bar.com</endsWith> ?  Wouldn't it have to be the latter 
if, for instance, <baseDomain> were not specified?

For simplicity's sake, my opinion is that <baseDomain> should be dropped.

<baseDomain> seems useful in the other queries in which it appears, though.

-- 
David Blacka    <[email-masked]> 
Sr. Engineer    Verisign Applied Research

_______________________________________________
Crisp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/crisp

---

From: Andrew Newton <[email-masked]>
Date: Sat, 3 Apr 2004 11:21:21 -0500

> <baseDomain> seems useful in the other queries in which it appears, 

This makes sense to me.  it's much clearer without it but no loss of 
functionality.

-andy

---

From: Andrew Newton <[email-masked]>
Date: Mon, 5 Apr 2004 15:29:58 -0400

This small change came in privately on Friday, and Marcos and I spent 
the weekend going through it:

There are some registries that do A and CNAME hosting as well as NS 
delegations.  There is a desire to have a <domain> object clearly 
specify this state.  The solution is to put an optional, boolean 
'hosting' attribute on the <registry> and <registrar> entity 
references.

Additionally, we found that the <delegationReference> entity reference 
is misnamed and should be <registrationReference>.

-andy