Subject: [Crisp] rreg draft

From: Nagahashi Kengo <[email-masked]>
Date: Mon, 27 Jun 2005 16:06:13 +0100

Hi,

We'll plan to submit revised rreg draft before ID cut-off.
Major changes in this draft is to add Motivation and Requirements.

Unlike areg and dreg, there is an argument which rreg does not well 
fit into iris framework. Our intention is to define requirements 
at first and then follow query/responce format on this requirements.

In this draft, it still remains query/responce but this might 
be better to remove it and define clear requiremens for routing registry.

any comments would be appreciate.

1.1 Motivation
  Our intention to apply  CRISP framework into Routing
  Registry is due to the current messy architecture 
  of routing registries.
  They  are scattered around the world but  neither hierarchical
  strcutre nor recursive look-up are 
  performed. This derives an inaccurate routing information
  in Routing Registry. 
  We have strong motivation to improve accuracy of the routing
  registries by introducing CRISP framework into routing registries.

  2 steps must be taken to improve the situation , (1) defines
  XML Schema for Routing Registry and (2)deploy CRISP enabled
  Routing Registry. 
  
  This document only focuses on the definition of XML schema for
  routing registries, and the deployment issues will be described
  in another document.

3. Requirements 
  
   Like other iris schema e.g. areg, dreg, routing registry should
   be defined XML schema which  comprises query and responce.

   The query and responce in routing registry is similer with 
   areg since main objective of routing registry is to manage
   prefix, autonomous system and contact information.
   
   The obvious difference with areg and rreg is that 
   rreg requries to handle routing policy schema 
   e.g. AS imports policy and exports policy.
   This routing policy schema is described by Routing Policy 
   Specification  Language (RPSL)[RPSL]. 
   Thus, rreg requires the routing policy handling defined 
   in RPSL.
   
   Since the routing registry are distributed without 
   strong relation, root resolution is a hard issue to solve. 
   One of straight forward solution is to decide the root 
   e.g. "rreg.nro.net" uniquely but it still requires to 
   discuss about it.

-kengo 

_______________________________________________
Crisp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/crisp

---

From: Andrew Newton <[email-masked]>
Date: Mon, 27 Jun 2005 11:56:42 -0400

Kengo,

As I observed the meeting and from my reading of the first version of  
the draft, it was hard to appreciate the difference between AREG and  
RREG.  My comments are inline:

>    Thus, rreg requires the routing policy handling defined

This is where you should probably concentrate your energy, in my  
opinion.  I was not able to determine how RREG was different from AREG.

If the difference really isn't in the type of data but instead of who  
is giving the data (a routing registry vs. an address registry), then  
this might need a little clarification.

>    e.g. "rreg.nro.net" uniquely but it still requires to

I would not worry about tackling this yet.
Just my 2 cents.

-andy

---

From: Nagahashi Kengo <[email-masked]>
Date: Mon, 27 Jun 2005 18:46:26 +0100

Andy,

thanks for your quick input.
Yes, we need to more concentrate policy stuff in RREG. 
1st step to concentrate is to clarify requirements for
what we should need for policy stuff in RREG.
Anyway we need to give detailed description for policy 
stuff.
thanks again.

-kengo

On Mon, 27 Jun 2005 11:56:42 -0400