Subject: Re: [Curdle] I-D Action: draft-ietf-curdle-pkix-01.txt

From: Deirdre Connolly <[email-masked]>
Date: Fri, 30 Sep 2016 18:08:55 +0000

Nit:

>  This document specify algorithm identifiers and ASN.1 encoding formats
for Elliptical Curve constructs...

'Elliptical' is not commonly used, 'elliptic' is more normative. 'Elliptic'
is used 7 times in the draft, this is the only usage of 'elliptical'.

On Fri, Aug 19, 2016 at 8:30 AM <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the CURves, Deprecating and a Little more
> Encryption of the IETF.
>
>         Title           : Algorithm Identifiers for Ed25519, Ed25519ph,
> Ed448, Ed448ph, X25519 and X448 for use in the Internet X.509 Public Key
> Infrastructure
>         Authors         : Simon Josefsson
>                           Jim Schaad
>         Filename        : draft-ietf-curdle-pkix-01.txt
>         Pages           : 15
>         Date            : 2016-08-15
>
> Abstract:
>    This document specify algorithm identifiers and ASN.1 encoding
>    formats for Elliptical Curve constructs using the Curve25519 and
>    Curve448 curves.  The signature algorithms covered are Ed25519,
>    Ed25519ph, Ed448 and Ed448ph.  The key agreement algorithm covered
>    are X25519 and X448.  The Encoding for Public Key, Private Key and
>    EdDSA digital signature structures is provided.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-curdle-pkix/
>
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-ietf-curdle-pkix-01
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-curdle-pkix-01
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle
>

---

From: Deirdre Connolly <[email-masked]>
Date: Fri, 30 Sep 2016 18:16:09 +0000

Another nit:

> This document specify algorithm identifiers

s/specify/specifies/

On Fri, Sep 30, 2016 at 2:08 PM Deirdre Connolly <[email-masked]>
wrote:

> 'Elliptical' is not commonly used, 'elliptic' is more normative.
> 'Elliptic' is used 7 times in the draft, this is the only usage of
> 'elliptical'.
>
>

---

From: Russ Housley <[email-masked]>
Date: Fri, 30 Sep 2016 14:24:00 -0400

Thanks for catching that mistake.  I’ll correct it.

Russ

On Sep 30, 2016, at 2:08 PM, Deirdre Connolly <[email-masked]> wrote:

> Nit: 
> 
> >  This document specify algorithm identifiers and ASN.1 encoding formats for Elliptical Curve constructs...
> 
> 'Elliptical' is not commonly used, 'elliptic' is more normative. 'Elliptic' is used 7 times in the draft, this is the only usage of 'elliptical'.
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the CURves, Deprecating and a Little more Encryption of the IETF.
> 
>         Title           : Algorithm Identifiers for Ed25519, Ed25519ph, Ed448, Ed448ph, X25519 and X448 for use in the Internet X.509 Public Key Infrastructure
> Please note that it may take a couple of minutes from the time of submission

---

From: Deirdre Connolly <[email-masked]>
Date: Fri, 30 Sep 2016 19:01:07 +0000

Thanks!