Subject: [Curdle] PKCS#11 solution

From: Jim Schaad <[email-masked]>
Date: Tue, 13 Sep 2016 13:51:17 -0700

I have written up a set of proposed edits that I think would address PKCS#11
for them to look at.  I plan to send this end at the end of the week, but
wanted to give anybody on the list who might want to comment to have a
chance to do so.  I could only improve what I am suggesting.

Jim

---

From: Russ Housley <[email-masked]>
Date: Wed, 14 Sep 2016 09:27:28 -0400

On Sep 13, 2016, at 4:51 PM, Jim Schaad <[email-masked]> wrote:

> <pkcs11.docx>

Jim:

With ECDH, how do you pick between ANSI-X9.63-KDF and HKDF for derivation of the KEK?

Russ

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 14 Sep 2016 11:19:55 -0400

>> chance to do so.  I could only improve what I am suggesting.

Do you mean to send to OASIS?

Thanks,
Kathleen

> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle

-- 

Best regards,
Kathleen

---

From: Jim Schaad <[email-masked]>
Date: Wed, 14 Sep 2016 08:46:47 -0700

> -----Original Message-----
> From: Kathleen Moriarty [mailto:[email-masked]]
> Sent: Wednesday, September 14, 2016 8:20 AM
> To: Russ Housley <[email-masked]>
> Cc: Jim Schaad <[email-masked]>; [email-masked]
> Subject: Re: [Curdle] PKCS#11 solution
> 
> >> I have written up a set of proposed edits that I think would address
> >> PKCS#11 for them to look at.  I plan to send this end at the end of
> >> the week, but wanted to give anybody on the list who might want to
> >> comment to have a chance to do so.  I could only improve what I am
> suggesting.
> 

Yes that is where I plan to send this at the end of the week.

Jim

---

From: Jim Schaad <[email-masked]>
Date: Wed, 14 Sep 2016 10:53:46 -0700

My first response is that this falls under the "not my problem" cloaking
device.  I was focusing on the issues dealing with how things work with the
draft that I am co-authoring and nothing else.

The real answer is that there needs to be some additional KDF functions
defined in section 2.3.8 of the current mechanism document for the new KDF
functions.  I will note this in the document.

Jim

> From: Russ Housley [mailto:[email-masked]]
> Sent: Wednesday, September 14, 2016 6:27 AM
> To: Jim Schaad <[email-masked]>
> Cc: [email-masked]