Subject: [Curdle] [Editorial Errata Reported] RFC8270 (5501)

From: RFC Errata System <[email-masked]>
Date: Fri, 21 Sep 2018 13:33:39 -0700 (PDT)

The following errata report has been submitted for RFC8270,
"Increase the Secure Shell Minimum Recommended Diffie-Hellman Modulus Size to 2048 Bits".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5501

--------------------------------------
Type: Editorial
Reported by: Eugene Adell <[email-masked]>

Section: 3

Original Text
-------------
[RFC4419] specifies a recommended minimum size of 1024 bits for k,
   which is the modulus length of the DH group.  It also suggests that,
   in all cases, the size of the group needs be at least 1024 bits.

Corrected Text
--------------
[RFC4419] specifies a recommended minimum size of 1024 bits for k,
   which is the modulus length of the DH group.  It also suggests that,
   in all cases, the size of the group needs to be at least 1024 bits.

Notes
-----
small typo

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8270 (draft-ietf-curdle-ssh-dh-group-exchange-06)
--------------------------------------
Title               : Increase the Secure Shell Minimum Recommended Diffie-Hellman Modulus Size to 2048 Bits
Publication Date    : December 2017
Author(s)           : L. Velvindron, M. Baushke
Category            : PROPOSED STANDARD
Source              : CURves, Deprecating and a Little more Encryption
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Sean Turner <[email-masked]>
Date: Sun, 23 Sep 2018 17:36:30 -0400

Definitely a candidate for HFDU (Hold For Document Update).

spt

> On Sep 21, 2018, at 16:33, RFC Errata System <[email-masked]> wrote:
> 
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle

---

From: Daniel Migault <[email-masked]>
Date: Mon, 24 Sep 2018 00:53:47 +0000

Took me some time to find it. This is really a nit, but definitively not a crucial one. 
Yours, 
Daniel

-----Original Message-----
From: Sean Turner <[email-masked]> 
Sent: Sunday, September 23, 2018 5:37 PM
To: Eric Rescorla <[email-masked]>
Cc: [email-masked]; [email-masked]; Daniel Migault <[email-masked]>; Rich Salz <[email-masked]>; [email-masked]; [email-masked]; Benjamin Kaduk <[email-masked]>
Subject: Re: [Curdle] [Editorial Errata Reported] RFC8270 (5501)

spt

> The following errata report has been submitted for RFC8270, "Increase 
> the Secure Shell Minimum Recommended Diffie-Hellman Modulus Size to 2048 Bits".
> 
> use "Reply All" to discuss whether it should be verified or rejected. 
> When a decision is reached, the verifying party can log in to change 
> the status and edit the report, if necessary.
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 23 Sep 2018 19:55:24 -0500

I added some clarifying text to the "Note" when verifying, that would
hopefully make the change easier to find.

-Ben